Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Do I need a CUE card for B-ADC feature?

hi all!

I intend to use TCL-Script for Basic ADC feature, so do I need a CUE card?

I have tried to configure the B-ADC TCL script in router Cisc 3745 without CUE card, but when I dialed to the pilot number, I hear nothing.

Thanks

4 REPLIES
Hall of Fame Super Gold

Re: Do I need a CUE card for B-ADC feature?

CUE is not needed for TCL IVR B-ACD.

Likely misconfiguration. Post your config.

New Member

Re: Do I need a CUE card for B-ADC feature?

Thank for support.

THis is my configuration in testing environment.

+ IOS AdvancedEnterprise 12.4

+Pilot number = 200

+only one IP phone connect directly to router

+when testing, I use this IP Phone dial to pilot number

--------Sh run---------------

Building configuration...

Current configuration : 2330 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool test

!

ip dhcp pool ITS

network 172.16.0.0 255.255.255.0

option 150 ip 172.16.0.1

default-router 172.16.0.1

!

!

!

multilink bundle-name authenticated

!

!

!

application

service aa flash:app-b-acd-aa-2.1.2.2.tcl

param welcomee-prompt asd

paramspace english index 1

paramspace english language en

param number-of-hunt-grps 2

paramspace english location flash:

param voice-mail 500

param handoff-string aa

param dial-by-extension-option 5

param welcome-prompt _bacd_welcome.au

param service-name queue

param aa-pilot 200

!

service adc_basic flash:

!

service queue flash:app-b-acd-2.1.2.2.tcl

param aa-hunt3 200

param queue-len 10

param number-of-hunt-grps 2

param queue-manager-debugs 1

!

!

!

!

!

!

username admin secret 5 $1$DFcI$rTviSFbNz5pc4V4it.euN.

!

!

!

!

!

!

!

interface Loopback0

ip address 192.168.0.1 255.255.255.0

!

interface FastEthernet0/0

ip address 172.16.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

!

ip http server

ip http authentication local

no ip http secure-server

ip http path flash:

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

dial-peer voice 200 voip

service aa

destination-pattern 200

session target ipv4:192.168.0.1

incoming called-number 200

dtmf-relay h245-alphanumeric

!

!

!

!

telephony-service

max-ephones 3

max-dn 3

ip source-address 172.16.0.1 port 2000

auto assign 1 to 3

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn 1

number 201

!

!

ephone-dn 2

number 202

!

!

ephone-dn 3

number 203

!

!

ephone 1

no multicast-moh

device-security-mode none

mac-address 0019.2F5E.DB22

type 7940

button 1:1

!

!

!

ephone 2

no multicast-moh

device-security-mode none

!

!

!

ephone 3

no multicast-moh

device-security-mode none

!

!

ephone-hunt 1 longest-idle

pilot 200

list 201, 202, 203

timeout 10, 10, 10

statistics collect

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

-----------sh flash---

System CompactFlash directory:

File Length Name/status

1 18836 app-b-acd-2.1.2.2-ReadMe.txt

2 24985 app-b-acd-2.1.2.2.tcl

3 35485 app-b-acd-aa-2.1.2.2.tcl

4 75650 en_bacd_allagentsbusy.au

5 83291 en_bacd_disconnect.au

6 63055 en_bacd_enter_dest.au

7 37952 en_bacd_invalidoption.au

8 496521 en_bacd_music_on_hold.au

9 123446 en_bacd_options_menu.au

10 42978 en_bacd_welcome.au

11 34794 en_bacd_xferto_operator.au

[1037716 bytes used, 15739496 available, 16777212 total]

16384K bytes of ATA System CompactFlash (Read/Write)

Hall of Fame Super Gold

Re: Do I need a CUE card for B-ADC feature?

Hello ngocgl,

Please add "codec g711ulaw" to dial-peer 200.

Don't forget to rate useful posts :)

New Member

Re: Do I need a CUE card for B-ADC feature?

Thanks for quickly reply.

I have rated for this post :)

119
Views
9
Helpful
4
Replies
CreatePlease login to create content