Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DTMF not recognized on connected call

I am not getting any DTMF accptance when I call into an IVR and asked to make a selection 1-9 ect...

ITSP ---->(SIP)  CUBE  --->(H323)  CUCM

pbxguy_router#sho run

Building configuration...

Current configuration : 8466 bytes

!

! Last configuration change at 23:31:47 UTC Wed Dec 11 2013 by scott

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname pbxguy_router

!

boot-start-marker

boot system flash c3825-adventerprisek9-mz.151-4.M7.bin

boot-end-marker

!

!

no logging buffered

enable secret 5 $1$jLw/$mT4zlcPRsWnipVZ0aHnBA0

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login sslvpn local

aaa authorization exec default local

!

!

!

!

!

aaa session-id common

!

!

dot11 syslog

ip source-route

!

ip cef

!

!

!

!

ip domain name pbxguy.com

ip name-server 8.8.8.8

no ipv6 cef

!

multilink bundle-name authenticated

!        

stcapp ccm-group 1

stcapp

!

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

ip address trusted list

  ipv4 0.0.0.0 0.0.0.0

no ip address trusted authenticate

media flow-around

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

  early-offer forced

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

!

!

!

!

voice translation-rule 1

rule 1 /4029881010/ /1010/

!

voice translation-rule 2

rule 2 /335201/ /1010/

!

!

voice translation-profile INCOMING

translate called 1

!

voice translation-profile TempIncoming

translate called 2

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1860214740

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1860214740

revocation-check none

rsakeypair TP-self-signed-1860214740

!

!

crypto pki certificate chain TP-self-signed-1860214740

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31383630 32313437 3430301E 170D3133 31303235 31353434

  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38363032

  31343734 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81009C49 FF6C8071 A0CF9255 70366C11 EDEDE473 013AC5E8 E26B8F1B 5B4FB0CE

  B801F441 67439BC7 2A251DD5 708A7A35 128E2DFC 861D23F4 18A23EF0 6AC87CB3

  C3F03C47 4285FC3E A043A66B 1232F885 3597F6D6 E98B5E3D 86902237 A3483ED5

  17E5B804 A478EAB3 D00D3DEA 68D13EAE 6D9552F3 780E6CB8 B329EEDD 255A22E4

  A7610203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 140840B0 1EF7F1E2 1A8CA935 431D067E 57B6C46F 37301D06

  03551D0E 04160414 0840B01E F7F1E21A 8CA93543 1D067E57 B6C46F37 300D0609

  2A864886 F70D0101 05050003 8181005D 03A541D5 9B3C206E 8BC2E4A3 B00017FE

  EC0A4806 5B5E2F3E 67CCDAC9 D11AD33D BD44989F 295E784D E4CF39AC 2E21A2B5

  FFAC5171 1372DD0B 764DD3C0 E4088CB7 01D5D4E2 4CA0C955 25F4FF2E 75C3D740

  399F67B5 9160F8F4 59206DDC 8392D4B7 47B8E683 220E06BD 2964EBA4 5B57BC98

  D623EFC5 399AA46D 6E591D52 45233C

            quit

!

!

license udi pid CISCO3825 sn FTX1239A28R

license accept end user agreement

archive

log config

  hidekeys

username scott privilege 15 secret 5 $1$Y4nT$1neWA5OmFc/IAvSfA4dB11

!

redundancy

!

!

ip ssh version 2

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1.40

encapsulation dot1Q 40

ip address 10.10.10.1 255.255.255.252

ip nat inside

ip virtual-reassembly in

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.10.1

!

!

router eigrp 10

network 10.10.10.1 0.0.0.0

!

ip local pool webvpn-pool 10.20.30.10 10.20.30.15

ip forward-protocol nd

ip http server

ip http secure-server

!

!

ip nat inside source list 1 interface GigabitEthernet0/0 overload

ip nat inside source static udp 192.168.192.3 3074 interface GigabitEthernet0/0 3074

ip nat inside source static udp 192.168.192.3 88 interface GigabitEthernet0/0 88

ip nat inside source static tcp 192.168.192.3 53 interface GigabitEthernet0/0 53

ip nat inside source static udp 192.168.192.3 53 interface GigabitEthernet0/0 53

ip nat inside source static tcp 192.168.192.3 80 interface GigabitEthernet0/0 80

ip nat inside source static tcp 192.168.192.3 3074 interface GigabitEthernet0/0 3074

ip nat inside source static tcp 192.168.254.10 5060 interface GigabitEthernet0/0 5060

ip nat inside source static udp 192.168.254.10 5060 interface GigabitEthernet0/0 5060

!

ip access-list extended inbound

permit udp any any eq 3074

permit udp any eq 88 any

permit tcp any any eq 3074

permit tcp any any eq domain

permit udp any any eq domain

permit tcp any any eq www

permit tcp any any eq 5060

permit udp any any eq 5060

!

access-list 1 permit 208.110.65.18

access-list 1 permit 192.168.192.0 0.0.0.255

access-list 1 permit 192.168.128.0 0.0.0.31

access-list 1 permit 10.20.30.0 0.0.0.255

access-list 1 permit 192.168.254.0 0.0.0.255

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 192.168.254.10 identifier 1 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register confLab

associate profile 2 register xcodeLab

associate profile 3 register mtpLab

!

dspfarm profile 2 transcode 

codec g729r8

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 9

associate application SCCP

!

dspfarm profile 1 conference 

codec g711ulaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 1

associate application SCCP

!

dspfarm profile 3 mtp 

codec g711ulaw

maximum sessions hardware 12

maximum sessions software 200

associate application SCCP

!

dial-peer voice 1 voip

incoming called-number .

voice-class codec 1 

dtmf-relay rtp-nte h245-signal h245-alphanumeric

no vad

!

dial-peer voice 2 voip

destination-pattern 4029881010

session target ipv4:192.168.254.10

voice-class codec 1 

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 4 voip

destination-pattern 1[2-9]..[2-9]......

session protocol sipv2

session target sip-server

session transport udp

no voice-class sip early-offer forced

dtmf-relay rtp-nte

no dtmf-interworking

codec g711ulaw

no vad

no supplementary-service sip refer

!

dial-peer voice 5 voip

destination-pattern [2-9]..[2-9]......

session protocol sipv2

session target sip-server

voice-class codec 1 

dtmf-relay rtp-nte

no vad

!

!

sip-ua

credentials username 335201 password 7 03570B58505E771C165D40 realm sip-ua.com

authentication username 335201 password 7 075C711F18584F554F4652 realm sip-ua.com

registrar dns:proxy.sip-ua.com expires 60

sip-server dns:proxy.sip-ua.com

!

!

!        

!

line con 0

line aux 0

line vty 0 4

exec-timeout 40 0

privilege level 15

password cisco

transport input ssh

!

scheduler allocate 20000 1000

!

webvpn gateway Cisco-WebVPN-Gateway

ip address 174.71.48.163 port 443 

ssl encryption rc4-md5

ssl trustpoint TP-self-signed-1860214740

logging enable

inservice

!

webvpn gateway webvpn

ssl trustpoint TP-self-signed-1860214740

no inservice

!

webvpn install svc flash:/webvpn/anyconnect-win-3.0.11042-k9.pkg sequence 1

!

webvpn install svc flash:/webvpn/anyconnect-macosx-i386-3.1.04072-k9.pkg sequence 2

!

webvpn context Cisc0-WebVPN

ssl authenticate verify all

!

!

policy group webvpnpolicy

   functions svc-enabled

no inservice

!

!

webvpn context Cisco-WebVPN

title "Scott Glenn Private Network, Authorized Users Only"

ssl authenticate verify all

!

url-list "rewrite"

!

acl "ssl-acl"

   permit ip 10.20.30.0 255.255.255.0 192.168.192.0 255.255.255.0

   permit ip 10.20.30.0 255.255.255.0 192.168.254.0 255.255.255.0

   permit ip 10.20.30.0 255.255.255.0 10.10.10.0 255.255.255.0

!

login-message "Cisco Secure WebVPN"

!

policy group webvpnpolicy

   functions svc-enabled

   svc address-pool "webvpn-pool" netmask 255.255.255.0

   svc rekey method new-tunnel

   svc split include 10.20.30.0 255.255.255.0

   svc split include 192.168.192.0 255.255.255.0

   svc split include 192.168.254.0 255.255.255.0

   svc split include 10.10.10.0 255.255.255.0

default-group-policy webvpnpolicy

aaa authentication list sslvpn

gateway Cisco-WebVPN-Gateway

max-users 2

inservice

!

end

7 REPLIES
New Member

DTMF not recognized on connected call

Please attach the following debugs from the CUBE

Debug voice ccapi inout

Debug cssip messages

Also for start if the Codec on the leg with the CUCM is G711ulaw, we can invoke Call manager(Software ) MTP on the sip trunk. If using G729 we need Hardware MTP

VIP Super Bronze

DTMF not recognized on connected call

Looking at your config,

1. your inboun dial-peer has been wrongly configured.. This dial-peer is used for routing calls from both your ITSP and CUCM. The problem with this is that one leg is SIP and the other is h323...This dial-peer is h323 dial-peer and it has rtp-nte as the primary dtmf method..This is not a good practice

dial-peer voice 1 voip

incoming called-number .

voice-class codec 1 

dtmf-relay rtp-nte h245-signal h245-alphanumeric

no vad

2. You will need to create two different inbound dial-peers and apply the correct dtmf method to them..

eg

dial-peer voice 1 voip

incoming called number XXXXXXX (where XXXXX= called number from ITSP)

session protocol sipv2

no vad

voice-class codec 1

dtmf-relay rtp-nte digit-drop

dial-peer voice 2 voip

incoming called number YYYYY, where YYYY=called number from cucm

dtmf-relay h245-alpha

no vad

voice-class codec 1

NB: You should use the digit drop key word so that DTMF are passed out of band on the sip leg hence preventing a need for MTP

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

DTMF not recognized on connected call

It appears that I am getting back the following messge when I call into a TFN and try to press option "1":

*Dec 16 14:58:48.604: //20386/xxxxxxxxxxxx/CCAPI/ccCallModifyExtended:

   Nominator=0x716C46E8, Params=0x716C46C0, Call Id=20386

*Dec 16 14:58:48.604: //20387/xxxxxxxxxxxx/CCAPI/ccCallModifyExtended:

   Nominator=0x716C46E8, Params=0x716C46C0, Call Id=20387

*Dec 16 14:58:48.604: //20387/xxxxxxxxxxxx/CCAPI/ccCallModifyExtended:

   Nominator=0x716C46E8, Params=0x716C46C0, Call Id=20387

*Dec 16 14:58:48.664: //20386/xxxxxxxxxxxx/CCAPI/ccCallModify:

   Nominator=0x18E00, Params=0x716C4A50, Call Id=20386

*Dec 16 14:58:48.668: //20386/xxxxxxxxxxxx/CCAPI/cc_api_call_modify_done:

   Result=0, Interface=0x6A030830, Call Id=20386

*Dec 16 14:58:48.668: //20386/xxxxxxxxxxxx/CCAPI/ccCallModifyExtended:

   Nominator=0x716C46E8, Params=0x716C46C0, Call Id=20386

*Dec 16 14:59:01.148: //20384/8008FC7E1300/CCAPI/cc_api_call_digit_begin:

   Consume mask is not set. Relaying Digit 1 to dstCallId 0x4FA1

*Dec 16 14:59:01.148: //20384/8008FC7E1300/CCAPI/cc_relay_digit_begin_for_3way_conference:

   Check DTMF relay digit begin for 3way conf

*Dec 16 14:59:01.148: //20384/8008FC7E1300/CCAPI/cc_api_call_digit_end:

   Consume mask is not set. Relaying Digit 1 to dstCallId 0x4FA1

*Dec 16 14:59:01.148: //20384/8008FC7E1300/CCAPI/cc_relay_digit_end_for_3way_conference:

   Check DTMF relay digit end for 3way conf

*Dec 16 14:59:11.280: //20386/xxxxxxxxxxxx/CCAPI/ccCallModify:

   Nominator=0x800, Params=0x716C4A98, Call Id=20386

VIP Super Bronze

DTMF not recognized on connected call

Have you made the changes I suggested..??

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

DTMF not recognized on connected call

I made the changes and there was no change in the outcome.  Still no digits are recognized when calling into menus.

VIP Super Bronze

Re: DTMF not recognized on connected call

Scoot,

Please send us the ff:

1. sh run

2. debug voip ccapi inout

3.debug ccsip messages

4. debug voip rtp session named-event

5. debug h245 asn1

Please collect the logs in one file and attach here

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: DTMF not recognized on connected call

I have attached the following in one file.

show run

debug voip ccapi inout

debug ccsip message

debug voip rtp session named-event

debug h245 asn1

1040
Views
0
Helpful
7
Replies
CreatePlease login to create content