Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DX650 No Display

Hi,

I am facing issue with a new DX650 Phone. When I connect the PoE power the Phone does not boot and it doesn't show anything on the display.

Attached snapshot of the DX650.

Thanks.

BR

Haris Shuja

Everyone's tags (1)
3 REPLIES

HelloCheck POE switch1- Can

Hello

Check POE switch

1- Can you connect one of your Cisco IP phones which work well with same port which you use for DX650.

 

Check UTP cable

1-Check to replace the cable with new one

 

Check switch logs

2- Kindly check logs after you plug your Cisco IP phone  to check the power . use the below

switch(conf)#logging console  " if you logging as console".

or

switch#terminal monitor  " if you logging as telnet or ssh"

 

Thanks

please rate all useful information

 

Community Member

Thank you for your response.-

Thank you for your response.

- I have other DX650 which are working perfectly on the same switch and port.

- Already used multiple cables.

- The DX650 isn't powering on properly.

- When I do show cdp neighbor, it is not being discovered.

- When I do show power inline it is taking 15.4 W when it actually should take 13.7.

- There are no messages on Console except for port up / down and poe.

 

Thanks.

Hilast test , if you have

Hi

last test , if you have external charger try to connect it to your IP Phone?. If you still have the problem , you have to do RMA for this IP phone back to cisco to replace it with new one.

 

 

Thanks 

please rate all useful information

159
Views
0
Helpful
3
Replies
CreatePlease to create content