Cisco Support Community
Community Member

E1 Controller LAYER 1 Status DEACTIVATED


I've recently been having trouble with my E1 PRI line. The controller interface is constantly getting deactivated and after a "shut, no shut" the ISDN status turns into SHUTDOWN and after that it just won’t come up. The only TEMOPORARY solution is to reboot my 2911 VSEC GW and only after that the line becomes ACTIVE and works fine. When I issue the Loopback Diag command the e1 controller interface becomes ACTIVE  but when i remove the loopback command the interface goes down and I receive a RAI error log. I also tried changing the cable just in case but still no luck.

The line used to work fine for over a year (with no interruptions) until this problem came along.

Is this a hardware issue or it can also be a protocol mismatch between my gateway and TELCO ?

I would really appreciate the communities help on this matter.

Best regard,

Visar Shllaku


E1 Controller LAYER 1 Status DEACTIVATED

Hi Visar,

you can try using the second E1 port on router,if available.

as far as RAI[remote alarm indiacation] is coming, this would be Telco issue.

Since this has been working media, chances of config change would be less.Ask Telco to check the media using BERT .



E1 Controller LAYER 1 Status DEACTIVATED

Hi Visar.

As Aman correctly stated (+5P) , this could be only a Provider Issue, since you tried to substitute the cable and you receive a RAI. Another test is to power cycle the Provider device and see if it make the difference.



Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
Community Member

E1 Controller LAYER 1 Status DEACTIVATED

Hi Aman,

I’ve been having this issue for a while now and I’ve tried almost everything but no luck (also tried power cycling the Telco Device as you advised).

I  also tried changing the E1 card (used a brand new one but still the same behavior). The only thing left is to try using another router but it doesn’t make any sense!!!

Today I was browsing some Cisco documentation and a read that clearing the isdn serial interface might do the trick so I issued the following command: clear interface serial 0/0/0:15 and the line immediately came up (did not power cycle the router) but I’m guessing that tomorrow I will face the problem again.

What does this command do exactly? Does it reset the interface completely and it starts to renegotiate the protocols with the TELCO device ? Also is there some command that it will automatically clear the interface as soon as the status of the interface is LAYER 1 deactivated ?

Any ideas since I’m really struggling here.

Thank you guys in advance.

E1 Controller LAYER 1 Status DEACTIVATED

Hi Visar,

After changing E1 card and cable from your end and if still you are receiving RAI then the possibility of remote end issue is more.

First step to check from your end for RAI:-

Receive Remote Alarm Indication

A Remote Alarm Indication (RAI) means that the far-end equipment has a problem with the signal it is receiving from the local equipment.

The RAI failure is declared when the A-bit (bit three in timeslot zero of frames not containing Frame Alignment Signal [FAS]) becomes one (1). The RAI failure is not declared when a Loss of Signal (LoS) or LoF is detected.

To correct rxRAI errors, complete these steps:

  1. Insert an external loopback cable into the port.For more information, see the Hard Plug Loopback Tests for E1 Lines document.
  2. Issue the show controller e1 EXEC command to determine if any alarms occur.If you do not find any alarms, then the local hardware is probably in good condition. In that case, complete these steps:
    1. Check the cabling. Ensure that you have correctly connected the cable between the interface port and the E1 service provider equipment or E1 terminal equipment. Ensure that you have connected the cable to the correct ports. Correct the cable connections if necessary.
    2. Check the cable integrity by looking for breaks or other physical abnormalities in the cable. Ensure the pinouts are set correctly. Replace the cable if necessary.
    3. Check the settings at the remote end and verify that they match your port settings.If the problem persists, contact your service provider.
  3. Remove the loopback plug, and reconnect your E1 line.
  4. Check the cabling.
  5. Power cycle the router.
  6. Connect the E1 line to a different port. Configure the port with the same settings as the line.If the problem does not persist, then the fault lies with the port. In this case, complete the following steps:
    1. Reconnect the E1 line to the original port.
    2. Perform a hardware loop test. For more information, see the Hard Plug Loopback Tests for E1 Lines document.

After performing above steps if the issue still persists then you can ask TELCO to change there port. Possibiltity is that from there end, port may be fluctuating frequently.

Nishant Savalia

Regards, Nishant Savalia

E1 Controller LAYER 1 Status DEACTIVATED

Hi Visar,

DO you have any device connected between router and E1 coming from Telco like modem?

can u explain a little bit.



CreatePlease to create content