Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

E1 is UP, but not working

Hello Everyone,

I am having a bad time configuring a E1. Eveything seems to be fine and up, but i cannot get to make a phone call. My telco says everything is fine on their side, but I get this results on the E1 controller:

R_POTOSI#show controllers e1

E1 0/0/0 is up.

Applique type is Channelized E1 - balanced

No alarms detected.

alarm-trigger is not set

Version info FPGA Rev: 08121917, FPGA Type: PRK1

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

International Bit: 1, National Bits: 11111

Data in current interval (195 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 5 15 minute intervals):

23 Line Code Violations, 287 Path Code Violations,

3 Slip Secs, 0 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins,

4 Errored Secs, 9 Bursty Err Secs, 0 Severely Err Secs, 1680 Unavail Secs

I read that the Line Code and Path Code Violations are due to physical line problems, but they say that everything is OK since the E1 is UP. Are they right? If not, how can I prove them wrong.

Thanks in advance for the help

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

E1 is UP, but not working

   Cause i = 0x828100000000 - Unallocated/unassigned number

tells you the dialed number is invalid.

Chris

13 REPLIES
Hall of Fame Super Silver

E1 is UP, but not working

Post your config of the controller.

Chris

E1 is UP, but not working

Hi Chris, this what I'v got configured:

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

Hall of Fame Super Silver

E1 is UP, but not working

Is this a pri circuit?  Can you post "sh isdn status"?

Since you are using MGCP do you have MGCP configured on the GW and in CUCM?

Chris

E1 is UP, but not working

Yes, this is a PRI circuit. MGCP is properly configured on CUCM. I have a couple of FXOs that are working just fine.

Router#show isdn status

Global ISDN Switchtype = primary-net5

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:15 interface

        dsl 0, interface ISDN Switchtype = primary-net5

        L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask: 0xFFFF7FFF

    Number of L2 Discards = 0, L2 Session ID = 28

    Total Allocated ISDN CCBs = 0

Bruno

Hall of Fame Super Silver

E1 is UP, but not working

Cool, can you get "debug isdn q931" for the failed call?

Chris

E1 is UP, but not working

I've got the debug Chris:

//70/CCB6379E8021/CCAPI/cc_api_call_report_digits_done:

   (vdbPtr=0x23B93650, callID=0x46, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)

001707: Jul 11 23:09:40.750: //70/CCB6379E8021/CCAPI/cc_api_call_report_digits_done:

   Enabled=TRUE, Disposition=0x0, Interface=0x23B93650, Call Id=70

001708: Jul 11 23:09:40.750: //70/CCB6379E8021/CCAPI/cc_api_call_report_digits_done:

   Call Entry(Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms))

001709: Jul 11 23:09:40.754: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0007

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

        Calling Party Number i = 0x0081, '0500'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '6228444'

                Plan:Unknown, Type:Unknown

001710: Jul 11 23:09:40.838: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x8007

        Channel ID i = 0xA9839F

                Exclusive, Channel 31

001711: Jul 11 23:09:40.846: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x8007

        Cause i = 0x828100000000 - Unallocated/unassigned number

001712: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/ccCallReportDigits:

   (callID=0x46, digit_event=0x0, enable=FALSE, consume=FALSE)

001713: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/ccCallReportDigits:

   Enabled=TRUE, Call Id=70

001714: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/cc_api_call_report_digits_done:

   (vdbPtr=0x23B93650, callID=0x46, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)

001715: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/cc_api_call_report_digits_done:

   Enabled=TRUE, Disposition=0x0, Interface=0x23B93650, Call Id=70

001716: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/cc_api_call_report_digits_done:

   Call Entry(Initial Digit Timeout=4000(ms), Inter Digit Timeout=4000(ms))

001717: Jul 11 23:09:40.934: //71/CCB6379E8021/CCAPI/ccGetCallStatistics:

   Call Stats=0x210B3B58, Call Id=71

001718: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/ccConferenceDestroy:

   Conference Id=0x1D, Tag=0x0

001719: Jul 11 23:09:40.934: //70/CCB6379E8021/CCAPI/ccConferenceDestroy:

001720: Jul 11 23:09:40.934: confID:0x1D; callEntry1 callID1:0x46, type:6; callEntry2 callID2:0x47, type:9

Thanks for the help

Green

E1 is UP, but not working

Bruno,

The status and config look correct

debug isdn q931 and make a test call

post the output of the debug

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

E1 is UP, but not working

Hello Alex, I've just posted the debug output on the question above.

The calling number is 0500 (that is actually translated to 2611-0500), and the called number is 6228444.

Bruno

Hall of Fame Super Silver

E1 is UP, but not working

   Cause i = 0x828100000000 - Unallocated/unassigned number

tells you the dialed number is invalid.

Chris

E1 is UP, but not working

Chris, is this because there's something missing on my config or because the Telco is missing something?

Hall of Fame Super Silver

E1 is UP, but not working

Is this in inboud or outboudn call?

Chris

E1 is UP, but not working

Hello Chris, this is and outbound call.

Bruno

E1 is UP, but not working

My problem has been solved. The Telco has corrected something, they wouldn't say what was it.

Anyway, thanks for the help Chris and Alex.

Bruno

266
Views
0
Helpful
13
Replies
CreatePlease login to create content