Cisco Support Community
Community Member

EMCC - Failed Login

Hi Support Community

I have configured EMCC between 2 clusters but users cannot login and they recieve error ' Login is Unavailable ( 23 ) Login Unnsuccesful , this indicates from the documentation that the device is not supported however i am using 8961's and i have verified these support EMCC ( see below ) ;

  • user ID's have been enabled with EMCC and they are unique in each cluster ( local extension mobility works fine )
  • EMCC is enabled on both clusters and i can see the remote cluster as activated in the Remote Cluster Service Configuration
  • All other information is correct to the best of my knowledge - Trunk, Inter Cluster Service Profile, EMCC Feature Configuration

Please see logs, i am not sure what these are indictaing, i can see that the user emccremote does not exist in this cluster which is correct as it exists in the remote cluster but then on the last error log it tells me Error Processing EMCC request : Userid not exist in this cluster, now is this telling me it has checked the remote cluster and the userID doesnt exist there, if this is the case i can confirm that the userID does exist and works with local extension mobility in the remote cluster. I also cant see any logs on the remote cluster regarding this EMCC login attemt.

2013-10-17 15:06:40,626 INFO [http-8443-3 ] EMServiceServlet - 25 findHomeCluster: Finding Home Cluster for User: emccremote

2013-10-17 15:06:40,627 ERROR [http-8443-3 ] EMServiceServlet - 25: Userid not exist in this cluster

2013-10-17 15:06:40,627 INFO [http-8443-3 ] EMServiceServlet - 25: EmccRequest Processing Time: 17

2013-10-17 15:06:40,627 ERROR [http-8443-3 ] EMServiceServlet - 25: Error processing EMCC request :Userid not exist in this cluster

Any help is appreciated.

Thanks, Carl

Community Member

EMCC - Failed Login

Hi Carl,

I have a few questions.

What is the CUCM version?

are you able to see the phone supports EMCC on the unified reporting?

Has EMCC ever worked before?

form this set of the traces looks like the request is unable to reach the home cluster.

Pls check the traces at the home cluster and to me it looks like a config issue. Pls check if EMCC etc is enabled.


Community Member

EMCC - Failed Login


The versions of CUCM are 8.0.3 and 8.6.2, i have however used in a lab environment 8.6.2 for both clusters to test if it was the CUCM versions not being able to speak to each other but i get the same issue.

I have checked and the phones are supported, iv actually tried 2 different models, Cisco 7962 and Cisco 8961.

EMCC has never been working it is a first time setup, i have followed this document line for line and doubled checked config and all seems ok. i can also see that both clusters can see the remote EMCC cluster.

I have checkd the home cluster of the user ID and the request never gets this far, the last log each time is the below which indicates its recieved the request then errors, it states userid does not exist in this cluster, which is correct as its a unique userid that exists in the other cluster.

2013-10-17 15:06:40,627 ERROR [http-8443-3 ] EMServiceServlet - 25: Error processing EMCC request :Userid not exist in this cluster

Thanks, Carl Ratcliffe

Community Member

EMCC - Failed Login

I am not sure which logs did you check at the home cluster. But if you checked the EMApp logs on the home cluster and you are not seing any request then it simply means that the integration is not working.

Here is a good link for EMCC config:

Make sure under Intercluster Service Profile you have EMCC as active and correct trunk selected. And under Remote Cluster Service Configuration  try disabling the service and then enabling it. You can also use the update button

If still every thing looks correct try rehosting the certs and reseting the SIP trunk.



CreatePlease to create content