Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

End User Directory search CUCM 8.6

Hi,

My customer has a Call Manager 4.1(3) cluster and previously used the following URL to view the Corporate Directory End Users configured on the system:

https://172.16.1.1/ccmuser/directory.asp

The customer created several hundred End User accounts with offnet numbers for their external customers. Staff could then use the above URL with Cisco Web Dialer to initiate a call to customers.

We are about to migrate the customer on to CUCM 8.6 and have found the above URL is no longer valid.

As an alternativer the customer can log in to their End User accounts and view the directory from the following URL:

https://172.16.1.1/ccmuser/directoryUserFindList.do

What we have found is that only the valid CUCM extensions appear as dialable links in the directory, all of the offnet numbers aren't displaying as an Ext.

I know LDAP integration is the way to resolve this but the customer is reluctant to configure hundreds of new accounts for all of the external clients.

Is there any other solution?

Regards,

Mark

1 ACCEPTED SOLUTION

Accepted Solutions

End User Directory search CUCM 8.6

Mark,

I don't have CUCM 8.6 but just tested this on my lab system and I found that if I created a user and configured an extension on the "Telephone Number" parameter, that number and the user are displayed in the directory listing. They also appear as dialable links.

Can you provide more specifics on your symptoms? Can you check your users to ensure you have created the appropriate values in the "Telephone Number" field of the enduser object?

Oh, BTW my "off net users" display the telephone number value under the "LDAP Ext" column (though I am NOT LDAP integrated on the CUCM system I tested).

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

7 REPLIES
New Member

End User Directory search CUCM 8.6

Mark,

Yes there is a solution - a purchase of a 3rd party product, such as 2Ring IPPS (IP Phone Services) - please have a look at it here: http://www.slideshare.net/2Ring/2ring-ipps-ip-phone-services-for-cisco-ip-telephony or even request a free demo here: http://www.2Ring.com/newjuice

Michal

New Member

End User Directory search CUCM 8.6

Thanks for the link, I'll take a look at the slideshow sometime soon. Fortunately managed to get around the issue without having to purchase any additional software.

Regards,

Mark

End User Directory search CUCM 8.6

Mark,

I don't have CUCM 8.6 but just tested this on my lab system and I found that if I created a user and configured an extension on the "Telephone Number" parameter, that number and the user are displayed in the directory listing. They also appear as dialable links.

Can you provide more specifics on your symptoms? Can you check your users to ensure you have created the appropriate values in the "Telephone Number" field of the enduser object?

Oh, BTW my "off net users" display the telephone number value under the "LDAP Ext" column (though I am NOT LDAP integrated on the CUCM system I tested).

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

New Member

End User Directory search CUCM 8.6

Hi Bill,

I've created the End User account as follows:

When I log in as CCM User and click on the Directory link you will see below that the extension number is blank and doesn't appear as a dialable link.

Apologies for the poor effort at concealing the telephone number and username.

On the customers exisitng 4.1(3) cluster they can use the following URL and the Extension number displays correctly:

https://172.16.1.1/ccmuser/directory.asp

It looks like the only numbers that appear as Extensions in CCM User Directory on the 8.6 cluster are numbers that are assigned to devices in CUCM.

I've only just found out that the customer uses Lotus Domino so I can't use LDAP.

Thanks,

Mark

New Member

End User Directory search CUCM 8.6

Bill,

You've pointed me in the right direction, I had LDAP extensions hidden in CCMUser Parameters Enteprise parameters.

I've enable it and now even though I'm not using LDAP the full number appears in the directory lookup.

Thanks for getting me off the hook!!

Regards,

Mark

End User Directory search CUCM 8.6

Good news. Thanks for the feedback.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

New Member

Re: End User Directory search CUCM 8.6

Amazing. I've been looking for this "answer" ever since I noticed that the majority of my directory listings vanished with the upgrade to UCM7. The strange part was all of the numbers still appeared in the Web Attendant Console. Thanks for the tip about changing the Show LDAP Entries. I'm back in business...

2333
Views
5
Helpful
7
Replies
CreatePlease to create content