Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ethernet Configurations

HELP!

By mistake I went into Ethernet Configurations and Enabled DHCP, now I can't get CUCM to boot up...

I read this warning now -but didn't see when I accidentially hit the submit..

If you enable DHCP, the system disables the Port and Gateway setting, and it cannot be changed.

-MJ

4 REPLIES

Re: Ethernet Configurations

Marcia,

I am not sure what CUCM version you are using.  On 7.x you can change the DHCP parameters.  I have not done this myself, but I would think that if you can get to the console of the server you could execute the command:

set network dhcp eth0 disable

So, if you wanted to give the address of 10.10.10.20/24 and your default gateway is 10.10.10.1 then you can use the following command:

admin:set network dhcp eth0 disable 10.10.10.20 255.255.255.0 10.10.10.1

The system will reboot after you execute this command.  When the system comes back online you should be good to go.  Keep in mind that one the Cisco appliance boots up it runs a network validation script.  This validation checks for the existance of the default gateway (among other things).  If validation fails the application services won't load properly.

HTH.

Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

New Member

Re: Ethernet Configurations

Thx Bill for the reply.  Yes, using7.1.3.

We tried several reboots, but don't get to 'admin' to enter your suggestions.-Set network, etc..

We must be running into the issue of validation failing, and services not loading properly.

Can we assign any settings from the subscriber?  It's our CUCM 1 that is OOS --not our CUCM 2.

Many thx, Marcia

Re: Ethernet Configurations

Marcia,

Since you were able to add a subscriber to the cluster, then I assume the publisher had a valid IP address at some point in time.  That is a critical piece of information.  I would recommend trying to get the publisher up using the IP address you had initially assigned, you can identify that IP address using the following command on the subscriber node.

show network cluster

This will kick out an IP address and hostname for your publisher node.  At least the IP address and hostname that the subscriber "knew" when it was added to the cluster (assuming you haven't renamed and/or re-ip'd anything).

Are you able to create a static reservation in DHCP for the publisher node?  If not, then do you have a cisco router on the VLAN that the publisher node is connecting to?  The idea is to take the IP address identified by the subscriber node and then create a static reservation for the publisher node eth0 mac address in the DHCP server or local IOS router.  You want the publisher to come online, recover its IP address via DHCP and then try to get back to a happy state.

Once you have the publisher on line then you can disable DHCP and assign the static address.  If you are trying to change the publisher's IP address, then you will need to follow the procedure here:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/install/7_1_2/ipchange/ipchg712.html

If you are not trying to change the IP address then you simply need to disable DHCP and assign the IP using the command provided in my original reply.

BTW, I am assuming you have direct console access to the publisher node.  Is that a correct assumption?  I ask because I have had situations where I botched up the IP addressing but could still get to the admin prompt on the server directly from the console.

HTH.

Let me know if you need more help.

Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

New Member

Re: Ethernet Configurations

Thx Again Bill

Yes, we were able to have direct console access to publisher node, during boot up, eth0 fails..and goes to network validation error, and then hangs.

Not trying to change IP, just bring publisher back online, because I made a stupid mistake!!  We'll try statically assigning the IP in the am.

Deep sigh, (it's always something), thx much!!

298
Views
5
Helpful
4
Replies
CreatePlease login to create content