Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Failure to register a MGCP gateway

Yesterday we lost the connection to a gateway for a few hours, returning the connection the gateway was not recorded in the CUCM, after making a show ccm-manager is always in registering:


MGCP Domain Name: ILL05254
Priority Status Host
================================================== ==========
Primary Backup Ready 10.127.32.155
First Backup Registering with CM 10.127.32.28
Second Backup None

We have deleted the configuration of the CUCM GW and the endpoint and created again and swings between registered and unregistered continuously.
The ISDN are correct:
# Sh isdn status ILL05254
Global ISDN primary-4ESS switchtype =

% Q.931 is to CCM MANAGER 0x0003 backhauled on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0: 15 interface
         dsl 0, interface ISDN primary-QSIG switchtype =
          Slave side configuration **** ****
         L2 Protocol = Q.921 0x0000 L3 Protocol (s) = CCM MANAGER 0x0003
     Layer 1 Status:
         ACTIVE
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
     Layer 3 Status:
         0 Active Layer 3 Call (s)
     Active dsl 0 CCBs = 0
     The Free Channel Mask: 0xFFFF7FFF
     Number of L2 Discards = 0, L2 Session ID = 1
     Total Allocated ISDN CCBs = 0Deshacer cambios

Internal calls are working correctly but not receive calls to DDI as the Gateway does not work.

Any idea???

Thanks!

7 REPLIES
New Member

Failure to register a MGCP gateway

here are a few things to check:

- make sure domain name for mgcp router is the same on both router and cucm config page (case sensitive)

- do "no mgcp" , "mgcp" to restart/download config

- remove "mgcp bind ...." and re-enter if you have bind cmd

New Member

Failure to register a MGCP gateway

thanks Tun Moe,

I did it so many times, and tried to register MGCP Gw to other CUCM in the cluster but stills fails, seems a firewall issue or something else....

Regards.

VIP Super Bronze

Failure to register a MGCP gateway

Ivan,

Is your mgcp gateway hostname still the same as whats configured on cucm. Like Tun said check that you dont have the command ip domain-name configured and if you do then this must be configured as your router hostname.domain-name in cucm config...

can you send a debug mgcp packets here

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Failure to register a MGCP gateway

Hi all,

Yes is the same name in Gw than in CUCM, seems a firewall problem because we have now more Gw with the same problem. in Gw shows always in registering and in CUCM is flopping between registered and unregistered.

Firewall and Security team are reviewing problem, may be a firewall issue, when we had the configuration I will say you.

Thanks and regards!

Green

Failure to register a MGCP gateway

Hi,

For MGCP make they are allowing these ports

Gateway

Unified CM

2427 / UDP

Media Gateway Control Protocol (MGCP) gateway control

Gateway

Unified CM

2428 / TCP

Media Gateway Control Protocol (MGCP) backhaul

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Failure to register a MGCP gateway

Hi all

Finally the problem has been resolved by firewall team

About the resolution they said that a rule in the firewall that were put to inspect SIP packets made gateways go to unregistered. Although that rule is for port 5060 in SIP and GWs goes in 2427 and 2428 in MGCP, this was the cause of the problem, and after eliminating that rule were registered with no problem.

I don´t know it this solution provided by firewall team is real of fake because they made something wrong and they gave us that solution, by the way all is working fine....

Thanks all and regards!

Failure to register a MGCP gateway

In my (limited) experience, SIP inspection on firewalls doesn't work...

GTG

Please rate all helpful posts.
1354
Views
0
Helpful
7
Replies
CreatePlease to create content