Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Fax not working properly with ATA-186

Hello there,

i am working with an 2811 Router with CME and an ATA186 (SCCP firmware) with a HP3392 Fax Machine attached.

My Problem is, the the faxes are not always working. It seems that it works by random. The Fax is sometimes

transmitted and completed correctly, but most of the time the pages are only filled to the half or 1/3rd and

the transmission is terminated with an error regarding the quality of the connection. The t.30 trace of the

fax reports a lot of errors during the transmission. I tried a lot of configurations, but it is not working,

and i dont know what else i could do.

I turned of H34 and error correction on the fax, but it seems the slowest speed the fax can perform is 14400,

so i cannot put it into 9600 speed, as some people told me.

My Router config is attached, can anybody please help me?



New Member

Re: Fax not working properly with ATA-186

Hi Marcus,

Haven't seen your config as it has now expired, please bear this is mind if I'm teaching you to suck eggs!

Is there any compelling reason for using Skinny? We've had quite a few strange problems using Skinny so we've decided to only use H323 for customers with CME and fax machines connected through ATAs.

It takes a bit more effort to set up the first time when compared to Skinny, but it seems to work every time (not had any complaints with H323 faxes yet).

First thing to do is upgrade/change the firmware on the ATA, you'll need to download the firmware from CCO ( is what I've been using lately) and then run a small exe contained in that zip file) from a PC on the same network as the ATA. From the ATA, use an analogue phone and use the IVR to upload the new firmware (basically you enter 100#192*168*1*1*8000# - depending on the IP address of the pc running the exe)

Once this is done, browse to the ATA ( and set up a static IP address, tftp server, UID (ext. # of fax), and gateway (CME router). There are a number of other settings that need to be correct, but these are usually the defaults.

Now create a dial-peer, this is a template that I've used ...

dial-peer voice ## voip

description *** Outgoing Fax Calls ***

destination-pattern !### ? internal extension

modem passthrough nse codec g711ulaw

session target ipv4:!**static IP address for ATA**!

incoming called-number ** external number** !(the number passed on by the exchange)

fax rate disable

no vad

This should now work without any issues including higher than 9600 speeds.

If you have any problems with this, reply on here and I'll try to help some more.



New Member

Re: Fax not working properly with ATA-186

Hi Glenn

I hope you don't mind me contacting you directly. I read this post and tried to set up a ata186 using h323. The problem is i am using a mgcp controlled gateway with callmanager 4.1

i get dial tone on ata but can't dial anywhere, i also can not receive calls on ata. Do you know if SCCP image will work with fax in this scenario? Can i use h323 in this instance,

regards colin

Hall of Fame Super Gold

Re: Fax not working properly with ATA-186


Have you checked the ATA fax parameters are correctly set ad described:

that will require editing of the parameters file, creating the binary config file with the utility, etc.

I would also try the redundancy option in "modem passthrough"

Re: Fax not working properly with ATA-186

I absolutely agree with Glenn about using H323. Even though CME 4.0 indicates ATA 186 does work in skinny mode, for faxing , i would suggest that you convert the load to H323 and setup dial-peers in teh CME router to send the fax call to the ATA. Make sure the dial-peer has fax passthrough enabled using modem passthrough command under the dial-peer and also disable fax relay using command "fax rate disable"

New Member

Re: Fax not working properly with ATA-186

Hi there,

thanks for the tipps.

There is no special reason for SCCP, but i

managed to turn down the faxrate to 4800bps,

and it works now (although a fax takes 2

minutes now, but well...), so i am not going

to touch it anymore.

If the problem persists, i will try H323.

Thank you very much,


New Member

Re: Fax not working properly with ATA-186

If you are going to use Skinny try setting the Audio mode to 0x00160016.

Just browse to the ATA then select the Audio mode tab and change to this param.

Usually helps with Fax Pass Through.

New Member

Re: Fax not working properly with ATA-186

Here is all I used to get faxes to work with ATAs using a SCCP image:

The below is required on the gateway:

network-clock-participate slot 1

network-clock-select 1 T1 1/0

mgcp modem passthrough voip mode nse

mgcp modem passthrough voip codec g711alaw

mgcp fax t38 inhibit

and on the ATA:

under Audio Parameters: Audio Mode: 0x00150015