Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Fax OnRamp Issue

Hi,

I did the following configuration:

hostname Router

ip domain name infomicro.local

ip name-server 192.168.0.100

fax receive called-subscriber $d$

fax interface-type fax-mail

mta send server 192.168.0.100 port 25

mta send subject "Cisco FAX to Mail"

mta send postmaster nelson@infomicro.local

mta send mail-from hostname Router.infomicro.local

mta send mail-from username $s$

!

application

service fax-onramp flash:app_faxmail_onramp.2.0.1.3.tcl

!

interface GigabitEthernet0/1

ip address 192.168.10.130 255.255.255.0

duplex auto

speed auto

!

dial-peer voice 40 pots

service fax-onramp

incoming called-number 5551234

direct-inward-dial

!

dial-peer voice 41 mmoip

service fax_on_vfc_onramp_app out-bound

max-conn 5

destination-pattern 5551234

information-type fax

session target mailto:fax@infomicro.local

When I make a call to the 5551234 the call begin the ring and after 2 or 3 seconds the call is answered, but that is all, the fxo port where I'm connecting the incoming line bring up and immediatly close the channel, I mean, disconect the call.

My question is, what is wrong? what I'm forgetting?

Hope somebody can help me

Regards

Nelson

PS: sorry about my english

3 REPLIES
New Member

Re: Fax OnRamp Issue

Hi Nelson

I haven't checked all your config but you're missing a POTS dialpeer to the FXO port. The FXO voice port should also have the "signal did" command because DID is not enabled by default (as far as I know).

http://www.cisco.com/en/US/docs/ios/voice/isdn/configuration/guide/vi_ext_mod_vcfx_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1027195

Regards

Stefan

New Member

Re: Fax OnRamp Issue

Hello,

I'm using a Cisco 3825 with Cisco Internetwork Operating System. Cisco IOS (tm) C3825 C3825-ADVIPSERVICESK9-M, The System version is 12.4(15)T7 / CME 4.1(0) and I try to configure a "T.37 Store and Forward Fax" but when I download the latest version of tcl script (app-faxmail-onramp.2.0.1.3.zip and app-faxmail-offramp.2.0.1.1.zip) and I put it on my router cannot do anything!!!.

And when I check how to solve this problem I found when I put in the CLI the command: "sh call application voice onramp_kywi" (onramp_kywi calls the script app-faxmail-onramp.2.0.1.3.zip) only have the next response:

Script Name : onramp_kywi

URL : flash:app-faxmail-onramp.2.0.1.2.tcl

Type : Service

State: Not Loaded

Life : Configured

Exec Instances: 0

Script Code Begin:

--------------------------------

--------------------------------

The same thing ocurs with the offramp script.

The most "worrying" part is when the command says about the script "State: Not Loaded"

Do you have any fix/solution to this problem???...I need urgent help.

Thanks!!

New Member

Re: Fax OnRamp Issue

You need to reload the router to load the script.

399
Views
0
Helpful
3
Replies
CreatePlease login to create content