Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Fax tone stops on Exacom E&M-200SF integration

Hi,

I'm connecting 2 VIC2-2E/M on a 3662 with an Exacom E&M-200SF (http://www.exacom.com/html/products/E&M200sf.htm)

and I'm enabling the signaling on Type I and 4-wire operation.

The Exacom device is connected with a Castelle Fax Server.

The call starts ok, but the fax tone stops app 10 seconds since the calls started.

The route call is this:

PSTN > E1 MGCP 2821 > CCM 5.1 > H323 3662

The config on gw 3662 is this:

voice service voip

signaling forward none

fax protocol pass-through g711alaw

h323

voice-port 2/0/0

operation 4-wire

signal immediate

input gain 12

output attenuation -4

dial-peer voice 50005 pots

destination-pattern 0525

progress_ind alert enable 8

direct-inward-dial

port 2/0/0

This Exacom has an FXS port to connect the fax server port, so I can connect a phone and call it from an IP Phone without problem.

If anyone has experience with this devices, I'll appreciate the support.

TIA

Andres Pasten Calzada

4 REPLIES
Silver

Re: Fax tone stops on Exacom E&M-200SF integration

The Cisco 2600 and 3600 series routers and Cisco MC3810 multiservice concentrator gateways provide standards-based toll bypass for fax and voice calls. In addition to existing voice and fax toll bypass capabilities, the multiservice gateways provide toll bypass for fax relay with the standards-based ITU-T T.38 fax relay implementation.

Interoperability with T.37 fax relay for VoIP H.323The Cisco 2600 and 3600 series routers and Cisco MC3810 multiservice concentrator gateways with ITU-T T.38 fax relay capability can interoperate with third-party gateways and gatekeepers over an IP H.323 network. The goal is to work with third-party gateways and gatekeepers to provide ITU-T standards-based T.38 fax relay services for multivendor networks.

Cisco Employee

Re: Fax tone stops on Exacom E&M-200SF integration

Sounds like you are using this device to convert from E&M to FXS for the fax server. This problem sounds like a fax relaty/passthrough issue and is possibly due to the config on the MGCP gateway.

Make sure the MGCP gateway is set up as detailed here -

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_configuration_guide_chapter09186a008053b50a.html

the important configs are -

ccm manager mgcp

no ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent 10.3.222.1 service-type mgcp version 0.1

mgcp modem passthrough voip mode nse

mgcp modem passthrough voip codec g711alaw

mgcp package-capability rtp-package

mgcp fax t38 inhibit

!

These will force the GW to do a codec upspeed to G711alaw when it detects a fax or modem CNG tone, which will then match what you have configured on the 3662 gateway.

Also, you need some minor corrections on the POTS dial peer -

dial-peer voice 50005 pots

destination-pattern 0525

progress_ind alert enable 8 <--- remove

direct-inward-dial <--- remove

port 2/0/0

These highlighted commands are not needed to analogue ports - they are for ISDN type interfaces.

New Member

Re: Fax tone stops on Exacom E&M-200SF integration

Yes, the Exacom converts from E&M signaling to teh FXS of the fax server.

I've tested the information in the related link, but including:

mgcp modem passthrough voip redundancy

But the call experienced a significant level of noise, and it didn't solve the problem.

I'll try again with the corrections on the dial-peer pots, and I'll let you know.

Only one question, on the gateway config page on the CCM, i've fax passthrough and modem passthrough enabled, is that ok, or shall I disable modem?

TIA

Andres Pasten Calzada

Cisco Employee

Re: Fax tone stops on Exacom E&M-200SF integration

This is not going to help either -

voice-port 2/0/0

operation 4-wire

signal immediate

input gain 12

output attenuation -4

the input gain is way too high and setting a -4dB attenuation means you boost the output level as well. This will result in distortion of the signal and could explain the noise you are hearing.

Set both these back to 0 and give it another try.

277
Views
1
Helpful
4
Replies
CreatePlease to create content