Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Faxing issue with XMedius

Hi NetPro,

I am here to ask for some assistance in this issue that I have been trying to resolve for the past few months.

Here is a summary of the issue we are having. When we send faxes, the receiving end will receive only the 1st page, or they will receive the fax over and over again. We believe this is happening because our system is not receiving an acknowledgement from the far end. ( this might be a configuration issue or issue in the pstn, though are ISP thinks over wise)

We are using XMedius faxing to send faxes through Call Manager, to the gateway, out of our PRI.

Details : XMedius to CUCM via SIP trunk. CUCM to Gateway via MGCP.

CUCM 8.6

IOS : c2900-universalk9-mz.SPA.152-3.T2.bin

XMedius : 6.5

I would really really appreciate some assistance. We’ve had many calls with cisco, xmedius, and our isp, but there is still no resolution.

Xmedius has viewed the wireshark captures and shows us that the software is not receiving confirmation from the far end. The system is designed to retry 3 times if the faxes fail due to errors.

Below is the output of show mgcp :

MGCP Admin State ACTIVE, Oper State ACTIVE - Cause Code NONE

MGCP call-agent: CUCM SERVER 2427 Initial protocol service is MGCP 0.1

MGCP validate call-agent source-ipaddr DISABLED

MGCP validate domain name DISABLED

MGCP block-newcalls DISABLED

MGCP send SGCP RSIP: forced/restart/graceful/disconnected DISABLED

MGCP quarantine mode discard/step

MGCP quarantine of persistent events is ENABLED

MGCP dtmf-relay for VoIP is SDP controlled

MGCP dtmf-relay for voAAL2 is SDP controlled

MGCP voip modem passthrough disabled

MGCP voaal2 modem passthrough disabled

MGCP voip modem relay: Disabled

MGCP T.38 Named Signalling Event (NSE) response timer: 200

MGCP Network (IP/AAL2) Continuity Test timer: 200

MGCP 'RTP stream loss' timer disabled

MGCP request timeout 500

MGCP maximum exponential request timeout 4000

MGCP rtp unreachable timeout 1000 action notify

MGCP gateway port: 2427, MGCP maximum waiting delay 3000

MGCP restart delay 0, MGCP vad DISABLED

MGCP rtrcac DISABLED

MGCP system resource check DISABLED

MGCP xpc-codec: DISABLED, MGCP persistent hookflash: DISABLED

MGCP persistent offhook: ENABLED, MGCP persistent onhook: DISABLED

MGCP piggyback msg ENABLED, MGCP endpoint offset DISABLED

MGCP simple-sdp ENABLED

MGCP undotted-notation DISABLED

MGCP codec type g711ulaw, MGCP packetization period 20

MGCP JB threshold lwm 30, MGCP JB threshold hwm 150

MGCP LAT threshold lwm 150, MGCP LAT threshold hwm 300

MGCP PL threshold lwm 1000, MGCP PL threshold hwm 10000

MGCP CL threshold lwm 1000, MGCP CL threshold hwm 10000

MGCP playout mode is adaptive 60, 40, 1000 in msec

MGCP Fax Playout Buffer is 300 in msec

MGCP media (RTP) dscp: ef, MGCP signaling dscp: af31

MGCP default package: fxr-package

MGCP supported packages: gm-package dtmf-package trunk-package line-package

                         hs-package rtp-package atm-package ms-package dt-package

                         mo-package mt-package sst-package fxr-package pre-package

                         md-package

MGCP Digit Map matching order: shortest match

SGCP Digit Map matching order: always left-to-right

MGCP VoAAL2 ignore-lco-codec DISABLED

MGCP T.38 Max Fax Rate is DEFAULT

MGCP T.38 Fax is ENABLED

MGCP T.38 Fax ECM is DISABLED

MGCP T.38 Fax NSF Override is DISABLED

MGCP T.38 Fax Low Speed Redundancy: 1

MGCP T.38 Fax High Speed Redundancy: 1

MGCP Fax relay SG3-to-G3: ENABLED

MGCP Fax relay ANSam suppression: DISABLED

MGCP control bound to interface Loopback0

MGCP media bound to interface Loopback0

MGCP Upspeed payload type for G711ulaw: 0, G711alaw: 8

MGCP Dynamic payload type for Cisco fax indication: 96, Cisco fax ack: 97

MGCP Dynamic payload type for G.726-16K codec

MGCP Dynamic payload type for G.726-24K codec

MGCP Dynamic payload type for G.726-32K codec

MGCP Dynamic payload type for G.Clear codec

MGCP Dynamic payload type for NSE is 100

MGCP Dynamic payload type for NTE is 99

MGCP rsip-range is enabled for TGCP only.

MGCP Comedia role is NONE

MGCP Comedia check media source is DISABLED

MGCP Comedia SDP force is DISABLED

MGCP g729 variants use static payload type and contain annexb in SDP

MGCP Guaranteed scheduler time is DISABLED

MGCP Disconnect delay error recovery DISABLED

MGCP DNS stale threshold is 30 seconds

Thank you very much in advance, any recommendations would be highly appreciated

David

5 REPLIES

Faxing issue with XMedius

Hi,

So the call flow looks something like this:

Telco---PRI---GW---MGCP---CUCM---SIP---XMedius?

Now:

"Xmedius has viewed the wireshark captures and shows us that the software  is not receiving confirmation from the far end. The system is designed  to retry 3 times if the faxes fail due to errors."

What is the confirmation message missing? Can they elaborate on this?

What Fax Protocol is being used by XMedius? If I had to guess, I'll say t.38?!?!

Please post the full "show run" and "show version" from the MGCP GW, as well the configuration of the SIP Trunk that poitns to XMedius.

Thx

--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.
New Member

Re: Faxing issue with XMedius

Yes this is the correct flow : Telco---PRI---GW---MGCP---CUCM---SIP---XMedius

Yes to the t.38 being used.

The sip trunk is configured in cucm.

Unfortunately I am not very familiar with faxing so I am not sure what they meant.

They explained it to me by showing me the wire shark voip call flow.

I believe they said that once we send the 1st page, we do not get a confirmation from the receiving end that they got it.

That is why xmedius continues to fax the 1st page over and over again.

Here is a show run of that gateway :

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

no service password-recovery

!

hostname voicegw01

!

boot-start-marker

boot system flash:c2900-universalk9-mz.SPA.152-3.T2.bin

boot-end-marker

!

!

card type t1 0 0

card type t1 0 2

logging buffered 1000000

!

aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authorization exec default group tacacs+ local

aaa authorization network default group tacacs+ local

aaa accounting send stop-record authentication failure

aaa accounting exec default

action-type start-stop

group tacacs+

!

aaa accounting commands 1 default

action-type stop-only

group tacacs+

!

aaa accounting commands 15 default

action-type stop-only

group tacacs+

!

aaa accounting network default

action-type start-stop

!

aaa accounting connection default

action-type start-stop

group tacacs+

!

aaa accounting system default

action-type start-stop

group tacacs+

!

!

!

!

!

!

aaa session-id common

clock timezone PST -8 0

clock summer-time PDT recurring

network-clock-participate wic 0

network-clock-participate wic 2

network-clock-select 3 T1 0/2/0

!

no ipv6 cef

no ip source-route

!

!

!

!

!

ip domain name XXXXXXX.org

ip name-server XXX.XXX.XXX.XXX

ip name-server XXX.XXX.XXX.XXX

ip cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

trunk group ANALOG

!

!

!

voice-card 0

voice-service dsp-reservation 50

dsp services dspfarm

!

!

!

voice service voip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

!

!

voice iec syslog

!

!

!

!

license udi pid CISCO2921/K9 sn FTXXXXXXXXXXX

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

archive

log config

logging enable

logging size 200

notify syslog contenttype plaintext

hidekeys

path ftp://XXXXXXXXXXXXXXXXXXXX

write-memory

username XXXXXXXXXX privilege 15 secret 5

username XXXXXXXXXX privilege 15 secret 5

!

redundancy

!

!

controller T1 0/0/0

clock source internal

cablelength long 0db

pri-group timeslots 1-24 service mgcp

!

controller T1 0/0/1

clock source internal

cablelength short 110

pri-group timeslots 1-24 service mgcp

description

!

controller T1 0/2/0

cablelength long 0db

pri-group timeslots 1-4,24 service mgcp

description

!

controller T1 0/2/1

cablelength long 0db

!

ip ssh version 2

!

!

!

!

interface Loopback0

ip address XXX.XXX.XXX.XXX 255.255.255.255

no ip proxy-arp

ip ospf 100 area 131

!

interface Loopback1

ip address XXX.XXX.XXX.XXX 255.255.255.255

shutdown

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description

ip address XXX.XXX.XXX.XXX 255.255.255.252

no ip proxy-arp

ip ospf message-digest-key 10 md5 7

ip ospf dead-interval 3

ip ospf hello-interval 1

ip ospf 100 area 131

duplex auto

speed auto

!

interface GigabitEthernet0/1

description

ip address XXX.XXX.XXX.XXX 255.255.255.252

no ip proxy-arp

ip ospf message-digest-key 10 md5 7

ip ospf dead-interval 3

ip ospf hello-interval 1

ip ospf 100 area 131

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/0/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

router ospf 100

router-id XXX.XXX.XXX.XXX

auto-cost reference-bandwidth 100000

area 131 authentication message-digest

area 131 stub no-summary

timers throttle spf 50 200 3000

timers throttle lsa 50 200 3000

timers lsa arrival 100

passive-interface Loopback0

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip tacacs source-interface Loopback0

!

ip access-list standard

permit XXX.XXX.XXX.XXX

deny   any log

ip access-list standard SSHin

permit XXX.XXX.XXX.XXX 0.127.255.255

deny   any log

ip access-list standard

permit XXX.XXX.XXX.XXX 0.0.1.255

permit XXX.XXX.XXX.XXX 0.0.1.255

permit XXX.XXX.XXX.XXX 0.0.0.255

deny   any log

!

logging source-interface Loopback0

logging XXX.XXX.XXX.XXX

logging XXX.XXX.XXX.XXX

logging XXX.XXX.XXX.XXX

logging XXX.XXX.XXX.XXX

!

snmp-server group snmpmonitor v1 access snmpmonitoring

snmp-server community XXX

snmp-server community XXX

snmp-server enable traps entity-sensor threshold

tacacs-server host XXX.XXX.XXX.XXX

tacacs-server host XXX.XXX.XXX.XXX

!

!

!

control-plane

!

!

voice-port 0/0/0:23

!

voice-port 0/2/0:23

!

voice-port 0/1/0

trunk-group ANALOG

description ANALOG Backup 999-999-9999

!

voice-port 0/1/1

trunk-group ANALOG

description ANALOG Backup 999-999-9999

!

voice-port 0/1/2

shutdown

description ANALOG Not Used

!

voice-port 0/1/3

shutdown

description ANALOG Not Used

!

voice-port 0/0/1:23

!

!

!

!

ccm-manager fallback-mgcp

ccm-manager redundant-host Publisher

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server Subscriber Publisher

ccm-manager config

!

mgcp

mgcp call-agent Subscriber 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package fxr-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 ls_redundancy 1

mgcp fax t38 hs_redundancy 1

mgcp bind control source-interface Loopback0

mgcp bind media source-interface Loopback0

!

mgcp profile default

!

sccp local Loopback0

sccp ccm xxx.xxx.xxx.xxx identifier 1 priority 1 version 7.0

sccp ccm xxx.xxx.xxx.xxx identifier 2 priority 2 version 7.0

sccp

!

sccp ccm group 1

bind interface Loopback0

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register XCODE

associate profile 2 register CFB

associate profile 3 register VCB

!

dspfarm profile 1 transcode

codec g722-64

codec g711ulaw

codec g729ar8

maximum sessions 5

associate application SCCP

!

dspfarm profile 2 conference

codec g722-64

codec g711ulaw

codec g729ar8

maximum sessions 3

associate application SCCP

!

dspfarm profile 3 conference video homogeneous

codec g729ar8

codec g711ulaw

codec g722-64

codec h264 vga frame-rate 30 bitrate 1mbps

maximum sessions 4

associate application SCCP

!

!

!

!

gatekeeper

shutdown

!

!

banner login ^CC

WARNING

Authorized Access Only

^C

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

session-timeout 30

access-class SSHin in

exec-timeout 15 0

logging synchronous

transport preferred ssh

transport input ssh

!

scheduler allocate 20000 1000

ntp server xxx.xxx.xxx.xxx prefer

ntp server xxx.xxx.xxx.xxx

!

end

voicegw01#

Here is a show version for the gateway :

show ver

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(3)T2, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Wed 26-Sep-12 07:24 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M1, RELEASE SOFTWARE (fc1)

voicegw01 uptime is 8 weeks, 6 days, 20 hours, 13 minutes

System returned to ROM by reload at 20:10:55 PDT Thu Jul 25 2013

System restarted at 20:12:13 PDT Thu Jul 25 2013

System image file is "flash:c2900-universalk9-mz.SPA.152-3.T2.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco CISCO2921/K9 (revision 1.0) with 479232K/45056K bytes of memory.

Processor board ID FTXXXXXXXXX

3 Gigabit Ethernet interfaces

53 Serial interfaces

1 terminal line

4 Channelized T1/PRI ports

4 Voice FXO interfaces

DRAM configuration is 64 bits wide with parity enabled.

255K bytes of non-volatile configuration memory.

254464K bytes of ATA System CompactFlash 0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#            PID                             SN

-------------------------------------------------

*0         CISCO2921/K9         FTXXXXXXXX  

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------

Technology   Technology-package           Technology-package

             Current       Type           Next reboot

------------------------------------------------------------------

ipbase       ipbasek9     Permanent     ipbasek9

security     None         None           None

uc           uck9         Permanent     uck9

data         None         None           None

Configuration register is 0x2102

voicegw01#

Thank you very much Jorge!

Re: Faxing issue with XMedius

Make sure you have the following commands:

no ccm-manager fax protocol cisco 

no mgcp fax t38 inhibit 

mgcp package-capability fxr-package

mgcp default-package fxr-package

no mgcp fax t38 ecm

mgcp fax t38 nsf 000000

Just for testing, set to default value "0":

mgcp fax t38 ls_redundancy 1 <-- 0

mgcp fax t38 hs_redundancy 1 <-- 0

Re-register the Gateway with CallManager by entering the following commands :

no mgcp

mgcp

HTH

--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

-- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.
New Member

Re: Faxing issue with XMedius

These commands are there:

no ccm-manager fax protocol cisco

no mgcp fax t38 inhibit

mgcp package-capability fxr-package

no mgcp fax t38 ecm

I will try to add :

mgcp fax t38 nsf 000000

Here is a question i do have :

Would changing the max fax rate from default to 14400 make a difference?

this was something xmedius recommend doing to hardcode it

MGCP T.38 Max Fax Rate is DEFAULT

to

MGCP T.38 Max Fax Rate is 14400

Thank you again Jorge

VIP Super Bronze

Faxing issue with XMedius

In addition to what Jorge suggested:

  • Ensure that the CUCM MGCP gateway has T.38 Fax Relay enabled and Cisco Fax Relay disabled. If you type the commands on the router but not CUCM they will likely be overriden from CUCM the next time you click Save.
  • For MGCP to SIP T.38 interworking you also need the gateway to have the following commands. Without them, CUCM will likely invoke an MTP, which will break T.38.
      • mgcp package-capability fm-package
      • mgcp dtmf-relay voip codec all mode nte-ca
      • In CUCM config, set Type of DTMF Relay to NTE-CA (*not* Current Config or NTE-GW) so they match.
    • Personally, I don't agree with disabling ECM as it's likely a symptom and not a cause but it won't hurt to test with it off.

    As for the DEFAULT vs. 14400 setting: essentially it means that the transmission rate cannot exceed the bandwidth of what the equivelent audio call would be. If it's G.711 then 14400 will be fine. If you're normally forcing audio calls down to G.729 then faxes would be capped at 7200. You would see that happening in the XMediusFAX console though.

    Please remember to rate helpful responses and identify helpful or correct answers.

    Please remember to rate helpful responses and identify helpful or
    7507
    Views
    0
    Helpful
    5
    Replies