Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

FXO-configration not working unable to call from IP phone -MGCP GW

 

Team,

 

I am Trying to make calls from IP phone -->cucm 9.1.2-->cisco 2901 voice gateway  (Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.3(3)M, RELEASE SOFTWARE (fc2) )-->VIC2-4FXO slot -->telephone line

When I dial a number I can see call reach gateway and IP phone starts the timer as if looks like call is going on. however the External number do not get any ring

When
I run show commands like show voice port sum,status i can see an active call -off hook

Similarly when I try to dial the number call reach till gateway but my IP phone do not ring

I suspect I am missing some commands which might be causing it. any sugestion?

 

License Details.:

------------------------------------------------------------------------
Technology    Technology-package                  Technology-package
              Current              Type           Next reboot 
------------------------------------------------------------------------
ipbase        ipbasek9             Permanent      ipbasek9
security      securityk9           Permanent      securityk9
uc            uck9                 Permanent      uck9
data          datak9               Permanent      datak9
appx          None                 None           None
NtwkEss       None                 None           None
CollabPro     None                 None           None

 

Running config:

 

voice-port 0/1/0
 input gain 14
 compand-type a-law
 cptone IN
 timeouts interdigit 3
 timeouts call-disconnect 1
 timeouts wait-release 1
 timing hookflash-out 50
 timing guard-out 1000
 connection plar 4002
 caller-id enable
 caller-id mode DTMF
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
 !
 !
 !
 !
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.240.19.6 
ccm-manager config
!
mgcp
mgcp call-agent 10.240.19.6 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
dial-peer voice 999010 pots
 service mgcpapp
 port 0/1/0
!
!
!
!
gatekeeper
 shutdown
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password <removed>
 login local
 transport input all
!
scheduler allocate 20000 1000
!
end

 

Also In cucm I can see the gateway is registerd

 

Please help

 

Rgds,

Ajith

  • IP Telephony
3 REPLIES
Super Bronze

HiWhen you call the extension

Hi

When you call the extension, if you have someone answer the phone even though it is not ringing, can you speak to them?

Here in the UK we require a particular type of adapter to be attached to the FXS port to generate ring tone - but the phones will 'work' otherwise. Maybe you need the same in India?

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Hey Aron,Well I just did some

Hey Aron,

Well I just did some changes towards ports I switched the ports -FXO now I am started getting incoming call  : )

However Outgoing call still I am getting an issuue.

Also I canot see caller ID it display 0 instead of calling number on the IP phone how do I fix it and how do I fix the outgoing call issue.

 

Regards,

Ajith

New Member

Hi all,Its working for me I

Hi all,

Its working for me I had done some few mistakes in commands :(

 

But some fine tune required like

1. If an external call is coming caller ID not displayed  but customer already has Caller ID facility I can see it on analog phone when I get a call on same line. but  0 is displayed on my IP phone.

2.If an external caller calls and after few ring he disconnects before I pick still I can see the IP phone ringing It should also stop ringing.

 

I have set timeouts call-disconnect 1 still no go please help

 

Regards,

Ajith

74
Views
0
Helpful
3
Replies