Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

FXO-Configuration with cisco router-2901-MGCP GW-cucm 9.1.2

I have configured FXO port with analog telephony line on cisco 2901 router.

I have cucm 9.1.2 MGCP GW connected to this router

I have registerd the FXO port with my CUCM  using 0/1/1 port connected it to router.

Calls are working fine both ways incoming as well as outgoing below are 2 issues I am not able to fix

 

1. If an external call is coming caller ID not displayed  but customer already has Caller ID facility I can see it on analog phone when I get a call on same line. but  "0" is displayed on my IP phone or some times "unkown number"

2.If an external caller calls and after few ring he disconnects before I pick up the call on IP phone still I can see the IP phone ringing It should also stop ringing.

On the router I have configred

 

voice-port 0/1/1-----------------------------> (on FXO port cisco 2901 router)
 input gain -6-----------------------------> also tried 14
 compand-type a-law
 cptone IN
 timeouts interdigit 3
 timeouts call-disconnect 1
 timeouts wait-release 1
 timing hookflash-out 50
 timing guard-out 1000
 connection plar 4002-------------------> (my IP phone extension also)
 caller-id enable
 caller-id mode DTMF

caller-id alerting line-reversal

caller-id alerting dsp-pre-allocation

 

Still no Go Please help Is there any other command which can fix my issue?

 

Rgds,

Ajith

 

 

6 REPLIES
Cisco Employee

Ajith,Check if you have

Ajith,

Check if you have enabled the parameter "Enable Caller Id" in the gateway page

If you connect the analog phone at what instance do you see the caller ID (i.e). after one ring or after connect, etc..

Also provide the following outputs

show version

show voice port 0/1/1

Debug voice ccai inout
Debug voip vtsp all
Debug vpm signal
Debug mgcp packets

 

Thanks,

Niran

New Member

Dear Niranjan,   "Enable

Dear Niranjan,

 

  "Enable Caller Id" in the gateway is alreayd present

I had tried  those commands and I have putty-logs I will share with you tomo..

 

rgds,

ajith

New Member

Hi NiranjanPFA putty logs I

Hi Niranjan

PFA putty logs I can see in

*Aug 14 11:06:50.230: [0/1/1] htsp_stop_caller_id_rx. message length 0htsp_setup_ind
*Aug 14 11:06:50.230: [0/1/1] get_fxo_caller_id:Caller ID receive failed.  parseCallerIDString:no data.
*Aug 14 11:06:50.230: [0/1/1] get_local_station_id calling num= calling name= calling time=08/14 11:06  orig called=
*Aug 14 11:06:50.234: //-1/xxxxxxxxxxxx/VTSP:(0/1/1):-1:-1:-1/vtsp_allocate_cdb: 
   CDB=0x3EEEA800

*Aug 14 11:06:50.230: [0/1/1] htsp_stop_caller_id_rx. message length 0htsp_setup_ind
*Aug 14 11:06:50.230: [0/1/1] get_fxo_caller_id:Caller ID receive failed.  parseCallerIDString:no data.
*Aug 14 11:06:50.230: [0/1/1] get_local_station_id calling num= calling name= calling time=08/14 11:06  orig called=
*Aug 14 11:06:50.234: //-1/xxxxxxxxxxxx/VTSP:(0/1/1):-1:-1:-1/vtsp_allocate_cdb: 
   CDB=0x3EEEA800

 

In above logs i can see  caller ID received failed and no string data

 

 

also in below log it says -->   X: 0
 

LIC-VOICE#
*Aug 14 11:06:39.774: MGCP Packet sent to 10.240.19.6:2427--->
NTFY 315225120 *@LIC-VOICE MGCP 0.1
X: 0
O:
<---

*Aug 14 11:06:39.774: MGCP Packet received from 10.240.19.6:2427--->
200 315225120
<---

X: 0
May be this is the reason I m getting 0 displayed on my ip phone when an incoming call is coming

 

 

 

 

 

 

Rgds,

Ajith

New Member

Any update ????

Any update ????

Cisco Employee

Hi Ajith,Try the following

Hi Ajith,

Try the following commands:  

mgcp persistent offhook 

then: 

no mgcp
mgcp 

voice-port x/x/x
timing guard-out 1000
sh
no sh

FYI, https://supportforums.cisco.com/discussion/11185531/cucm8-caller-id-issue-fxofxs-using-mgcp#3404786

Thanks,

Niran

VIP Gold

Hi Ajith,Plz attach requested

Hi Ajith,

Plz attach requested logs or try to change the gateway to H323 gateway. I have seen problems with caller id in mgcp gateways but not with H323 gaetway.

Suresh

 

 

782
Views
0
Helpful
6
Replies
CreatePlease login to create content