Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

FXO Issue

We're having a strange issue with our locations configured with FXO ports only where they eventually stop working. Incoming calls get one ring and then dial tone. Outgoing calls work fine. When issue show voice calls, each port diplays something like this:

0/2/1 - - - vpm level 1 state = FXOLS_ONHOOK

vpm level 0 state = S_UP

calling number , calling name unavailable, calling time 12/17 16:11

running the ccm-manager command I see the latest MGCP failover / switchback occured yesterday evening when I assume everything stopped working.

I can reset the gateway and nothing happens. The only way to resolve this issue is to physically restart / reload the router.

Is there any other way?

I'm running 12.4(6)T5-SP-SERV-CRYPTO on all 13 locations. Only the 4 locations without a PRI are having this issue.


Re: FXO Issue

There is a distinct possibily that you are running into a known issue given the version that you are currently running.

It is assumed that the other gateways with FXO ports exhibit the same symptoms following a fallback to SRST and then re-registered with CallManager?

In such cirmstances have you tried restarting the MGCP app rather than reloading the gateway? Initiate a 'no mgcp' then 'mgcp'.

I have experienced various issues with MGCP, FXO and SRST under 12.4(9)T, symptoms similiar to those you described. In most cases you could hear alerting on the pstn call leg, however there was no ringing on the phone, this was directly after the gateway re-registered. Given the time constraints it was difficult to troubleshoot and raise a Tac case. It was far easier to configure the gateway for H323, after which there were no issues after fallback.

I will take a look and see if there are any known issues similar to what you have described.



Community Member

Re: FXO Issue


I haven't tried the 'no mgcp' and 'mgcp' command nor have I ever tried to configure the gateway for H323.

What I found strange is the dial peer order changes every time this happens. The command

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

always falls to the end of the dial-peer configuration instead of the beginning. Simply moving it to the front makes everything work again.

I have been meaning to look into a H323 configuration - could you shoot one my way for review.

Re: FXO Issue

Tim, I have emailed a H323 configuration, and I have added comments to simply the explanation.

If you have the opportunity please take a look at the following document which discusses configuring CallManager dial-peer redundancy as shown in the example I forwarded:-

The following link details configuring a IOS H323 gateway for use with CallManager:-

Hope this all helps. If you find the configuration and details helpful, please rate this post.



CreatePlease to create content