Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

fxs port stuck

hi,

ios: Version 12.4(24)T8

cme: 7.1

VIC2-2FXS

 

I have an analog phone under voice-port 0/2/1

all works fine except sometimes when I call home from outside or when I try to use the phone from inside it doesn't work I have to do a shut and no shut of the interface.

when it doesn't work this is what I've been able to find,

#sh voice dsp

----------------------------FLEX VOICE CARD 0 ------------------------------
                           *DSP VOICE CHANNELS*

CURR STATE : (busy)inuse (b-out)busy out (bpend)busyout pending
LEGEND     : (bad)bad    (shut)shutdown  (dpend)download pending

DSP   DSP                 DSPWARE CURR  BOOT                         PAK   TX/RX
TYPE  NUM CH CODEC        VERSION STATE STATE   RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ========= ========== ===== ======= === == ========= == ==== ============
C5510 001 01 g711ulaw      24.3.8 busy  idle      0  0 0/2/1     01    0     75867/26
                           *DSP SIGNALING CHANNELS*
DSP   DSP                 DSPWARE CURR  BOOT                         PAK   TX/RX
TYPE  NUM CH CODEC        VERSION STATE STATE   RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ========= ========== ===== ======= === == ========= == ==== ============
C5510 001 01 {flex}        24.3.8 alloc idle      0  0 0/0/0     02    0         43/0
C5510 001 02 {flex}        24.3.8 alloc idle      0  0 0/0/1     06    0         36/0
C5510 001 03 {flex}        24.3.8 alloc idle      0  0 0/2/0     02    0         33/0
C5510 001 04 {flex}        24.3.8 alloc idle      0  0 0/2/1     02    0        766/0
------------------------END OF FLEX VOICE CARD 0 ----------------------------

 

 

 

RTR#sh voice call summary
PORT           CODEC     VAD VTSP STATE            VPM STATE
============== ========= === ==================== ======================
0/0/0         -          -  -                     FXOLS_ONHOOK
0/0/1         -          -  -                     FXOLS_ONHOOK
0/2/0         -          -  -                     FXSLS_ONHOOK
0/2/1         g711ulaw   n  S_SETUP_REQ_PROC      FXSLS_WAIT_OFFHOOK
 

 

the phone is not being used but it's s if it's hung the fxs card does not detect that the phone is not being used or something.

 

 

voice-port 0/2/1
 mwi
 cptone CA
 timeouts ringing infinity
 description *** HOME PHONE ***
 station-id name HOMEPHONE
 station-id number 41250
 caller-id enable

 

 

not sure if this is a bug or what. this happens maybe once every 2...3..4 weeks so it doesn't happen every day.

 

 

you think moving to IOS 15.0.1M8 will fix this? anyone else had the issue?

 

I could try to change the phone to the other FXS port but really worth it since this happens every 2...3..4 weeks.

 

ideas?

 

thanks.
 

 

 

 

3 REPLIES

Have you tested if

Have you tested if disconnecting the cable from the FXS port and plugging it back in also resolves?

New Member

hi,yes I have but it did not

hi,

yes I have but it did not work.

only way I found was to do a shut and no shut on the voice port.

New Member

here is the fix for others, I

here is the fix for others,

 

I went from advipservices to same version of ios but the one called, 

c2801-ipvoicek9-mz.151-4.M8.bin

 

now dsp has the good drivers and doesn't complain anymore.

C5510  001 01 {flex}       28.3.11 alloc idle      0  0 0/0/0     02    0         37/0
C5510  001 02 {flex}       28.3.11 alloc idle      0  0 0/0/1     06    0         37/0
C5510  001 03 {flex}       28.3.11 alloc idle      0  0 0/0/2     10    0         37/0
C5510  001 04 {flex}       28.3.11 alloc idle      0  0 0/0/3     14    0         37/0

 

153
Views
0
Helpful
3
Replies
CreatePlease to create content