Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

FXS-to-FXS call disconnect

I have a current problem with my client's ip tel set up, they have three offices HQ, Branch A and Branch B. My problem is after changing their HQ's router from 1760 to 2901, Branch A and B can't call HQ anymore call is drop 2 seconds after the caller finished dialing. However calls from HQ to Branch A and B are successful and calls from Branch A to B and vice versa are also successful. Already tried applying different codecs on the dial-peers, below are my configurations from HQ and Branch A routers.

                                      ***** HQ Router configuration *****

voice-card 0

dspfarm

dsp services dspfarm

dsp allocation signaling dspid

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

ip address trusted list

  ipv4 192.168.0.0

  ipv4 192.168.1.0

  ipv4 192.168.2.0

gcid

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

  cause-code legacy

!

voice class codec 1

codec preference 1 g723r53

codec preference 2 g723r63

!

voice class codec 2

codec preference 1 g729r8

codec preference 2 g729br8

!

voice class codec 3

codec preference 1 g723r53

codec preference 2 g711ulaw

!

!

application

global

  service alternate Default

!

map

  q850-cause 34 q850-cause 17

!

license udi pid CISCO2901/K9 sn FGL155320RY

license boot module c2900 technology-package datak9

hw-module pvdm 0/0

!

!

!

archive

log config

  hidekeys

!

redundancy

!

!

!

class-map match-all voip

match access-group 100

!

!

policy-map llq2

class voip

  priority 128 2400

  set ip precedence 5

class class-default

  fair-queue

  shape average 512000 5120

policy-map llq

class voip

  priority 128 2400

  set ip precedence 5

class class-default

  fair-queue

  shape average 1024000 10240

!

gw-accounting syslog

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.0.10 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.0.10

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 1024

no ip address

no ip mfib cef input

encapsulation frame-relay IETF

load-interval 30

frame-relay lmi-type ansi

service-policy output llq

!

interface Serial0/0/0.20 point-to-point

ip address 172.23.251.166 255.255.255.252

frame-relay interface-dlci 20  

  class VOFR

!

interface Serial0/0/1

bandwidth 512

no ip address

no ip mfib cef input

encapsulation frame-relay IETF

load-interval 30

service-policy output llq2

!

interface Serial0/0/1.939 point-to-point

ip address 10.212.179.70 255.255.255.252

frame-relay interface-dlci 939  

  class VOFR2

!

!

ip forward-protocol nd

!

ip pim bidir-enable

ip http server

ip http authentication local

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.0.2

!

!

map-class frame-relay VOFR

frame-relay cir 1024000

frame-relay bc 10240

frame-relay be 0

frame-relay mincir 1024000

!

map-class frame-relay VOFR2

frame-relay cir 128000

frame-relay bc 1280

frame-relay be 0

frame-relay mincir 128000

logging 192.168.0.20

access-list 100 permit udp any any range 16384 32767

access-list 100 permit ip any any dscp cs5

access-list 100 permit udp any any dscp ef

access-list 100 permit udp any any precedence critical

!

!

snmp-server community public RO

snmp-server enable traps entity-sensor threshold

!

!

!

control-plane

!

call treatment cause-code no-QoS

!

voice-port 0/1/0

secondary dialtone

timeouts call-disconnect 5

timeouts wait-release 5

description **** PABX LOCAL 156 *****

!

voice-port 0/1/1

secondary dialtone

timeouts call-disconnect 5

timeouts wait-release 5

description **** PABX LOCAL 136 *****

!

!

!

mgcp profile default

!

!

dial-peer cor custom

!

!

dial-peer voice 11 pots

destination-pattern 11...

port 0/1/1

forward-digits 3

!

dial-peer voice 10 pots

destination-pattern 10...

port 0/1/0

forward-digits 3

!

dial-peer voice 30 voip

description **** Branch B ****

destination-pattern 3.

session target ipv4:192.168.2.10

voice-class codec 3 

req-qos guaranteed-delay audio

ip qos dscp cs5 media

!

dial-peer voice 20 voip

description **** Branch A ****

destination-pattern 2.

session target ipv4:192.168.1.10

voice-class codec 2 

req-qos guaranteed-delay audio

ip qos dscp cs5 media

!

dial-peer voice 110 pots

destination-pattern 110

port 0/1/1

forward-digits 1

!

dial-peer voice 100 pots

destination-pattern 100

port 0/1/0

forward-digits 1

                                ***** Branch A Router configuration*****

voice rtp send-recv

!

voice class codec 1

codec preference 1 g723r53

codec preference 2 g723r63

!

voice class codec 2

codec preference 1 g729r8

codec preference 2 g729br8

!

voice class codec 3

codec preference 1 g729r8

codec preference 2 g711ulaw

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

class-map match-all voip

  match access-group 100

!

!

policy-map llq

  class voip

   priority 64

   set precedence 5

  class class-default

   fair-queue

!

gw-accounting syslog

!

!

interface FastEthernet0/0

ip address 192.168.1.10 255.255.255.0

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1

bandwidth 192

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type ansi

ip rtp priority 16384 16383 64

!

interface Serial0/1.1 point-to-point

ip address 10.10.15.2 255.255.255.252

frame-relay interface-dlci 25  

  class VOFR

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.15.1

ip http server

!

!

!

!

map-class frame-relay VOFR

frame-relay cir 192000

frame-relay bc 1920

frame-relay be 0

frame-relay mincir 192000

service-policy output llq

logging 192.168.0.20

access-list 100 permit udp any any range 16384 32767

access-list 100 permit ip any any dscp cs5

access-list 100 permit ip any any precedence critical

!

snmp-server engineID local 000000090200000216F209DE

snmp-server community public RO

snmp-server enable traps tty

radius-server authorization permit missing Service-Type

call rsvp-sync

!

voice-port 2/0

timeouts call-disconnect 5

timeouts wait-release 5

!

voice-port 2/1

timeouts call-disconnect 5

timeouts wait-release 5

!

dial-peer cor custom

!        

!

!

dial-peer voice 20 pots

destination-pattern 20

port 2/0

!

dial-peer voice 21 pots

destination-pattern 21

port 2/1

!

dial-peer voice 30 voip

description **** Branch B ****

destination-pattern 3.

voice-class codec 3

session target ipv4:192.168.2.10

req-qos guaranteed-delay

ip qos dscp cs5 media

!     

dial-peer voice 10 voip

description ***** HQ *****

destination-pattern 1[0-1]0

voice-class codec 3

session target ipv4:192.168.0.10

req-qos guaranteed-delay

ip qos dscp cs5 media

!

dial-peer voice 1000 voip

description ***** HQ *****

destination-pattern 10...

voice-class codec 3

session target ipv4:192.168.0.10

req-qos guaranteed-delay

ip qos dscp cs5 media

!

dial-peer voice 1001 voip

description ***** HQ *****

destination-pattern 11...

voice-class codec 3

session target ipv4:192.168.0.10

req-qos guaranteed-delay

ip qos dscp cs5 media

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Green

Re: FXS-to-FXS call disconnect

Hi Mike,

You are welcome

Please mark the case as correct answer provided.

Regards

Alex

Regards, Alex. Please rate useful posts.
8 REPLIES
Green

Re: FXS-to-FXS call disconnect

Hi,

On you HQ router can you post the output of

show ip address trusted list

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: FXS-to-FXS call disconnect

hi acampbell,

please see results below:

#show ip address trusted list

IP Address Trusted Authentication

Administration State: UP

Operation State:      UP

IP Address Trusted Call Block Cause: call-reject (21)

VoIP Dial-peer IPv4 Session Targets:

Peer Tag        Oper State      Session Target

--------        ----------      --------------

30              UP              ipv4:192.168.2.10

20              UP              ipv4:192.168.1.10

40              UP              ipv4:192.168.8.10

82              UP              ipv4:192.168.8.10

80              UP              ipv4:192.168.8.10

IP Address Trusted List:

ipv4 192.168.1.0

ipv4 192.168.2.0

ipv4 192.168.8.0

ipv4 192.168.0.0

Green

Re: FXS-to-FXS call disconnect

Hi,

On BRANCH A router
can you add the H323 binding to the fast0/0 interface


!
interface FastEthernet0/0
h323-gateway voip bind srcaddr 192.168.1.10
!

Also have a look on BRANCH B and bind the H323 there too.

Then retest

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Re: FXS-to-FXS call disconnect

Hi Alex,

After adding some configurations both on Branch A and HQ Router, Branch A can now call HQ however when HQ will call Branch A after 5 secs the call drops. I initiate debug voice ccapi inout on both sides and i got a Disconnect Cause=63 on the HQ Router, which means [Service or option ot available, unspecified.]

               ********** BRANCH A **********

!

voice call send-alert

voice call convert-discpi-to-prog

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

cause-code legacy

h323

  session transport udp

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

codec preference 3 g711alaw

!

voice class codec 2

codec preference 1 g729r8

codec preference 2 g729br8

!

voice class codec 3

codec preference 1 g723r53

codec preference 2 g711ulaw

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

class-map match-all voip

  match access-group 100

!

!

policy-map llq

  class voip

   priority 64

   set precedence 5

  class class-default

   fair-queue

!

gw-accounting syslog

!

!

interface FastEthernet0/0

ip address 192.168.1.10 255.255.255.0

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.1.10

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1

bandwidth 192

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type ansi

ip rtp priority 16384 16383 64

!

interface Serial0/1.1 point-to-point

ip address 10.10.15.2 255.255.255.252

frame-relay interface-dlci 25  

  class VOFR

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.15.1

ip http server

!

!

map-class frame-relay VOFR

frame-relay cir 192000

frame-relay bc 1920

frame-relay be 0

frame-relay mincir 192000

service-policy output llq

logging 192.168.0.20

access-list 100 permit udp any any range 16384 32767

access-list 100 permit ip any any dscp cs5

access-list 100 permit ip any any precedence critical

!

snmp-server engineID local 000000090200000216F209DE

snmp-server community RO

snmp-server enable traps tty

radius-server authorization permit missing Service-Type

call rsvp-sync

!

voice-port 2/0

timeouts call-disconnect 5

timeouts wait-release 5

!

voice-port 2/1

timeouts call-disconnect 5

timeouts wait-release 5

!

dial-peer cor custom

!

!

!

dial-peer voice 20 pots

destination-pattern 20

port 2/0

!

dial-peer voice 21 pots

destination-pattern 21

port 2/1

!

!

dial-peer voice 10 voip

description ****** HQ ROUTER ******

destination-pattern 1[0-1]0

voice-class codec 2

session target ipv4:192.168.0.10

req-qos guaranteed-delay

ip qos dscp cs5 media

!

dial-peer voice 100 voip

description ****** HQ ROUTER ******

destination-pattern 1[0-1]...

voice-class codec 2

session target ipv4:192.168.0.10

req-qos guaranteed-delay

ip qos dscp cs5 media

!

!

               ********** HQ ROUTER **********

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

ip address trusted list

  ipv4 0.0.0.0 0.0.0.0

mode border-element

media transcoder sync-streams

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

  cause-code legacy

h323

  session transport udp

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

codec preference 3 g711alaw

!

voice class codec 2

codec preference 1 g729r8

codec preference 2 g729br8

!

voice class codec 3

codec preference 1 g723r53

codec preference 2 g711ulaw

!

!

fax interface-type fax-mail

!

application

global

  service alternate Default

!

!

license udi pid CISCO2901/K9 sn FGL155320RY

license boot module c2900 technology-package datak9

hw-module pvdm 0/0

!

!

!

archive

log config

  hidekeys

username trends privilege 15 password 7

!

redundancy

!

!

!

class-map match-all voip

match access-group 100

!

!

policy-map llq2

class voip

  set ip precedence 5

  priority 64 2400

class class-default

  fair-queue

  shape average 512000 5120

policy-map llq

class voip

  priority percent 50

  set ip precedence 5

class class-default

  fair-queue

  shape average 1024000 10240

!

gw-accounting syslog

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 192.168.0.10 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.0.10

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 1024

no ip address

no ip mfib cef input

encapsulation frame-relay IETF

load-interval 30

frame-relay lmi-type ansi

service-policy output llq

!

interface Serial0/0/0.20 point-to-point

ip address 172.23.251.166 255.255.255.252

frame-relay interface-dlci 20  

  class VOFR

!

interface Serial0/0/1

bandwidth 512

no ip address

no ip mfib cef input

encapsulation frame-relay IETF

load-interval 30

service-policy output llq2

!

interface Serial0/0/1.939 point-to-point

ip address 10.212.179.70 255.255.255.252

frame-relay interface-dlci 939  

  class VOFR2

!

!

ip forward-protocol nd

!

ip pim bidir-enable

ip http server

ip http authentication local

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.0.2

!

map-class frame-relay VOFR2

frame-relay cir 128000

frame-relay bc 1280

frame-relay be 0

frame-relay mincir 128000

!

map-class frame-relay VOFR

frame-relay cir 1024000

frame-relay bc 10240

frame-relay be 0

frame-relay mincir 1024000

logging 192.168.0.20

access-list 100 permit udp any any range 16384 32767

access-list 100 permit ip any any dscp cs5

access-list 100 permit udp any any dscp ef

access-list 100 permit udp any any precedence critical

!

!

snmp-server community RO

snmp-server community RO

snmp-server enable traps entity-sensor threshold

!

!

!

control-plane

!

!

voice-port 0/1/0

secondary dialtone

no battery-reversal

no vad

description **** PABX LOCAL 156 *****

!

voice-port 0/1/1

secondary dialtone

no battery-reversal

no vad

description **** PABX LOCAL 136 *****

!

!

!

mgcp profile default

!

!

dial-peer cor custom

!

!

dial-peer voice 20 voip

description *** BRANCH A ***

destination-pattern 2.

session target ipv4:192.168.1.10

voice-class codec 2 

req-qos guaranteed-delay audio

ip qos dscp cs5 media

!

dial-peer voice 10 pots

destination-pattern 100

port 0/1/0

forward-digits 1

!

dial-peer voice 11 pots

destination-pattern 110

port 0/1/1

forward-digits 1

!

dial-peer voice 100 pots

destination-pattern 10...

port 0/1/0

forward-digits 3

!

dial-peer voice 110 pots

destination-pattern 11...

port 0/1/1

forward-digits 3

!

New Member

Re: FXS-to-FXS call disconnect

Hi,

Can you please add on your Branch A router, under "voice service voip"  the command:

allow-connections h323 to h323

and test please.

Green

Re: FXS-to-FXS call disconnect

Hi,

Can you post the debug voice ccapi inout

From the HQ router when you make a call to the BRANCH A

I think your new issue is being caused by incomplete RSVP configuation,

You need to specify an RSVP interface and it is best that your SP network supports RSVP too.

A very complex subject.

I do not think you need to use RSVP at all.

You have configured QOS over your frame relay interfaces - thats good.

If you are trying use the RSVP for CAC to control the number of calls, try using a different method.

This is your existing DP from HQ to BRANCH A

!

dial-peer voice 20 voip

description *** BRANCH A ***

destination-pattern 2.

session target ipv4:192.168.1.10

voice-class codec 2 

req-qos guaranteed-delay audio

ip qos dscp cs5 media

!

If you are trying to limit this route to say 2 calls then try changing the DP to this:-

!

dial-peer voice 20 voip

description *** BRANCH A ***

destination-pattern 2.

session target ipv4:192.168.1.10

voice-class codec 2 

no req-qos guaranteed-delay audio

max-conn 2

ip qos dscp cs5 media

!

Do the same at the DP on BRACH A to HQ

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

FXS-to-FXS call disconnect

Hi Alex,

It Works! After adding the said configurations on both sides calls are not drop anymore.

Thanks alot,

Mike

Green

Re: FXS-to-FXS call disconnect

Hi Mike,

You are welcome

Please mark the case as correct answer provided.

Regards

Alex

Regards, Alex. Please rate useful posts.
854
Views
5
Helpful
8
Replies
CreatePlease login to create content