Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

FXS without dial tone in CME

Hi!

I have a problem configuring a FXS port in a router 2911 with CME.

After introduce all commands for the configuration, i have not a dial tone, Now the router is not connected with any BRI or PRI, but I think that I should hear a dial tone when an analogic phone where connected, these are the commands:

Voice ports

voice-port 0/1/0
signal groundStart
no echo-cancel enable
echo-cancel mode 1
cptone ES
timeouts ringing infinity
connection plar 2000
bearer-cap Speech
caller-id enable
!
voice-port 0/1/1
signal groundStart
no echo-cancel enable
echo-cancel mode 1
cptone ES
timeouts ringing infinity
connection plar 2000
bearer-cap Speech
caller-id enable

SCCP

sccp local GigabitEthernet0/0.10
sccp ccm x.x.x.x identifier 1 version 7.0
sccp


sccp ccm group 1
associate ccm 1 priority 1

Dial-peer association

dial-peer voice 500 pots
service stcapp
port 0/1/0
!
dial-peer voice 501 pots
service stcapp
port 0/1/1

Do i need anything else??

Thanks!!!!

5 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

FXS without dial tone in CME

Hi, Here is the explanation:

PVDM3-16 = 1dsp

PVDM3-32= 2 dsp

PVDM3-48= 3dsp

PVDM3-64=4dsp

http://www.cisco.com/web/applicat/dsprecal/dsp_calc.html

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

FXS without dial tone in CME

Hi Ivan,

Can you try this config to test out:

Remove all the commands under the voice-port:

voice-port 0/1/0

!

voice-port 0/1/1

Dial-peer association should look like this (remove the extra config)

dial-peer voice 500 pots

destination-p 1001

port 0/1/0

!

dial-peer voice 501 pots

destination-p 1002

port 0/1/1

Save config and reload the router if required so that there are no cached values.

Basically any phone should have a line appearence (which is provided by the destination-pattern command on an FXS port. This config is missing in your "show run".

Let me know if this resolves the issue.

Regards,

Arun Kumar MV

Cisco Employee

Re: FXS without dial tone in CME

If the voice port turns up you have enough dsp resources. Your CME config is incomplete. First make sure the ip of the Sccp service points to the source address under telephony service. Next show the stcapp device names it's either under stcapp app or Sccp I don't remember off the top of my head. After you get the name add an ephone of type analog and whatever Mac address you got from the last step. Finally add an ephone-dn and assign it to that ephone.

Sent from Cisco Technical Support iPad App

Hall of Fame Super Gold

FXS without dial tone in CME

With service stcapp, you have the port in SCCP mode.

With destination-pattern, in regular dial-peer mode.

The two modes, and commands are mutually exclusive.

New Member

FXS without dial tone in CME

Hi Ivan,

Paolo is right. We don't need the destination-pattern command if you are looking to control the analog endpoints via CME. The destination-pattern is for providing an extension number to the analog stations.

However you may use the destination-pattern command to verify the hardware (VIC3 card).

So the correct configuration would be:

voice-port 0/1/0

caller-id enable

cptone ES

voice-port 0/1/1

caller-id enable

cptone ES

stcapp ccm-group 1

stcapp

sccp local GigabitEthernet0/0.10

sccp ccm x.x.x.x identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

dial-peer voice 500 pots

 service stcapp

port 0/1/0

!

dial-peer voice 501 pots

 service stcapp

port 0/1/1

telephony-service
no auto-reg-ephone
max-ephones 50
max-dn 50
ip source-address x.x.x.x port 2000



Other example configuration:
http://www.cisco.com/en/US/docs/ios/voice/fxs/configuration/guide/fxsbasic_ps10592_TSD_Products_Configuration_Guide_Chapter.html#wp1010513


I came across a Cisco Documentation that says that while connecting the RJ11 cable to the VIC3-2FXS/DID, the router has to be powered off:

http://www.cisco.com/en/US/partner/docs/routers/access/interfaces/ic/hardware/installation/guide/2port_FXS_DID_VIC.html#wp1065733

So first enter the configuration commands. Power off the router, connect the RJ11 cable to the phone. Power on the router and check if the Phone has the dial tone.

Regards,

Arun Kumar MV

Please rate useful posts !!!

27 REPLIES
Hall of Fame Super Gold

FXS without dial tone in CME

Signal must be loop start.
Also, plar commands have no effect for ports in SCCP mode, as well bearer-cap.

New Member

FXS without dial tone in CME

Ok thanks, I removed plar and bearer-cap, but although I introduce the loopstart commands in the voice-port,

Router(config)#voice-port 0/1/0

Router(config-voiceport)#signal loopStart

Router(config-voiceport)#exit

Router(config)#voice-port 0/1/1

Router(config-voiceport)#signal loopStart

It stills shows without it, why?

voice-port 0/1/0

no echo-cancel enable

echo-cancel mode 1

cptone ES

timeouts ringing infinity

caller-id enable

!

voice-port 0/1/1

no echo-cancel enable

echo-cancel mode 1

cptone ES

timeouts ringing infinity

caller-id enable

Hall of Fame Super Gold

FXS without dial tone in CME

Because is the default.

New Member

FXS without dial tone in CME

Still fails with loopstart, there is not a dial tone.

Thanks.

Hall of Fame Super Gold

FXS without dial tone in CME

Check if it works without SCCP first.

Cisco Employee

Re: FXS without dial tone in CME

Can you send a debug VPm signal of when you go off hook on the voice port with the analog phone. Also you need do a shut no shut to switch port signal type.

Sent from Cisco Technical Support iPad App

New Member

FXS without dial tone in CME

Hi!

Thanks for your response, now i hear a tone, but a busy tone, below you can see the debug vpm signal:

RouterMarpetrol#
Aug 21 08:28:24.459: htsp_process_event: [0/1/0, FXSLS_ONHOOK, E_DSP_SIG_1100]fxsls_onhook_offhook htsp_setup_ind
Aug 21 08:28:24.459: [0/1/0] get_local_station_id calling num= calling name= calling time=08/21 10:28  orig called=
Aug 21 08:28:24.459: htsp_pre_connect_disconnect, cdb = 2AC03798 cause = 29

Aug 21 08:28:24.459: htsp_process_event: [0/1/0, FXSLS_WAIT_SETUP_ACK, E_HTSP_PRE_CONN_DISC]fxsls_wait_setup_pre_conn_disc
Aug 21 08:28:32.223: htsp_process_event: [0/1/0, FXSLS_WAIT_SETUP_ACK, E_DSP_SIG_0100]fxsls_wait_setup_onhook
Aug 21 08:28:32.223: htsp_timer - 1000 msec
Aug 21 08:28:33.223: htsp_process_event: [0/1/0, FXSLS_W_SETUP_ACK_ONHOOK, E_HTSP_EVENT_TIMER]fxsls_onhook_setup_ack_timer
Aug 21 08:28:33.223: htsp_timer_stop
Aug 21 08:28:33.223: htsp_process_event: [0/1/0, FXSLS_W_SETUP_ACK_ONHOOK, E_HTSP_RELEASE_REQ]fxsls_wait_setup_release
Aug 21 08:28:33.223: htsp_timer_stop
Aug 21 08:28:35.855: htsp_process_event: [0/1/0, FXSLS_ONHOOK, E_DSP_SIG_1100]fxsls_onhook_offhook htsp_setup_ind

I tested it in both voice port , with the same result, busy tone.

Regards.

New Member

FXS without dial tone in CME

I add more information:

Router#sh stcapp device voice-port 0/1/1

Port Identifier:  0/1/1

Device Type:      ALG

Device Id:        3

Device Name:      AN4C1183A598081

Device Security Mode : None

Modem Capability: None

Device State:     OOS

Diagnostic:       None

Directory Number:

Dial Peer(s):     501

Dialtone after remote onhook feature: not activated

Busytone after remote onhook feature: not activated

Last Event:       STCAPP_CC_EV_CALL_SETUP_IND

Line State:       UNREGISTERED    ---------------------------------> This is a normal state for analog phone??

Line Mode:        CALL_BASIC

Hook State:       ONHOOK

mwi:              DISABLE

vmwi:             OFF

mwi config:       Both

Privacy:          Not configured

PLAR:             DISABLE

Callback State:   DISABLED

CWT Repetition Interval: 0 second(s) (no repetition)

Number of CCBs:   0

Global call info:

    Total CCB count      = 0

    Total call leg count = 0

debug voip ccapi inout

Aug 21 08:36:09.071: //-1/17159923801A/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Aug 21 08:36:09.071: //-1/17159923801A/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x311BAEC0, Call Info(
   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=501, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
Aug 21 08:36:09.071: //-1/17159923801A/CCAPI/ccCheckClipClir:
   In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Aug 21 08:36:09.071: //-1/17159923801A/CCAPI/ccCheckClipClir:
   Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Aug 21 08:36:09.071: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Aug 21 08:36:09.071: :cc_get_feature_vsa malloc success
Aug 21 08:36:09.071: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Aug 21 08:36:09.071:  cc_get_feature_vsa count is 1
Aug 21 08:36:09.071: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Aug 21 08:36:09.071: :FEATURE_VSA attributes are: feature_name:0,feature_time:717329400,feature_id:7
Aug 21 08:36:09.071: //7/17159923801A/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown))
Aug 21 08:36:09.071: //7/17159923801A/CCAPI/cc_process_call_setup_ind:
   Event=0x3119BBF8
Aug 21 08:36:09.071: //7/17159923801A/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 7 with tag 501 to app "stcapp"
Aug 21 08:36:09.071: //7/17159923801A/CCAPI/ccCallDisconnect:
   Cause Value=41, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Aug 21 08:36:09.071: //7/17159923801A/CCAPI/ccCallDisconnect:
   Cause Value=41, Call Entry(Responsed=TRUE, Cause Value=41)
Aug 21 08:36:09.071: //7/17159923801A/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null

show voice port summ    (PRI is disconnected)

                                           IN       OUT

PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC

=============== == ============ ===== ==== ======== ======== ==

0/0/0:15        01  isdn-voice  down  down none     none     n

0/0/0:15        02  isdn-voice  down  down none     none     n

0/0/0:15        03  isdn-voice  down  down none     none     n

0/0/0:15        04  isdn-voice  down  down none     none     n

0/0/0:15        05  isdn-voice  down  down none     none     n

0/0/0:15        06  isdn-voice  down  down none     none     n

0/0/0:15        07  isdn-voice  down  down none     none     n

0/0/0:15        08  isdn-voice  down  down none     none     n

0/0/0:15        09  isdn-voice  down  down none     none     n

0/0/0:15        10  isdn-voice  down  down none     none     n

0/0/0:15        11  isdn-voice  down  down none     none     n

0/0/0:15        12  isdn-voice  down  down none     none     n

0/0/0:15        13  isdn-voice  down  down none     none     n

0/0/0:15        14  isdn-voice  down  down none     none     n

0/0/0:15        15  isdn-voice  down  down none     none     n

0/0/0:15        17  isdn-voice  down  down none     none     n

0/0/0:15        18  isdn-voice  down  down none     none     n

0/0/0:15        19  isdn-voice  down  down none     none     n

0/0/0:15        20  isdn-voice  down  down none     none     n

0/0/0:15        21  isdn-voice  down  down none     none     n

0/0/0:15        22  isdn-voice  down  down none     none     n

0/0/0:15        23  isdn-voice  down  down none     none     n

0/0/0:15        24  isdn-voice  down  down none     none     n

0/0/0:15        25  isdn-voice  down  down none     none     n

0/0/0:15        26  isdn-voice  down  down none     none     n

0/0/0:15        27  isdn-voice  down  down none     none     n

0/0/0:15        28  isdn-voice  down  down none     none     n

0/0/0:15        29  isdn-voice  down  down none     none     n

0/0/0:15        30  isdn-voice  down  down none     none     n

0/0/0:15        31  isdn-voice  down  down none     none     n

0/1/0           --  fxs-ls      up    dorm on-hook  idle     n

0/1/1           --  fxs-ls      up    dorm on-hook  idle     n

VIP Super Bronze

FXS without dial tone in CME

Do you have the ff: config in your gateway? You have not sent your full config, so I cant tell if you have it or not...

stcapp ccm-group 1

stcapp

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

FXS without dial tone in CME

Hi!

Yes i have it, I forget to add it,

stcapp ccm-group 1

stcapp

Still receive a busy tone, i keep on looking for which could be the problem

Thanks!

VIP Super Bronze

FXS without dial tone in CME

Do you have DSPs in your router for the analogue cards?

What type of analogue cards do you have?

Can you send a show version and a  show diag.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

FXS without dial tone in CME

show version

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Tue 20-Mar-12 18:57 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M15, RELEASE SOFTWARE (fc1)

RouterMarpetrol uptime is 1 hour, 39 minutes
System returned to ROM by power-on
System restarted at 10:03:47 VERANO Tue Aug 21 2012
System image file is "flash0:c2900-universalk9-mz.SPA.151-4.M4.bin"
Last reload type: Normal Reload


Cisco CISCO2911/K9 (revision 1.0) with 479232K/45056K bytes of memory.
Processor board ID FCZ162070T9
3 Gigabit Ethernet interfaces
31 Serial interfaces
1 terminal line
1 Channelized E1/PRI port
2 Voice FXS interfaces
DRAM configuration is 64 bits wide with parity enabled.
255K bytes of non-volatile configuration memory.
250880K bytes of ATA System CompactFlash 0 (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#   PID                   SN
-------------------------------------------------
*0        CISCO2911/K9         xxxxxxxxxxxxx

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot
------------------------------------------------------------------
ipbase        ipbasek9      Permanent      ipbasek9
security      None          None           None
uc            uck9          Permanent      uck9
data          None          None           None

Configuration register is 0x2102

show diag

C2911 Mother board 3GE, integrated VPN and 4W Port adapter, 6 ports
        Port adapter is analyzed
        Port adapter insertion time 01:40:18 ago
        EEPROM contents at hardware discovery:
        PCB Serial Number        : FOC16165JAU
        Hardware Revision        : 1.0
        Part Number              : 73-11833-08
        Top Assy. Part Number    : 800-30797-04
        Board Revision           : D0
        Deviation Number         : 123694
        Fab Version              : 03
        Product (FRU) Number     : CISCO2911/K9
        Version Identifier       : V05
        CLEI Code                : CMMBR00ARC
        Processor type           : C1
        Chassis Serial Number    : FCZ162070T9
        Chassis MAC Address      : a44c.1183.a598
        MAC Address block size   : 80
        Manufacturing Test Data  : 00 00 00 00 00 00 00 00
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF C1 8B 46 4F 43 31 36 31 36 35 4A 41 55 40
          0x10: 06 18 41 01 00 82 49 2E 39 08 C0 46 03 20 00 78
          0x20: 4D 04 42 44 30 88 00 01 E3 2E 02 03 CB 8C 43 49
          0x30: 53 43 4F 32 39 31 31 2F 4B 39 89 56 30 35 20 D9
          0x40: 04 40 C1 CB C2 C6 8A 43 4D 4D 42 52 30 30 41 52
          0x50: 43 09 C1 C2 8B 46 43 5A 31 36 32 30 37 30 54 39
          0x60: C3 06 A4 4C 11 83 A5 98 43 00 50 C4 08 00 00 00
          0x70: 00 00 00 00 00 F3 00 03 40 01 25 FF FF FF FF FF
          0x80: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x90: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xA0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xB0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xC0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xD0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xE0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xF0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
        Internal Power Supply information
        Top Assy. Part Number    : 341-0235-06
        Deviation Number         : 0
        PCB Serial Number        : DCA1610R2Y5
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Version Identifier       : V04
        Product (FRU) Number     : PWR-2911-AC
        CLEI Code                : 0000000000
        Board Revision           : A0
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 E5 DF 45 01 55 00 EB 06 88 00 00 00
          0x10: 00 C1 8B 44 43 41 31 36 31 30 52 32 59 35 03 00
          0x20: 81 00 00 00 00 04 00 89 56 30 34 20 CB 8B 50 57
          0x30: 52 2D 32 39 31 31 2D 41 43 C6 8A 30 30 30 30 30
          0x40: 30 30 30 30 30 F3 00 59 41 00 BE 42 00 05 F8 00
          0x50: 50 01 F3 15 97 02 F0 18 3B 03 E6 19 FB 04 E2 1B
          0x60: 1C 05 D9 1C 53 06 D8 1D 4F 07 D6 1D B6 08 CE 1E
          0x70: 40 09 C2 1E ED 0A B8 1F B1 0B B9 20 20 0D AF 20
          0x80: 86 0F 9B 20 ED 11 91 21 3F 13 87 21 62 17 74 21
          0x90: C0 1B 57 21 DB 1F 38 21 F3 23 25 21 FC 27 0A 21
          0xA0: F3 42 41 30 FF FF FF FF FF FF FF FF FF FF FF FF
          0xB0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xC0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xD0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xE0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xF0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        PVDM Slot 0:
        16-channel (G.711) Voice/Fax PVDM3 DSP DIMM PVDM daughter card
        Hardware Revision        : 1.0
        Part Number              : 73-11576-03
        Board Revision           : C0
        Deviation Number         : 0
        Fab Version              : 03
        PCB Serial Number        : FOC1617691F
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM3-16
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 D8 41 01 00 82 49 2D 38 03 42 43 30
          0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 31 36 31 37
          0x20: 36 39 31 46 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 8F 50 56 44 4D 33 2D 31 36 20 20 20 20 20 20 20
          0x40: 89 56 30 31 20 D9 02 40 C1 FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        PVDM Slot 1:
        32-channel (G.711) Voice/Fax PVDM3 DSP DIMM PVDM daughter card
        Hardware Revision        : 1.0
        Part Number              : 73-11577-03
        Board Revision           : C0
        Deviation Number         : 0
        Fab Version              : 03
        PCB Serial Number        : FOC162318BZ
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM3-32
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 D9 41 01 00 82 49 2D 39 03 42 43 30
          0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 31 36 32 33
          0x20: 31 38 42 5A 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 8F 50 56 44 4D 33 2D 33 32 20 20 20 20 20 20 20
          0x40: 89 56 30 31 20 D9 02 40 C1 FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 0:
        VWIC3-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-34657-01
        Part Number              : 73-13419-01
        Board Revision           : B0
        Deviation Number         : 0
        Fab Version              : 05
        PCB Serial Number        : FOC162144PM
        Version Identifier       : V01
        Product (FRU) Number     : VWIC3-1MFT-T1/E1
        CLEI Code                : COUIA7PCAA
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 06 ED 41 01 00 C0 46 03 20 00 87 61 01
          0x10: 82 49 34 6B 01 42 42 30 88 00 00 00 00 02 05 C1
          0x20: 8B 46 4F 43 31 36 32 31 34 34 50 4D 89 56 30 31
          0x30: 20 CB 90 56 57 49 43 33 2D 31 4D 46 54 2D 54 31
          0x40: 2F 45 31 C6 8A 43 4F 55 49 41 37 50 43 41 41 03
          0x50: 00 81 00 00 00 00 04 00 D9 03 40 C1 CB FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 1:
        3rd generation - FXS DID Voice daughter card (2 port)
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-33587-01
        Board Revision           : D0
        Deviation Number         : 0
        Fab Version              : 08
        PCB Serial Number        : FOC16216B1R
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VIC3-2FXS/DID
        Version Identifier       : V03
        CLEI Code                : IP9IAB3CAC
        Longitudinal Calibration : 01 10 10 82 D6 10 10 8A
                                   52
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 06 21 41 01 00 C0 46 03 20 00 83 33 01
          0x10: 42 44 30 88 00 00 00 00 02 08 C1 8B 46 4F 43 31
          0x20: 36 32 31 36 42 31 52 03 00 81 00 00 00 00 04 00
          0x30: CB 8D 56 49 43 33 2D 32 46 58 53 2F 44 49 44 89
          0x40: 56 30 33 20 D9 02 40 C1 C6 8A 49 50 39 49 41 42
          0x50: 33 43 41 43 D3 09 01 10 10 82 D6 10 10 8A 52 FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF


Embedded Service Engine 0/0 :
  Total platform memory : 524288K bytes
  Total 2nd core memory : 0K bytes
  Start of physical address for 2nd core : 0x80000000
  Virtual address start of 2nd core memory : 0x0 - 0x0
  2nd core configured disabled
  L2 cache ways for 2nd core : 0

VIP Super Bronze

FXS without dial tone in CME

Ok. From what I can see you should have enough DSPs. Finally can you send a sh run. Please attach in a text file.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

FXS without dial tone in CME

I add here because there is not a lot information in the router:

RouterMarpetrol#sh run
Building configuration...


Current configuration : 5085 bytes
!
! No configuration change since last restart
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
enable secret 4 Tw/TVweCrKP8tReUhD.qT6x6FACDOS52YTSZ8LoMV5A
!
no aaa new-model
clock timezone ES 1 0
clock summer-time VERANO date Jun 21 2012 0:00 Sep 20 2012 0:00
network-clock-participate wic 0
!
no ipv6 cef
ip source-route
ip cef
!
!

!
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
!
isdn switch-type primary-net5
!
crypto pki token default removal timeout 0
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
  call start slow
sip
  redirect contact order best-match
!
voice class codec 100
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
!
voice translation-rule 1
rule 1 /-------/ /6201/
!
!
voice translation-profile PSTN
translate called 1
!
!
license udi pid CISCO2911/K9 sn ---------------
license accept end user agreement
license boot module c2900 technology-package uck9
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username Marpetrol
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-31
description PRIMARIO DE VOZ
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address x.x.x.x 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address x.x.x.x 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
no echo-cancel enable
echo-cancel mode 1
cptone ES
connection plar 2000
shutdown
bearer-cap Speech
!
voice-port 0/1/0
no echo-cancel enable
echo-cancel mode 1
cptone ES
timeouts ringing infinity
caller-id enable
!
voice-port 0/1/1
no echo-cancel enable
echo-cancel mode 1
cptone ES
timeouts ringing infinity
caller-id enable
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0.10
sccp ccm x.x.x.x identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
dspfarm profile 2 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 2
associate application SCCP
shutdown
!
dspfarm profile 1 conference
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 2
associate application SCCP
!
dspfarm profile 3 mtp
codec g711ulaw
maximum sessions hardware 3
shutdown
!
dial-peer voice 1 pots
translation-profile incoming PSTN
preference 1
incoming called-number .
port 0/0/0:15
!
dial-peer voice 2 pots
description salientes a moviles
translation-profile incoming PSTN
destination-pattern 6........
port 0/0/0:15
forward-digits all
!
dial-peer voice 10 pots
description salientes a fijos nacionales
translation-profile incoming PSTN
destination-pattern 9........
port 0/0/0:15
forward-digits all
!
dial-peer voice 50 pots
service stcapp
port 0/0/0:15
!
dial-peer voice 500 pots
service stcapp
port 0/1/0
!
dial-peer voice 501 pots
service stcapp
port 0/1/1
!
dial-peer voice 100 pots
description llamadas internacionales
destination-pattern 0T
port 0/0/0:15
forward-digits all
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
no auto-reg-ephone
max-ephones 50
max-dn 50
ip source-address x.x.x.x port 2000
max-redirect 20
system message Marpetrol
user-locale ES
network-locale ES
load 7942 sccp
load 7962 sccp
time-format 24
date-format dd-mm-yy
keepalive 15
max-conferences 8 gain -6
moh music-on-hold.au
transfer-system full-consult
transfer-pattern ....
secondary-dialtone 0
xmltest
create cnf-files version-stamp 7960 Aug 21 2012 11:51:23
!
!
!
line con 0
password 7 0123031049040A
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password 7 13351206190308
login
transport input all
line vty 5 15
password 7 1427171F1E0B26
login
transport input all
!
scheduler allocate 20000 1000
end

thanks!!!

VIP Super Bronze

FXS without dial tone in CME

I have used the DSP calcultaor to check how many DSPs you need for your current configuration. 30 E1 channels, 2 High codec complexity conference session and 2 FXS ports. The result came up as 4 DSPs..i.e pvdm3-64. From your sh diag, you only have 3 dsps, i.e pvdm3-16 + pvdm3-32.

What you can do to confirm if this is a PVDM related issue is to shutdown the conference dspfarm profile. That will free up dsps. You can test the analogue ports again. If it works this time, then you know you need more DSPs

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

FXS without dial tone in CME

Hi!

I shutdown the conference dspfarm profile but stills fails, may be is other thing:

Router(config)#dspfarm profile 1
Router(config-dspfarm-profile)#shut

Disabling profile will disconnect active CONFERENCING calls,
do you want to continue ? [yes/no]yes

Still I receive a busy tone , please could you send me link the the DSP calculator? and, other question why pvdm3-16 + pvdm3-32 give me 3 DSP? and 3-64 give me 4?

Thanks!!

VIP Super Bronze

FXS without dial tone in CME

Hi, Here is the explanation:

PVDM3-16 = 1dsp

PVDM3-32= 2 dsp

PVDM3-48= 3dsp

PVDM3-64=4dsp

http://www.cisco.com/web/applicat/dsprecal/dsp_calc.html

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

FXS without dial tone in CME

Thanks for your help!

Could resolve this issue if I upgrade the IOS?

regards!

New Member

FXS without dial tone in CME

Hi Ivan,

Can you try this config to test out:

Remove all the commands under the voice-port:

voice-port 0/1/0

!

voice-port 0/1/1

Dial-peer association should look like this (remove the extra config)

dial-peer voice 500 pots

destination-p 1001

port 0/1/0

!

dial-peer voice 501 pots

destination-p 1002

port 0/1/1

Save config and reload the router if required so that there are no cached values.

Basically any phone should have a line appearence (which is provided by the destination-pattern command on an FXS port. This config is missing in your "show run".

Let me know if this resolves the issue.

Regards,

Arun Kumar MV

Hall of Fame Super Gold

Re: FXS without dial tone in CME

Save config and reload the router if required so that there are no cached values.

Cisco router do not need reload after configuration changes.

Basically any phone should have a line appearence (which is provided by the destination-pattern command on an FXS port. This config is missing in your "show run".

That does not create a line appearancebut only support for basic calling. True line appearance for analog phones in CME is done configuring the port in SCCP mode, that is what the OP had , at least partially, in the initial posted config

Cisco Employee

Re: FXS without dial tone in CME

If the voice port turns up you have enough dsp resources. Your CME config is incomplete. First make sure the ip of the Sccp service points to the source address under telephony service. Next show the stcapp device names it's either under stcapp app or Sccp I don't remember off the top of my head. After you get the name add an ephone of type analog and whatever Mac address you got from the last step. Finally add an ephone-dn and assign it to that ephone.

Sent from Cisco Technical Support iPad App

New Member

FXS without dial tone in CME

Hi arunkum3 !!

Now I have a dial-tone, even with this configuration in voice-port:

voice-port 0/1/0

no echo-cancel enable

echo-cancel mode 1

cptone ES

timeouts ringing infinity

caller-id enable

!

voice-port 0/1/1

no echo-cancel enable

echo-cancel mode 1

cptone ES

timeouts ringing infinity

caller-id enable

Question is about destination-p in the dial-peer, i have tested when i quit the command ´service stcapp´ and put destinattion-pattern runs, so the problem was there. my question are:

Why do i must to quit this? in cisco.com explains this command is mandatory

The destinattion-pattern 1001 and 1002 why? is as example, can i put there whatever?

thanks and regards!!!!!

Hall of Fame Super Gold

FXS without dial tone in CME

With service stcapp, you have the port in SCCP mode.

With destination-pattern, in regular dial-peer mode.

The two modes, and commands are mutually exclusive.

New Member

FXS without dial tone in CME

Hi Ivan,

Paolo is right. We don't need the destination-pattern command if you are looking to control the analog endpoints via CME. The destination-pattern is for providing an extension number to the analog stations.

However you may use the destination-pattern command to verify the hardware (VIC3 card).

So the correct configuration would be:

voice-port 0/1/0

caller-id enable

cptone ES

voice-port 0/1/1

caller-id enable

cptone ES

stcapp ccm-group 1

stcapp

sccp local GigabitEthernet0/0.10

sccp ccm x.x.x.x identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

dial-peer voice 500 pots

 service stcapp

port 0/1/0

!

dial-peer voice 501 pots

 service stcapp

port 0/1/1

telephony-service
no auto-reg-ephone
max-ephones 50
max-dn 50
ip source-address x.x.x.x port 2000



Other example configuration:
http://www.cisco.com/en/US/docs/ios/voice/fxs/configuration/guide/fxsbasic_ps10592_TSD_Products_Configuration_Guide_Chapter.html#wp1010513


I came across a Cisco Documentation that says that while connecting the RJ11 cable to the VIC3-2FXS/DID, the router has to be powered off:

http://www.cisco.com/en/US/partner/docs/routers/access/interfaces/ic/hardware/installation/guide/2port_FXS_DID_VIC.html#wp1065733

So first enter the configuration commands. Power off the router, connect the RJ11 cable to the phone. Power on the router and check if the Phone has the dial tone.

Regards,

Arun Kumar MV

Please rate useful posts !!!

New Member

FXS without dial tone in CME

Hi again!

I did the changes you said me but when I put ´service stcapp´ in a dial-peer sounds always a busy tone in the analog phone, the finally configuration is as below:

RouterMarpetrol#sh run
Building configuration...

!
card type e1 0 0
no logging console
enable secret 4 Tw/TVweCrKP8tReUhD.qT6x6FACDOS52YTSZ8LoMV5A
!
no aaa new-model
clock timezone ES 1 0
clock summer-time VERANO date Jun 21 2012 0:00 Sep 20 2012 0:00
network-clock-participate wic 0
!
no ipv6 cef
ip source-route
ip cef
!
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
!
isdn switch-type primary-net5
!
crypto pki token default removal timeout 0
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
  call start slow
sip
  redirect contact order best-match
!
voice class codec 100
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!

!
!
license udi pid CISCO2911/K9 sn FCZ162070T9
license accept end user agreement
license boot module c2900 technology-package uck9
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!

redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-31
description PRIMARIO DE VOZ
!

!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 10.7.5.4 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 212.4.110.10 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!

!
!
!
control-plane
!
!
voice-port 0/0/0:15
no echo-cancel enable
echo-cancel mode 1
cptone ES
connection plar 2000
shutdown
bearer-cap Speech
!
voice-port 0/1/0
no echo-cancel enable
echo-cancel mode 1
cptone ES
timeouts ringing infinity
caller-id enable
!
voice-port 0/1/1
no echo-cancel enable
echo-cancel mode 1
cptone ES
timeouts ringing infinity
caller-id enable
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0.10
sccp ccm 10.7.5.4 identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 2
associate application SCCP
shutdown
!
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
shutdown
!
dspfarm profile 3 mtp
codec g711ulaw
maximum sessions hardware 3
shutdown
!
dial-peer voice 1 pots
translation-profile incoming PSTN
preference 1
incoming called-number .
port 0/0/0:15
!
dial-peer voice 2 pots
description salientes a moviles
translation-profile incoming PSTN
destination-pattern 6........
port 0/0/0:15
forward-digits all
!
dial-peer voice 100 pots
description llamadas internacionales
destination-pattern 0T
port 0/0/0:15
forward-digits all
!
dial-peer voice 500 pots
service stcapp
port 0/1/0
!
dial-peer voice 501 pots
service stcapp
port 0/1/1
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
no auto-reg-ephone
max-ephones 50
max-dn 50
ip source-address 10... port 2000
max-redirect 20
system message Marpetrol
user-locale ES
network-locale ES
load 7942 sccp
load 7962 sccp
time-format 24
date-format dd-mm-yy
keepalive 15
max-conferences 8 gain -6
moh music-on-hold.au
web admin customer name Petrol password Petrol
transfer-system full-consult
transfer-pattern ....
secondary-dialtone 0
xmltest
create cnf-files version-stamp 7960 Aug 22 2012 10:24:30

The webpage you send me is the same pdf file from cisco i used, so the first configuration was fine, the only runs is change stcapp in the dial-peer for destination-pattern.

As i will use this with a CME, is there any problem if I live the dial-peer with destination-p in order to get it runs instead of service stcapp??

And the destination-p number could be any number? or must be the telephony number of the analog phone?

Thanks Arunkum and Paolo!

New Member

FXS without dial tone in CME

Hi!

All runs properly now, the destinattion-p number is used as the extension of the analog phone.

So question is, what is used for the ´stcapp service´ ???

thanks!

Un saludo.

Hall of Fame Super Gold

FXS without dial tone in CME

To have an analog phone access features that otherwise it doesn't have.

Thanks for the nice rating and good luck!

2776
Views
0
Helpful
27
Replies
CreatePlease to create content