Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Gatekeeper config help

Hello All,

I´m trying to make a private voice network, in which the central point is an IOS Router with GK and the edges are IOS Routers with H323 to the GK and QSIG to the edge PBXs.

Then, I see that the call from the PBX goes into the QSIG, but the edge IOS router seems to not forward it to the H323 dial-peer.

Any help?

This are the configs:

GK**********************************************

gatekeeper
zone local R6-2611 telecor.es
zone prefix R6-2611 202... gw-priority 10 R2-2811
zone prefix R6-2611 405... gw-priority 10 R3-3825
gw-type-prefix 1#*
no shutdown

EDGE ROUTER *****************************

interface Loopback0
ip address 172.31.1.2 255.255.255.255
h323-gateway voip interface
h323-gateway voip id R6-2611 ipaddr 172.30.253.253 1719
h323-gateway voip h323-id R2-2811@telecor.es
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 172.31.1.2

!

dial-peer voice 1 pots
destination-pattern 1#202....
incoming called-number .......
direct-inward-dial
port 1/0/0:15
prefix 202
no register e164
!
dial-peer voice 20 voip
destination-pattern .......
session target ras
tech-prefix 1#
codec g729r8 bytes 50

The call tested is like:

Calling -- 202AAAA

Called -- 405BBBB

Many thanks

5 REPLIES
Silver

Re: Gatekeeper config help

Hi

Your configuration seems ok on this Edge router. I guess you have similar on the other side. Can upload other Edge router config too?

Also, are they GWs registered to GK?

"show gateway" on the gateway and "show gatekeeper endpoint" on the GK will help to determine that.

If all seems ok, then time to look some debug

GW debug(both):

debug isdn q931

debug h225 asn1

GK debug

debug gatekeeper main 10

debug h225 asn1

Thanks

- abu

Community Member

Re: Gatekeeper config help

Hello,

Thanks for your help.

This is the other EDGE ROUTER CONFIG*************************

!
!
interface Loopback0
ip address 172.31.1.3 255.255.255.255
h323-gateway voip interface
h323-gateway voip id R6-2611 ipaddr 172.30.253.253 1719
h323-gateway voip h323-id R3-3825@telecor.es
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 172.31.1.3
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
no logging event link-status
isdn switch-type primary-qsig
isdn overlap-receiving
isdn network-failure-cause 34
isdn incoming-voice voice
isdn send-alerting
no cdp enable
!
!
!
voice-port 0/1/0:15
cptone DE
!
!
!
dial-peer voice 1 pots
destination-pattern 1#405....
incoming called-number .......
direct-inward-dial
port 0/1/0:15
prefix 405
no register e164
!
dial-peer voice 20 voip
destination-pattern 202....
session target ras
tech-prefix 1#
codec g729r8 bytes 50
!
!
gateway
timer receive-rtp 1200
*******************************************************************************************

"show gateway" and "show gatekeeper endpoint" show at edges and gk that the gateways are registered.

If I use "debug q931" in the edge that receives the QSIG call, I see that the answer from the edge to the pbx is "Unallocated number"

If I use "debug h225 asn1" in the same router for the same call, I see only registration request to the GK and registration confirms from the gk, but nothing about the call.

It seems dial-peer voice 20 voip is no aplying.

What do you think?

Community Member

Re: Gatekeeper config help

Hello,

Once the first problem is solved (mistakes in the dial-peer digits), it seems that I have a problem in the GK, that can not find the destination gateway.

The error is "rejectReason calledPartyNotRegistered", but I see the gateway with the destination number registered. Any help?

This is the usefull info for this:

R6-2611#show running-config
gatekeeper
zone local R6-2611 test.es
zone prefix R6-2611 200* gw-priority 10 R2-2811
zone prefix R6-2611 405* gw-priority 10 R3-3825
no shutdown


R6-2611#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.31.1.2      1720  172.31.1.2      53198 R6-2611           VOIP-GW 
    H323-ID: R2-2811
172.31.1.3      1720  172.31.1.3      61240 R6-2611           VOIP-GW 
    H323-ID: R3-3825
Total number of active registrations = 2


R6-2611#show gatekeeper gw-type-prefix
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 1#*
  Zone R6-2611 master gateway list:
    172.31.1.3:1720 R3-3825
  Zone R6-2611 prefix 405* priority gateway list(s):
   Priority 10:
    172.31.1.3:1720 R3-3825
  Zone R6-2611 prefix 200* priority gateway list(s):
   Priority 5:
    172.31.1.3:1720 R3-3825


R6-2611#debug h225 asn1
H.225 ASN1 Messages debugging is on
R6-2611#terminal monitor
R6-2611#
*Mar  1 00:09:40.159: RAS INCOMING ENCODE BUFFER::= 27881D1400F00038003200360039003400440041004300300030003000300030003000300032010300533533300203007388A3540600520033002D003300380032003500A0002A40B500001280C680000010A901810E184953444E20302F312F303A313580AC00A949414D2C0D0A50524E2C6973646E2A2C2C515349472A2C0D0A5553492C726174652C632C732C632C310D0A5553492C6C6179312C616C61770D0A544D522C30300D0A43504E2C30302C2C752C323030323030300D0A43474E2C30302C2C752C792C322C343035353730320D0A4350432C30390D0A4643492C2C2C2C2C2C2C792C0D0A4743492C62616536616437633634303431316466383033343030323663626561393830300D0A0D0A0100BAE6AD7C640411DF80340026CBEA980008E0200001801100BAE749A4640411DF80F5B26442D10AB40100
*Mar  1 00:09:40.167:
*Mar  1 00:09:40.171: RAS INCOMING PDU ::=

value RasMessage ::= admissionRequest :
    {
      requestSeqNum 7445
      callType pointToPoint : NULL
      callModel direct : NULL
      endpointIdentifier {"82694DAC00000002"}
      destinationInfo
      {
        e164 : "2002000"
      }
      srcInfo
      {
        e164 : "4055702",
        h323-ID : {"R3-3825"}
      }
      bandWidth 160
      callReferenceValue 42
      nonStandardData
      {
        nonStandardIdentifier h221NonStandard :
        {
          t35CountryCode 181
          t35Extension 0
          manufacturerCode 18
        }
        data '80000010A901810E184953444E20302F312F303A...'H
      }
      conferenceID 'BAE6AD7C640411DF80340026CBEA9800'H
      activeMC FALSE
      answerCall FALSE
      canMapAlias TRUE
      callIdentifier
      {
        guid 'BAE749A4640411DF80F5B26442D10AB4'H
      }
      willSupplyUUIEs FALSE
    }

*Mar  1 00:09:40.191: H225 NONSTD INCOMING ENCODE BUFFER::= 80000010A901810E184953444E20302F312F303A313580AC00A949414D2C0D0A50524E2C6973646E2A2C2C515349472A2C0D0A5553492C726174652C632C732C632C310D0A5553492C6C6179312C616C61770D0A544D522C30300D0A43504E2C30302C2C752C323030323030300D0A43474E2C30302C2C752C792C322C343035353730320D0A4350432C30390D0A4643492C2C2C2C2C2C2C792C0D0A4743492C62616536616437633634303431316466383033343030323663626561393830300D0A0D0A0100
*Mar  1 00:09:40.199:
*Mar  1 00:09:40.199: H225 NONSTD INCOMING PDU ::=

value ARQnonStandardInfo ::=
    {
      sourceAlias
      {
      }
      sourceExtAlias
      {
      }
      callingOctet3a 129
      interfaceSpecificBillingId "ISDN 0/1/0:15"
    }

*Mar  1 00:09:40.203: RAS OUTGOING PDU ::=

value RasMessage ::= admissionReject :
    {
      requestSeqNum 7445
      rejectReason calledPartyNotRegistered : NULL
    }

*Mar  1 00:09:40.207: RAS OUTGOING ENCODE BUFFER::= 2C1D1400
*Mar  1 00:09:40.207:

Silver

Re: Gatekeeper config help

This one is not coming with techprefix

  destinationInfo
      {
        e164 : "2002000"
      }

make sure the voip dial-peer that is pointing to GK has "tech-prefix 1# command configured

thanks

- abu

Community Member

Re: Gatekeeper config help

R6-2611#show gatekeeper gw-type-prefix
GATEWAY TYPE PREFIX TABLE
=========================
Prefix: 1#*
  Zone R6-2611 master gateway list:
    172.31.1.3:1720 R3-3825
  Zone R6-2611 prefix 405* priority gateway list(s):
   Priority 10:
    172.31.1.3:1720 R3-3825
  Zone R6-2611 prefix 200* priority gateway list(s):
   Priority 5:
    172.31.1.3:1720 R3-3825

--------------------------------------------------------------------

check out the prefix taken is 200* not the 202* like you wanted to configure it.

hth

255
Views
0
Helpful
5
Replies
CreatePlease to create content