Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Gateway and incoming call issues with CUCM over VPN

Hello All,


I'm trying to setup a site-to-site VPN with a CUCM 6 server on one end.  There is an h.323 gateway at each site with FXO connectivity to the PSTN.  On site A, the site with the CUCM, everything works perfectly.  The phones register to the CUCM server, incoming calls from the PSTN hit the gateway and get routed to the CUCM server by the voip dial-peer.  I have line groups, hunt lists, and hunt pilots setup in CUCM.  When I dial in from the PSTN to the second site (site-B), it hits the dial-peer on the gateway, but the hunt list never activates.  Perhaps there is something wrong with the VPN config, not sure.  Phones register successfully on the remote site.  Below is the config for the remote site.  Any suggestions are greatly appreciated.

trunk group  POTS2
hunt-scheme round-robin
!        
!        
!        
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
!        
!        
!        
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g723r63
codec preference 4 g726r16

crypto isakmp policy 10
authentication pre-share
crypto isakmp key berryhill address 173.xx.xx.30
!        
!        
crypto ipsec transform-set berryhill esp-aes esp-sha-hmac
!        
crypto map berryhill 10 ipsec-isakmp
set peer 173.xx.xx.30
set transform-set berryhill
match address 100
!        
!        
!        
!        
!        
!        
!        
interface FastEthernet0/0
description Trunkport
no ip address
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
!        
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.11.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!        
interface FastEthernet0/0.20
encapsulation dot1Q 20 native
ip address 192.168.21.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!        
interface FastEthernet0/1
description WAN, to 851
ip address 173.xx.xx.22 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map berryhill
!        
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 173.xx.xx.17
!        
!        
ip http server
ip http port 8766
no ip http secure-server
ip http path flash:gui
ip nat inside source list NAT_LIST interface FastEthernet0/1 overload
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0/1 overload
!        
ip access-list extended NAT_LIST
permit ip 0.0.0.0 255.255.255.0 any
permit ip 192.168.21.0 0.0.0.255 any
!        
access-list 100 permit ip 192.168.11.0 0.0.0.255 192.168.10.0 0.0.0.255

voice-port 1/0/0
trunk-group POTS2
no battery-reversal
input gain 10
echo-cancel suppressor
no comfort-noise
timing hookflash-out 50
connection plar opx 1201
threshold noise -90
station-id number 8455555551
caller-id enable
!        
voice-port 1/0/1
trunk-group POTS2
no battery-reversal
input gain 10
echo-cancel suppressor
no comfort-noise
timing hookflash-out 50
connection plar opx 1201
threshold noise -90
station-id number 8455555552
caller-id enable
!        
voice-port 1/1/0
trunk-group POTS2
no battery-reversal
input gain 10
echo-cancel suppressor
no comfort-noise
timing hookflash-out 50
connection plar opx 1201
threshold noise -90
station-id number 8455555553
caller-id enable

dial-peer voice 201 voip
destination-pattern 1201
session target ipv4:192.168.10.250

dtmf-relay h245-alphanumeric h245-signal
codec g711ulaw
no vad  
!        
dial-peer voice 101 pots
trunkgroup POTS2
destination-pattern 91[2-9]..[2-9]......
prefix 1

1 REPLY
New Member

Re: Gateway and incoming call issues with CUCM over VPN

Solved the incoming call issue, it was a missing dial-peer.  Now the issue is one-way audio when dialing OUTBOUND using the h.323 gateway at Site B.  The PSTN caller can hear audio from the IP phone, but the IP phone gets no audio from the PSTN.  Possibly NAT?  I'm open to suggestions.

344
Views
0
Helpful
1
Replies
CreatePlease to create content