Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Gateway fails to Config with CUCM7

I am trying to config my 2621 to be a gateway for my CUCM 7.0.  But I can seem to get them to work.  On my  CUCM do I need to select the router or H.232?  Please help:

CCM-Manager Debug

*Mar  1 00:57:37.726: cmapp_xml_process_timer:

*Mar  1 00:57:37.726: cmapp_xml_find_ep_by_name: Checking for ep_name [*]

*Mar  1 00:57:37.726: cmapp_xml_exec_fsm: Endpoint is [*]

*Mar  1 00:57:37.726: cmapp_xml_exec_fsm: endpoint = * state = CMAPP_XML_FILE_DNLD, event = CMAPP_XML_EVT_FILE_DNLD_TIMER

*Mar  1 00:57:37.726: cmapp_xml_file_retry_timer_expired: state = CMAPP_XML_FILE_DNLD, event = CMAPP_XML_EVT_FILE_DNLD_TIMER

*Mar  1 00:57:37.734: cmapp_xml_tftp_download_file: Unable to read file tftp://192.168.1.245/VoiceGateway.jjkkcc.com.cnf.xml, rc=-2

*Mar  1 00:57:37.734: cmapp_xml_get_xml_file: Could not read file tftp://192.168.1.245/VoiceGateway.jjkkcc.com.cnf.xml, len = 0

*Mar  1 00:57:37.734: cmapp_xml_tftp_download_file: Unable to read file tftp:///VoiceGateway.jjkkcc.com.cnf.xml, rc=-2

*Mar  1 00:57:37.738: cmapp_xml_get_xml_file: Could not read file tftp:///VoiceGateway.jjkkcc.com.cnf.xml, len = 0

*Mar  1 00:57:37.738: cmapp_xml_tftp_download_file: Unable to read file tftp:///VoiceGateway.jjkkcc.com.cnf.xml, rc=-2

*Mar  1 00:57:37.738: cmapp_xml_get_xml_file: Could not read file tftp:///VoiceGateway.jjkkcc.com.cnf.xml, len = 0

*Mar  1 00:57:37.742: cmapp_xml_exec_fsm: New state = CMAPP_XML_FILE_DNLD, ep = 8487CDB0

CCM Manager

MGCP Domain Name: jjkkcc.com

Priority        Status                   Host

============================================================

Primary         Registering with CM      192.168.1.245

First Backup    None

Second Backup   None

Current active Call Manager:    None

Backhaul/Redundant link port:   2428

Failover Interval:              30 seconds

Keepalive Interval:             15 seconds

Last keepalive sent:            00:39:38 UTC Mar 1 2002 (elapsed time: 00:20:42)

Last MGCP traffic time:         00:59:57 UTC Mar 1 2002 (elapsed time: 00:00:23)

Last failover time:             None

Last switchback time:           None

Switchback mode:                Graceful

MGCP Fallback mode:             Not Selected

Last MGCP Fallback start time:  None

Last MGCP Fallback end time:    None

MGCP Download Tones:            Disabled

TFTP retry count to shut Ports: 2

Configuration Auto-Download Information

=======================================

No configurations downloaded

Current state: Downloading XML file

Configuration Download statistics:

        Download Attempted             : 1

          Download Successful          : 0

          Download Failed              : 0

          TFTP Download Failed         : 18

        Configuration Attempted        : 0

          Configuration Successful     : 0

          Configuration Failed(Parsing): 0

          Configuration Failed(config) : 0

Last config download command:

Configuration Error History:

FAX mode: cisco

Running Config

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VoiceGateway

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable password cisco

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

ip domain name jjkkcc.com

ip name-server 192.168.1.250

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-2731642326

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2731642326

revocation-check none

rsakeypair TP-self-signed-2731642326

!

!

crypto pki certificate chain TP-self-signed-2731642326

certificate self-signed 01

  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32373331 36343233 3236301E 170D3032 30333031 30303430

  32315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37333136

  34323332 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100EF22 8B37729A 73F6BE43 50AB088C EB3B5C5D 38E8A91C E61513BC 1E10F175

  2BE25620 39A9DFC8 811E6EBE 13D04CF1 F8FBC2EA 4B7D353C B4B82224 0667B6ED

  9E662C26 9B3B9873 09CF4ABA 7C0B7F48 5F820F4A B4D6ABB7 C9D7FA30 7BF394F5

  8D918E38 95220282 6B35D73B DD04A506 9C6D660E C9889655 04414F56 049282C4

  127F0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603

  551D1104 1B301982 17566F69 63654761 74657761 792E6A6A 6B6B6363 2E636F6D

  301F0603 551D2304 18301680 14B97015 A4BF731B 46B280A8 938521A9 8C1643B2

  D1301D06 03551D0E 04160414 B97015A4 BF731B46 B280A893 8521A98C 1643B2D1

  300D0609 2A864886 F70D0101 04050003 81810051 0BF18489 4C9D92C2 2FFB7502

  0C9BE7A2 056509ED 5DEECDD8 4B70057B 9F4B65CA F3076E76 0469D937 DAC9018B

  E31FAC07 7CC2655D FA29ACC3 70C069F9 14CE6AF1 E74C3904 797C0520 63CE6146

  82A1BB71 169ABE81 02CF527E DA46C3F6 0540FFE7 2BF494FD B6F20CD9 38250CB6

  83920441 ACAC4E8B 01C951F1 A1C31D18 07B092

  quit

username admin privilege 15 secret 5 $1$TZgR$FNkiy1bLFvT4W/FmPegTd/

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.118 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

!

interface Serial0/0.51 point-to-point

ip address 10.1.12.5 255.255.255.0

frame-relay interface-dlci 501

!

interface FastEthernet0/1

ip address 30.0.36.1 255.255.255.0

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.1.119

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

!

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 192.168.1.245

ccm-manager config

!

mgcp

mgcp call-agent 192.168.1.245 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp validate domain-name

no mgcp explicit hookstate

!

mgcp profile default

!

!

!

dial-peer voice 101 pots

service mgcpapp

port 1/1/0

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

!

CUCM7.jpg

Everyone's tags (1)
7 REPLIES

Gateway fails to Config with CUCM7

Hi,

you should add the name as "VoiceGateway", it is the hostname of the router. and add the domain name as "jjkkcc.com"

this will solve your registration issue

HTH

Anas

please rate all helpful posts

New Member

Gateway fails to Config with CUCM7

Routers Hostname is VoiceGateway

Domain on CUCM is set as jjkkcc.com

Where should the name VoiceGateway be added, CUCM only give me the domain option.

Gateway fails to Config with CUCM7

in the domain name write it as the below

VoiceGateway.jjkkcc.com

HTH

Anas

please rate all helpful posts

New Member

Gateway fails to Config with CUCM7

Awesome, looks like that did the trick...Las question, why is the IP address blank on my CUCM gateway page for the 262?

Gateway fails to Config with CUCM7

click on the see endpoints, can you find ip address ?

if you run show ccm-manager, what is the output on the gateway ?

Anas

New Member

Gateway fails to Config with CUCM7

They are there, thanks

Re: Gateway fails to Config with CUCM7

Hi Jonthan,

great.

kindly don't forget to rate the helpful posts. this will help the community

thanks in advance

366
Views
15
Helpful
7
Replies
CreatePlease to create content