cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6437
Views
0
Helpful
2
Replies

GNS3 and problem with VLANs on c3700

marton225
Level 1
Level 1

Hi,

I have some problems with setup VLANs in GNS3.

The network topology is as on picture:

2011-12-14_223852.png

with following details:

- router c3700 for CME with VOICE IOS c3725-adventerprisek9-mz.124-15.T7.bin

- router c3700 with NM-16ESW module for simulating switch

- 2x Cisco IP Communicator in VLAN 20

- 2x PC in VLAN 10

The problem is starting during setup VLANs on router c3700 with NM-16ESW module.

When I try to set following:

SW1(config)#vlan 10

SW1(config-vlan)#name DATA

SW1(config-vlan)#vlan 20

SW1(config-vlan)#name VOICE

SW1(config)#interface range fastEthernet 1/0 - 1

SW1(config-if-range)#switchport mode access

SW1(config-if-range)#switchport access vlan 10

SW1(config-if-range)#switchport voice vlan 20

SW1(config-if-range)#spanning-tree portfast

SW1(config-if-range)#end

The VLAN 10 and VLAN 20 are assigned to ports fa 1/0 fa 1/1 as stated below.

In this situation PC1 from VLAN 10 can not ping PC2 in VLAN 20:

SW1#show vlan-switch

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa1/2, Fa1/3, Fa1/4, Fa1/5

                                                Fa1/6, Fa1/7, Fa1/8, Fa1/9

                                                Fa1/11, Fa1/12, Fa1/13, Fa1/14

                                                Fa1/15

10   DATA                             active    Fa1/0, Fa1/1

20   VOICE                            active    Fa1/0, Fa1/1

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

I tried the same scenario with Packet Tracer and there it works flawlessly.

In this situation PC1 from VLAN 10 can ping PC2 in VLAN 20:

SW1#show vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/4, Fa0/5, Fa0/6, Fa0/7

                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11

                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15

                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19

                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23

                                                Fa0/24, Gig1/1, Gig1/2

10   DATA                             active    Fa0/2, Fa0/3

20   VOICE                            active   

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

The subinterfaces on CME router are configured properly on same way in GNS3 and Packet Tracer.

What do you suggest?

Best regards,

Tony

2 Replies 2

alitadir
Level 1
Level 1

Hi Tony, I think you have to configure the switch port which connected to the CME router as a trunk. If you configured it properly, it will work.

interface fasthernet 1/10

switchport trunk encapsulation dot1q

switchport mode trunk

!

Hope this helps

Ali TADIR

Hi,

I have already set trunk on fa1/10 of SW1 interface.

My PC is on 192.168.1.0 network, and it is place from where I am trying to realize ping toward GNS3.

Network that connects CIPC and SW1 is on 192.168.1.0 /24 network, and it is same network between my PC and GNS3.

Ping normally works to 192.168.1.10 subinterface, but it doesn't work toward 192.168.2.10 subinterface.

If I change network between PC and GNS3 to 192.168.2.0 /24 (then it become same network between CIPC and SW1).

Then I need to put switchport access to vlan 20,  and in this case I am able to ping 192.168.2.10 subinterface, but not 192.168.1.10 subinterface

SW1(config)#interface range fastEthernet 1/0 - 1

SW1(config-if-range)#switchport mode access

SW1(config-if-range)#switchport access vlan 20

SW1(config-if-range)#switchport voice vlan 10

SW1(config-if-range)#spanning-tree portfast

SW1(config-if-range)#end

For more clearly understanding below are startup config from CME router and SW1 switch:

CME startup config:

version 12.4

hostname CME

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.10

description DATA VLAN

encapsulation dot1Q 10

ip address 192.168.1.10 255.255.255.0

!

interface FastEthernet0/0.20

description VOICE VLAN

encapsulation dot1Q 20

ip address 192.168.2.10 255.255.255.0

!

interface Serial0/0

no ip address

shutdown

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

SW1 startup config:

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SW1

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

clock rate 2000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet1/0

switchport access vlan 10

switchport voice vlan 20

spanning-tree portfast

!

interface FastEthernet1/1

switchport access vlan 10

switchport voice vlan 20

spanning-tree portfast

!

interface FastEthernet1/2

!

interface FastEthernet1/3

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

description CONNECTION TO THE CME ROUTER

switchport mode trunk

duplex full

speed 100

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

Best regards,

Tony

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: