Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

H.323 and MGCP Gateway

Hello Guys,

I just need a confirmation on this question: Can a single router (3845) be configured for both H.323 and MGCP Gateways?

Thank you.

  • IP Telephony
5 REPLIES
Blue

H.323 and MGCP Gateway

Hi

Yes you can configure it.

Regards

Ronak patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: H.323 and MGCP Gateway

Hello,

Thank you Ronak.

The issue is that I have been trying to configure an FXS port connected to an analogue telephone line. I ghave done the MGCP and CUCM configuration.

When I called the analogue number from a Cisco Phone, it is ringing but not heard on the analogu phone. If the analogue phone is off hook, there is no dialing tone.

Anyone with a possible solution should kindly assist.

Thank you.

Cisco Employee

Re: H.323 and MGCP Gateway

Please post the FXS port config. Running config of router would be great to have.

GP.

New Member

Re: H.323 and MGCP Gateway

Find below the router configuration:

Building configuration...

Current configuration : 12511 bytes

!

! No configuration change since last restart

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service compress-config

service sequence-numbers

!

!

boot-start-marker

boot system flash:c3845-ipvoicek9-mz.124-25f.bin

boot system tftp )# 255.255.255.255

boot system tftp c3845-ipvoice-mz.124-24.T3.bin 192.168.20.131

boot-end-marker

!

aaa new-model

!

!

aaa authentication login default group tacacs+ line enable

aaa authentication enable default group tacacs+ enable

aaa authorization config-commands

aaa authorization exec default group tacacs+ if-authenticated

aaa authorization commands 1 default group tacacs+ none

aaa authorization commands 15 default group tacacs+ none

aaa accounting update newinfo

!

aaa session-id common

clock timezone GMT 1

network-clock-participate wic 0

network-clock-participate wic 2

network-clock-select 1 E1 0/0/0

network-clock-select 2 E1 0/2/0

no ip source-route

ip cef

!

!

!

no ip domain lookup

ip domain name ng.sbicdirectory.com

isdn switch-type primary-qsig

voice-card 0

no dspfarm

!

!

!

!

voice service voip

h323

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 3 g729r8

codec preference 4 g711ulaw

!

!

voice class h323 1

h225 timeout setup 30

!

!

!

!

!

!

!

!

!

archive

log config

  hidekeys

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 0/2/0

pri-group timeslots 1-31

!

!

interface Loopback0

ip address 192.168.253.73 255.255.255.255

!

interface GigabitEthernet0/0

description ******** CONNECTION TO IDEJO SERVER FARM LAN ********

ip address 192.168.20.10 255.255.255.0

duplex half

speed 100

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

!

!

voice-port 0/0/0:15

voice-port 0/2/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 192.168.10.17

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.10.9 

ccm-manager config

!

mgcp

mgcp call-agent 192.168.10.9 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability gm-package

no mgcp package-capability dtmf-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer voice 1 voip

destination-pattern 7...

session target ipv4:192.168.10.9

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 30 pots

destination-pattern 0

direct-inward-dial

port 0/0/0:15

forward-digits all

!

dial-peer voice 60 voip

destination-pattern 6...

session target ipv4:192.168.10.9

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 5 voip

destination-pattern 5...

session target ipv4:192.168.10.9

dtmf-relay h245-alphanumeric

codec g711alaw

!

dial-peer voice 101 pots

destination-pattern 9T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 0/2/0:15

dial-peer voice 7470 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

Blue

Re: H.323 and MGCP Gateway

Hi,

Please use service MGCPAPP and not service mgcpapp. It is case sensitive.

Regards

Ronak Patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
368
Views
0
Helpful
5
Replies
This widget could not be displayed.