Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

H323 Cause Value=41

Hi All,

Kindly note that we have the below topology:

PSTN---->H323 VGW-1(E1)----->CUCM 8.5------>UCCX 8.5------>Agent (CAD & CIPC)

but we have a problem that some calls answered by the the agent but after some time it disconnected with Disconnect Cause=41 & Disconnect Cause=31.

and the configuration on VGW-1 like below:

hostname VOICE-GATEWAY-1

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 0

!

no aaa new-model

clock timezone Amman 2 0

network-clock-participate wic 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

isdn switch-type primary-4ess

!

crypto pki token default removal timeout 0

!

!

voice-card 0

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

!

voice class codec 2

codec preference 1 g711alaw

codec preference 2 g711ulaw

!

voice class h323 10

  h225 timeout tcp establish 3

!

!

!

!

voice translation-rule 1

rule 1 /5679141/ /*150/

rule 2 /5100731/ /7311/

rule 3 /5100732/ /7024/

!

voice translation-rule 2

rule 1 /7.../ /5679141/

rule 2 /7311/ /5100731/

!

voice translation-rule 3

rule 1 /\(.*\)/ /9\1/

!

!

voice translation-profile INC

translate calling 3

translate called 1

!

voice translation-profile OUT

translate calling 2

!

voice translation-profile Prefix_9

translate calling 3

!

!

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

!

redundancy

!

!

controller E1 0/0/0

pri-group timeslots 1-31

!

bridge irb

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.19

encapsulation dot1Q 19

bridge-group 19

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

bridge-group 20

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.19

encapsulation dot1Q 19

bridge-group 19

!

interface GigabitEthernet0/1.20

encapsulation dot1Q 20

bridge-group 20

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

interface BVI19

ip address 192.168.19.1 255.255.255.0

!

interface BVI20

ip address 192.168.20.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.20.1

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.20.3

!

!

!

!

control-plane

!

bridge 19 protocol ieee

bridge 19 route ip

bridge 20 protocol ieee

bridge 20 route ip

!

voice-port 0/0/0:15

!

voice-port 0/1/0

echo-cancel coverage 64

shutdown

!

voice-port 0/1/1

!

no ccm-manager fax protocol cisco

!

no mgcp package-capability res-package

no mgcp timer receive-rtcp

!

mgcp profile default

!

!

dial-peer voice 2 pots

translation-profile incoming INC

incoming called-number .

direct-inward-dial

!

dial-peer voice 150 voip

preference 2

destination-pattern *150

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

session target ipv4:192.168.20.10

voice-class codec 2 

voice-class h323 10

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 151 voip

preference 1

destination-pattern *150

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

session target ipv4:192.168.20.11

voice-class codec 2 

voice-class h323 10

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1 voip

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

dial-peer voice 9 pots

destination-pattern 9T

port 0/0/0:15

!

dial-peer voice 7000 voip

preference 1

destination-pattern 7...

session target ipv4:192.168.20.11

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

!

!

gateway

media-inactivity-criteria rtp

timer media-inactive 10

timer receive-rtp 1200

!

!

gatekeeper

shutdown

!

!

telephony-service

max-conferences 8 gain -6

transfer-system full-consult

!

!

ntp master 9

ntp update-calendar

ntp server ip 192.168.20.3

end

VOICE-GATEWAY-1#sh version

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc1).

Everyone's tags (2)
8 REPLIES

H323 Cause Value=41

Temporary failure

Typical scenarios include:

Network failure.

41

Indicates that the network is not functioning correctly and that the condition is likely to be resolved quickly.

Voice CCIE #37771

H323 Cause Value=41

So the Problem is in the network, and there is no prolem in the configuration.

and if the problem in the network, why the problem happened in some calls, and how to know where is the problem, and kindly note that there in no firewall between the CUCM, VGW, and Agents.

H323 Cause Value=41

it seems so yes, any the problem with network errors is it is also intermittend, maybe the qos is not working 100% and when the load on the network gets to high.

If the FW had an issue all calls would have been dropped unless there is some sort of bw setting for qos on the FW

Voice CCIE #37771

H323 Cause Value=41

Network_1.jpg

This is our network topology, and we are not configured the QoS because all calls on the lan, and the calls dropped in time that there few number of calls.

H323 Cause Value=41

any spanning tree setup on the network?

Voice CCIE #37771

Re: H323 Cause Value=41

yes, and we configure the core-1 as the root bridge, and you can see the sh spanning-tree & sh runn in the attachment, but there is a strange issue on the switches, the issue is the switches see non physical neighbor in the show cdp neighbor you can see that on Agents_sw_1.txt, and i am sure that there no hub between them, and thank you.

H323 Cause Value=41

The problem was on the Agent PC that was block the traffic from the VGW to the CIPC.

H323 Cause Value=41

in sort then it was a network issue, the PC was blocking the network....

Voice CCIE #37771
1330
Views
0
Helpful
8
Replies
CreatePlease to create content