Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

h323 gateway registration with CCM 6

hi.i have very strange problem.im tring to add a h323 gateway to ccm6 i have created every thing(device pool,CCM group,region,date/time) and any thing that should be done befor adding a h323 gateway and i have configured my gateway with this commands:gateway,voice class h323 1-->h225 timeout tcp establish 3 . whene i want to add this device as a gateway in device name i enter device ip address and i set other parameters such as device pool and so on.whene its done in the gateway list may device ip address is UNKNOWN and my device status is UNKNOWN too... why this is!? please help me ..do i need more configuration on my gateway or...

19 REPLIES

Re: h323 gateway registration with CCM 6

H.323 gateways do not register with the call manager, so the status will always show as "unknown".

H.323 uses a peer-to-peer model. You perform most of the configuration through the IOS software on the voice gateway device. With the peer-to-peer model, Call Manager does not have control over the gateway, which limits the Call Manager feature support on H.323 gateways. For example, H.323 gateways do not support call survivability, and only devices that support H.323 version 2 (H.323v2) can take advantage of CallManager supplementary services, suck as hold, transfer, and conference features. However, H.323 gateways support additional IOS features outside of CallManager that other gateways do not, such as call admission control, fractional PRI support, FXO caller-ID support, NFAS signaling, and Cisco Survivable Remote Site Telephony (SRST).

taken from Authorized Self Study Guide Cisco IP Telephony (CIPT) Cisco Press

Hope that helped.

New Member

Re: h323 gateway registration with CCM 6

thanks.but another question.what about ip phones?! im trying too add theme else but after seting all parameters and phone mac address i get UNKNOWN for ip phone.truth is im using soft phone so do i need any configuration dor ephone on gateeway router to force the phone to register with CCM(i mean CCM not CCME,i did it well)but with geting register the ephone with ccm i got this problem.thanks.im waiting...

Re: h323 gateway registration with CCM 6

The IP phones should register with the call manager, even though the h.323 gateway doesnt.

Can you post the config of your gateway by any chance?

New Member

Re: h323 gateway registration with CCM 6

CCM-GW#sh runn

Building configuration...

Current configuration : 870 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CCM-GW

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 11.11.11.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

router ospf 100

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

network 11.11.11.0 0.0.0.255 area 0

!

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

gateway

timer receive-rtp 1200

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

CCM is on fa 0/0 and ephone is on a computer that connects to router via fa 0/1

Re: h323 gateway registration with CCM 6

Is the call manager providing dhcp services, do you have a voice vlan configured? Of course you know that the MAC address for the softphone is going to be the MAC address of the NIC card in your PC. Your config appears to be incomplete as far as getting the phones to register.

New Member

Re: h323 gateway registration with CCM 6

ok.when i want to register ephone with ccm i put the mac address of ephone with ephone 1,ephone-dn and other configurations and then walla!! ephone get registers.but here is the thing when i want to add ephone to ccm directly not to CME then should i use ephone command on gateway or not if not then why is my configuratin incomplete?!?! thanks

Re: h323 gateway registration with CCM 6

If you want the phone to register with CCM, the configuration of the phone is done in the CCM. But my question to you is, where are the phones getting their IP address from? I dont see any dhcp scope configured on your router, so I can only assume that the phone will get its IP address from the dhcp scope configured on the call manager, if you have one configured. If not, you need to have a dhcp scope configured on the gateway.

New Member

Re: h323 gateway registration with CCM 6

i said im using Ephone so i say-->the ephones ip address is computer nic ip address.is this true or no?!am i wrong?thanks

Re: h323 gateway registration with CCM 6

ephone is CME terminology, and yes, you are correct, the softphone ip is the same as the computer ip...my bad, i forgot you were using IP communicator....where in the phone registration process does it stop (configuring vlan, configuring IP, etc)??

New Member

Re: h323 gateway registration with CCM 6

i didnt configured any vlan on router .my ephone is instaled on a pc and that pc in connected to fa 0/1 problem is when i try to add the phone and when i give the mac address in phones list my 7960 ephone status is unknown and ip address of the ephone is unknown to? why is this? ccm cant find ephone ip address based on mac address that i gave it??!!

Re: h323 gateway registration with CCM 6

What exactly kind of softphone is this? is is Cisco soft phone, cisco IP communicator, etc?

New Member

Re: h323 gateway registration with CCM 6

it is blue ip phone.it is full functional.i can register it with cme but with ccm no.ccm dosent get ephone ip address.i dont know why?

Re: h323 gateway registration with CCM 6

Im assuming you are using a windows box, try turning windows firewall off if it is on. Oh, also check the settings of your softphone and see what it has configured for TFTP server.

New Member

Re: h323 gateway registration with CCM 6

it is windows but firewall is tottaly off.ok after this information exchange and taking your time,with this information that im using ephone and that was my gateway configuration did i mised something?do i need any thing else to configure on gateway or ccm???thanks

Re: h323 gateway registration with CCM 6

check the settings on your "ephone", the TFTP server address should be the IP address of your call manager. Otherwise, I cant think of anything else that should prevent the phone from registering. I am assuming that you can ping the call manager from your computer.

New Member

Re: h323 gateway registration with CCM 6

yes my tftp address is my ccm address and i can ping it from pc.im confused i think i have to get some try and error stuf to find it out.thanks for your help and time.

Re: h323 gateway registration with CCM 6

No problem, sorry I couldnt assist you further.

One last thing, I noticed that your interface that connects to the call manager needs to have an h323 bind statement.

h323-gateway voip bind srcaddr [ip of interface that you identified the gateway by in CCM]

Cisco Employee

Re: h323 gateway registration with CCM 6

i'm a little unclear on this.

so, you're using CUCM, right? which version?

what kind of phone are you trying to use? a Cisco IP Communicator or a hard phone? i mean a 7960/7940, etc?

to what device is either phone connected to? a router directly or a switch?

are the phones already configured in CUCM? or are you using auto-registration?

what does the phone shows in the screen? what message?

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi

Re: h323 gateway registration with CCM 6

Jaime, I believe he is using an IP soft phone simulator that is supposed to emulate a 7960(he says its a blue IP phone), at least thats what i gather from what he says. The CUCM is in port fa0/0 and his pc is plugged into port fa0/1.

857
Views
0
Helpful
19
Replies
CreatePlease to create content