Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

handle the incoming call to the voicegateway to be routed for DN

Hi All;

The voicegateway is AS5350

I have six E1s (controller E1 3/0-5), and I need to handle the incoming call to be routed for an DN 6998 (which actually JTAPI mapped to the ICM script at the IPCC enterprise). Actually the provider told us that our number is 99880011 (which will be routed to the E1s), and it is directed to all our E1s (so as I understand it might come to any of those E1s).

To handle the incoming call and route it for DN6998, what is the needed command to be used? And to be typed under all the interfaces or it can be typed as a global for all the interfaces without need to repeat it for each interface?

Any advise?

Regards

Bilal

7 REPLIES
Super Bronze

Re: handle the incoming call to the voicegateway to be routed fo

Hi

You should post your gateway config to get an accurate answer.

Basically (assuming your circuits are already configured and working through this gateway) you will need to modify your dial-peers or add new ones to route this new number.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: handle the incoming call to the voicegateway to be routed fo

I think there is a confusion:

I am talking about Inbound and not outbound.

People will call our company number, and this will come to the voice gateway which is connected to those E1s, once the call come, we need to direct it for the DN.

Are we going to use PLAR?

Why I need a dial peer? It is incoming call and not outgoing.

Thanks

Regards

Bilal

Super Bronze

Re: handle the incoming call to the voicegateway to be routed fo

The call comes in from the PSTN, and goes out to UCCE, correct?

You therefore have both inbound and outbound peers.

I would suggest you start reading up on how these things work; start with something like this:

http://www.ciscosystems.com/en/US/docs/ios/voice/dialpeer/configuration/guide/vd_dp_overview_ps6350_TSD_Products_Configuration_Guide_Chapter.html

PLAR is used in scenarios where you want a given off-hook event to generate a call to a preconfigured number. As you are on a digital circuit that may carry several different inbound numbers, this will almost certainly not be appopriate... unless you would like all your inbound numbers to go to a single destination?

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: handle the incoming call to the voicegateway to be routed fo

Yes I need all my numbers to go for certain destination (the mentioned DN).

Any advise?

Super Bronze

Re: handle the incoming call to the voicegateway to be routed fo

Hi


Yes - read the documentation as suggested earlier...

Or post back your config as suggested earlier so we can provide you a solution.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: handle the incoming call to the voicegateway to be routed fo

Kindly find below my voice gateway configuration, also please note that we have one call manager as publisher and two as subscribers while their IP addresses are (publisher 172.16.108.129, subscriber 172.16.108.130, subscriber 172.16.108.131).

ZAIN-CVP-VG02#show running-config    
Building configuration...


Current configuration : 3142 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ZAIN-CVP-VG02
!
boot-start-marker
boot system flash:c5350-is-mz.124-15.T10.bin
no boot startup-test
boot-end-marker
!
enable secret 5 $1$NREf$leS8e/KQUgmmnNIcipgJR0
!
!
!
resource-pool disable
no aaa new-model
voice-card 1
no local-bypass
!
voice-card 2
no local-bypass
!
voice-card 3
!
!
!
ip cef
!
!
multilink bundle-name authenticated
isdn switch-type primary-ni
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
archive
log config
  hidekeys
iua
  AS ZAIN-CVP-VG02 10.151.109.8 10.151.109.134 9900
   ASP ZAIN-CVP-PGW1 AS ZAIN-CVP-VG02  10.151.109.3 10.151.109.129 9900
   ASP ZAIN-CVP-PGW2 AS ZAIN-CVP-VG02  10.151.109.4 10.151.109.130 9900
!
!
controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31 nfas_d primary nfas_int 0 nfas_group 0 iua ZAIN-CVP-VG02
description *** E1 from zainss01 CIC 1-31  ***
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31 nfas_d none nfas_int 1 nfas_group 0
description *** E1 from zainss01 CIC 33-63  ***
!
controller E1 3/2
framing NO-CRC4
pri-group timeslots 1-31 nfas_d none nfas_int 2 nfas_group 0
description *** E1 from zainss01 CIC 65-95 ***
!
controller E1 3/3
framing NO-CRC4
pri-group timeslots 1-31 nfas_d none nfas_int 3 nfas_group 0
description *** E1 from zainss01 CIC 97-127   ***
!
controller E1 3/4
framing NO-CRC4
pri-group timeslots 1-31 nfas_d primary nfas_int 4 nfas_group 2 iua ZAIN-CVP-VG02
description *** E1 from zainss01 CIC 129-159   ***
!
controller E1 3/5
framing NO-CRC4
pri-group timeslots 1-31 nfas_d none nfas_int 5 nfas_group 2
description *** E1 from zainss01 CIC 161-191   ***
!
controller E1 3/6
framing NO-CRC4
pri-group timeslots 1-31 nfas_d primary nfas_int 6 nfas_group 3 iua ZAIN-CVP-VG02
description *** E1 from zainss01 CIC 193-223   ***
!
controller E1 3/7
!
!
!
!
interface GigabitEthernet0/0
ip address 10.151.109.8 255.255.255.128
duplex auto
speed auto
negotiation auto
!
interface GigabitEthernet0/1
ip address 10.151.109.134 255.255.255.128
duplex auto
speed auto
negotiation auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial3/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Dchannel3/0
no ip address
encapsulation hdlc
no isdn send-status-enquiry
isdn negotiate-bchan resend-setup
no cdp enable
!
interface Dchannel3/4
no ip address
encapsulation hdlc
no isdn send-status-enquiry
isdn negotiate-bchan resend-setup
no cdp enable
!
interface Dchannel3/6
no ip address
encapsulation hdlc
no isdn send-status-enquiry
isdn negotiate-bchan resend-setup
no cdp enable
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.151.109.126
no ip http server
!
!
!
!
!
!
control-plane
!
!
!
voice-port 3/0:D
!
voice-port 3/6:D
!
voice-port 3/4:D
!
!
!
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
line aux 0
line vty 0 4
password 7 0307585A56581E617A2A
login
!
scheduler allocate 10000 400
end

ZAIN-CVP-VG02#
ZAIN-CVP-VG02#
ZAIN-CVP-VG02#

New Member

Re: handle the incoming call to the voicegateway to be routed fo

The below configuration will work? If yes, then I need to do it for all the controllers or there is a method to do this configuration one time for all the controllers (instead of doing for each controller):

voice-port 3/0:1
connection plar 6998

dial-peer voice 6998 voip
destination-pattern 699.

session target ipv4:172.16.108.129

!--- My publisher Call Manager IP address is 172.16.108.129

If this is fine, then do I need to do the connection plar for other controllers (3/1, 3/2, 3/3, 3/4, 3/5, 3/6) or there is a method to do this configuration one time and will be used for all of them?

Or using the connection plar is wrong? Actually I need to send all the incoming calls at all of these controllers to the same DN which is 6998.

Any advise?

Regards

Bilal

293
Views
0
Helpful
7
Replies