Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Hello all

have  problem   as  incoming  call  failed  this  my   Toplogy     i have   branch A  with  ((  one pbx  and  cisco router_gateway --------  connected  via  Wan  to branche B gateway  connected  to  pBX )

call  to  brance  B failed but  call  for   outgoing  success

all  my  debug  was  done in  Brance  B gateway  i think  problem  in it  so  please   help me

also  all debug  done  during  call to branche B

======================================

======================================

*Jun  5 08:18:50.377: ISDN  Q921d: isdn_from_driver_process: QUEUE_EVENT

*Jun  5 08:18:50.377: ISDN Se0/1/0:15 Q921r: Net RX <-

*Jun  5 08:18:50.377:     000101B1--000000B3

*Jun  5 08:18:50.377: ISDN Se0/1/0:15 Q921d: process_rxdata: Frame sent to L2

*Jun  5 08:18:50.377: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt:

    source_id (0x200), state (0x0),

    dest_id (0x20A), event (0x141),

    sapi (0x0), ces (0x0), call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_pkt (0x1),

    pkt (0x225E983C), msecs (0x0), priority (0xA)

*Jun  5 08:18:50.377: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BEDD8), size (4)

*Jun  5 08:18:50.377:     000101B1--000000B3

*Jun  5 08:18:50.377: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt: Sending from L2

    dest_id = 0, source_id = 512, prim = 141

    priv_ln = 4, int_id = 584537848

  datastart = E7BEDC8, netstart = E7BEDD8, datasize = 20

*Jun  5 08:18:50.377: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BEDC8), size (20)

*Jun  5 08:18:50.381:     22D756F800000200014104AE00000A00000101B1--000003FA

*Jun  5 08:18:50.381: ISDN  Q921d: isdn_from_driver_process: event_count 1

*Jun  5 08:18:50.381: ISDN  L2_CODE: isdn_l2_process: QUEUE_EVENT state = 0

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: handle_mail: received:

    dest_id = 0, source_id = 512, prim = 141

    priv_ln = 4, int_id = 584537848, datasize = 20

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BEDD8), size (20)

*Jun  5 08:18:50.381:     000101B13B9840003C0629C08101671081656FFE--0000063D

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: handle_mail: received data =

*Jun  5 08:18:50.381:     000101B1--000000B3

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 L2_CODE: L2IF_GetDriverID()

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: L2IF_SendprimPkt:

    source_id (0x20A), state (0x7), dest_id (0x200), event (0x140),

    sapi (0x0), ces (0x1),  call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_p (0x1), pkt (0x3D9DF778), msecs (0x0), priority (0xA)

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt:

    source_id (0x20A), state (0x7),

    dest_id (0x200), event (0x140),

    sapi (0x0), ces (0x1), call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_pkt (0x1),

    pkt (0x216AC764), msecs (0x0), priority (0xA)

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(D9E6958), size (4)

*Jun  5 08:18:50.381:     0001016D--0000006F

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt: Sending from L2

    dest_id = 0, source_id = 522, prim = 140

    priv_ln = 4, int_id = 584537848

  datastart = D9E6948, netstart = D9E6958, datasize = 20

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(D9E6948), size (20)

*Jun  5 08:18:50.381:     22D756F80000020A014004AE00010A000001016D--000003C0

*Jun  5 08:18:50.381: ISDN  L2_CODE: isdn_l2_process: TIMER_EVENT

*Jun  5 08:18:50.381: ISDN  Q921d: isdn_l2d_srq_process: QUEUE_EVENT

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 PACKET: handle_l2d_srq_mail: received:

    dest_id = 0x0000, source_id = 0x020A, prim = 0x0140

    priv_ln = 4, int_id = 0x22D756F8, datasize = 4

    line_status[0] = IF_ACTIVE

*Jun  5 08:18:50.381: ISDN Se0/1/0:15 Q921r: Net TX ->

*Jun  5 08:18:50.381:     0001016D--0000006F

*Jun  5 08:18:50.381: ISDN  Q921d: isdn_l2d_srq_process: event_count 1

*Jun  5 08:18:50.381: ISDN  L2_CODE: isdn_l2_process: state (0x0), event_count (1)

*Jun  5 08:18:57.677: ISDN  CDAPI: cdapi_find_tsm found a GTD message IAM,

PRN,isdn*,,QSIG*,

USI,rate,c,s,c,1

USI,lay1,alaw

TMR,00

CPN,00,,1,98555

CGN,00,,1,y,4,166

CPC,09

FCI,,,,,,,y,

GCI,f509b4e7ccef11e28fed001cf6d623b8

:

    end of gtd length is 164

*Jun  5 08:18:57.677: //-1/F509B4E78FED/DPM/dpAssociateIncomingPeerCore:

   Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=98555

*Jun  5 08:18:57.677: //-1/F509B4E78FED/DPM/dpMatchPeertype:

   Is Incoming=TRUE, Number Expansion=FALSE

*Jun  5 08:18:57.677: //-1/F509B4E78FED/DPM/dpMatchCore:

   Dial String=98555, Expanded String=98555, Calling Number=

   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH

*Jun  5 08:18:57.677: //-1/F509B4E78FED/DPM/MatchNextPeer:

   Result=Success(0); Incoming Dial-peer=15 Is Matched

*Jun  5 08:18:57.677: H245 FS OLC INCOMING ENCODE BUFFER::= 0000000E000101800B050001005765BA3242DF80

*Jun  5 08:18:57.677:

*Jun  5 08:18:57.677: H245 FS OLC INCOMING PDU ::=

value OpenLogicalChannel ::=

    {

      forwardLogicalChannelNumber 1

      forwardLogicalChannelParameters

      {

        dataType audioData : g729wAnnexB : 2

        multiplexParameters h2250LogicalChannelParameters :

        {

          sessionID 1

          mediaControlChannel unicastAddress : iPAddress :

          {

            network '5765BA32'H

            tsapIdentifier 17119

          }

          silenceSuppression TRUE

        }

      }

    }

*Jun  5 08:18:57.677: H245 FS OLC INCOMING ENCODE BUFFER::= 400000060401004E0001018012150001005765BA3242DE005765BA3242DF80

*Jun  5 08:18:57.677:

*Jun  5 08:18:57.677: H245 FS OLC INCOMING PDU ::=

value OpenLogicalChannel ::=

    {

      forwardLogicalChannelNumber 1

      forwardLogicalChannelParameters

      {

        dataType nullData : NULL

        multiplexParameters none : NULL

      }

      reverseLogicalChannelParameters

      {

        dataType audioData : g729wAnnexB : 2

        multiplexParameters h2250LogicalChannelParameters :

        {

          sessionID 1

          mediaChannel unicastAddress : iPAddress :

          {

            network '5765BA32'H

            tsapIdentifier 17118

          }

          mediaControlChannel unicastAddress : iPAddress :

          {

            network '5765BA32'H

            tsapIdentifier 17119

          }

          silenceSuppression TRUE

        }

      }

    }

*Jun  5 08:18:57.681: //-1/F509B4E78FED/DPM/dpAssociateIncomingPeerCore:

   Match Rule=DP_MATCH_INCOMING_DNIS; Called Number=98555

*Jun  5 08:18:57.681: //-1/F509B4E78FED/DPM/dpMatchPeertype:

   Is Incoming=TRUE, Number Expansion=FALSE

*Jun  5 08:18:57.681: //-1/F509B4E78FED/DPM/dpMatchCore:

   Dial String=98555, Expanded String=98555, Calling Number=

   Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH

*Jun  5 08:18:57.681: //-1/F509B4E78FED/DPM/MatchNextPeer:

   Result=Success(0); Incoming Dial-peer=15 Is Matched

*Jun  5 08:19:00.305: ISDN  Q921d: isdn_from_driver_process: QUEUE_EVENT

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 Q921r: Net RX <-

*Jun  5 08:19:00.305:     000101B1--000000B3

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 Q921d: process_rxdata: Frame sent to L2

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt:

    source_id (0x200), state (0x0),

    dest_id (0x20A), event (0x141),

    sapi (0x0), ces (0x0), call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_pkt (0x1),

    pkt (0x22725350), msecs (0x0), priority (0xA)

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BEC58), size (4)

*Jun  5 08:19:00.305:     000101B1--000000B3

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt: Sending from L2

    dest_id = 0, source_id = 512, prim = 141

    priv_ln = 4, int_id = 584537848

  datastart = E7BEC48, netstart = E7BEC58, datasize = 20

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BEC48), size (20)

*Jun  5 08:19:00.305:     22D756F800000200014104AE00000A00000101B1--000003FA

*Jun  5 08:19:00.305: ISDN  Q921d: isdn_from_driver_process: event_count 1

*Jun  5 08:19:00.305: ISDN  L2_CODE: isdn_l2_process: QUEUE_EVENT state = 0

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: handle_mail: received:

    dest_id = 0, source_id = 512, prim = 141

    priv_ln = 4, int_id = 584537848, datasize = 20

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BEC58), size (20)

*Jun  5 08:19:00.305:     000101B13BB340003C0629A88101671081656FFE--00000640

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: handle_mail: received data =

*Jun  5 08:19:00.305:     000101B1--000000B3

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 L2_CODE: L2IF_GetDriverID()

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_SendprimPkt:

    source_id (0x20A), state (0x7), dest_id (0x200), event (0x140),

    sapi (0x0), ces (0x1),  call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_p (0x1), pkt (0x3D9DF778), msecs (0x0), priority (0xA)

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt:

    source_id (0x20A), state (0x7),

    dest_id (0x200), event (0x140),

    sapi (0x0), ces (0x1), call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_pkt (0x1),

    pkt (0x3CDCDF90), msecs (0x0), priority (0xA)

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BFCD8), size (4)

*Jun  5 08:19:00.305:     0001016D--0000006F

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt: Sending from L2

    dest_id = 0, source_id = 522, prim = 140

    priv_ln = 4, int_id = 584537848

  datastart = E7BFCC8, netstart = E7BFCD8, datasize = 20

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BFCC8), size (20)

*Jun  5 08:19:00.305:     22D756F80000020A014004AE00010A000001016D--000003C0

*Jun  5 08:19:00.305: ISDN  L2_CODE: isdn_l2_process: TIMER_EVENT

*Jun  5 08:19:00.305: ISDN  Q921d: isdn_l2d_srq_process: QUEUE_EVENT

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 PACKET: handle_l2d_srq_mail: received:

    dest_id = 0x0000, source_id = 0x020A, prim = 0x0140

    priv_ln = 4, int_id = 0x22D756F8, datasize = 4

    line_status[0] = IF_ACTIVE

*Jun  5 08:19:00.305: ISDN Se0/1/0:15 Q921r: Net TX ->

*Jun  5 08:19:00.305:     0001016D--0000006F

*Jun  5 08:19:00.305: ISDN  Q921d: isdn_l2d_srq_process: event_count 1

*Jun  5 08:19:00.305: ISDN  L2_CODE: isdn_l2_process: state (0x0), event_count (1)

*Jun  5 08:19:10.233: ISDN  Q921d: isdn_from_driver_process: QUEUE_EVENT

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 Q921r: Net RX <-

*Jun  5 08:19:10.233:     000101B1--000000B3

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 Q921d: process_rxdata: Frame sent to L2

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt:

    source_id (0x200), state (0x0),

    dest_id (0x20A), event (0x141),

    sapi (0x0), ces (0x0), call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_pkt (0x1),

    pkt (0x224B29D8), msecs (0x0), priority (0xA)

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BF258), size (4)

*Jun  5 08:19:10.233:     000101B1--000000B3

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt: Sending from L2

    dest_id = 0, source_id = 512, prim = 141

    priv_ln = 4, int_id = 584537848

  datastart = E7BF248, netstart = E7BF258, datasize = 20

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BF248), size (20)

*Jun  5 08:19:10.233:     22D756F800000200014104AE00000A00000101B1--000003FA

*Jun  5 08:19:10.233: ISDN  Q921d: isdn_from_driver_process: event_count 1

*Jun  5 08:19:10.233: ISDN  L2_CODE: isdn_l2_process: QUEUE_EVENT state = 0

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: handle_mail: received:

    dest_id = 0, source_id = 512, prim = 141

    priv_ln = 4, int_id = 584537848, datasize = 20

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BF258), size (20)

*Jun  5 08:19:10.233:     000101B13BBD40003C06299E8101671081656FFE--00000640

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: handle_mail: received data =

*Jun  5 08:19:10.233:     000101B1--000000B3

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 L2_CODE: L2IF_GetDriverID()

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_SendprimPkt:

    source_id (0x20A), state (0x7), dest_id (0x200), event (0x140),

    sapi (0x0), ces (0x1),  call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_p (0x1), pkt (0x3D9DF778), msecs (0x0), priority (0xA)

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt:

    source_id (0x20A), state (0x7),

    dest_id (0x200), event (0x140),

    sapi (0x0), ces (0x1), call_id (0x0),

    chan_id (0x0), int_id (0x22D756F8), free_pkt (0x1),

    pkt (0x3D0A8F04), msecs (0x0), priority (0xA)

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BF9D8), size (4)

*Jun  5 08:19:10.233:     0001016D--0000006F

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_SendPkt: Sending from L2

    dest_id = 0, source_id = 522, prim = 140

    priv_ln = 4, int_id = 584537848

  datastart = E7BF9C8, netstart = E7BF9D8, datasize = 20

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: L2IF_DispPak: packet - start(E7BF9C8), size (20)

*Jun  5 08:19:10.233:     22D756F80000020A014004AE00010A000001016D--000003C0

*Jun  5 08:19:10.233: ISDN  L2_CODE: isdn_l2_process: TIMER_EVENT

*Jun  5 08:19:10.233: ISDN  Q921d: isdn_l2d_srq_process: QUEUE_EVENT

Rout_RWH#

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 PACKET: handle_l2d_srq_mail: received:

    dest_id = 0x0000, source_id = 0x020A, prim = 0x0140

    priv_ln = 4, int_id = 0x22D756F8, datasize = 4

    line_status[0] = IF_ACTIVE

*Jun  5 08:19:10.233: ISDN Se0/1/0:15 Q921r: Net TX ->

*Jun  5 08:19:10.233:     0001016D--0000006F

*Jun  5 08:19:10.233: ISDN  Q921d: isdn_l2d_srq_process: event_count 1

*Jun  5 08:19:10.233: ISDN  L2_CODE: isdn_l2_process: state (0x0), event_count (1)

=======================================================

========================================================

Rout_RWH#show dialplan number 98414

Macro Exp.: 98414

VoiceEncapPeer1

    peer type = voice, system default peer = FALSE, information type = voice,

    description = `',

    tag = 1, destination-pattern = `^98...$',

    voice reg type = 0, corresponding tag = 0,

    allow watch = FALSE

    answer-address = `', preference=0,

    CLID Restriction = None

    CLID Network Number = `'

    CLID Second Number sent

    CLID Override RDNIS = disabled,

    rtp-ssrc mux = system

    source carrier-id = `',    target carrier-id = `',

    source trunk-group-label = `',    target trunk-group-label = `',

    numbering Type = `unknown'

    group = 1, Admin state is up, Operation state is up,

    Outbound state is up,

    incoming called-number = `', connections/maximum = 0/unlimited,

    DTMF Relay = disabled,

    URI classes:

        Destination =

    huntstop = disabled,

    in bound application associated: 'DEFAULT'

    out bound application associated: ''

    dnis-map =

    permission :both

    incoming COR list:maximum capability

    outgoing COR list:minimum requirement

    Translation profile (Incoming):

    Translation profile (Outgoing):

    incoming call blocking:

    translation-profile = `'

        disconnect-cause = `no-service'

        advertise 0x40 capacity_update_timer 25 addrFamily 4 oldAddrFamily 4

        mailbox selection policy: none

        type = pots, prefix = `',

        forward-digits 3

        session-target = `', voice-port = `0/1/0:15',

        direct-inward-dial = enabled,

        digit_strip = enabled,

        register E.164 number with H323 GK and/or SIP Registrar = TRUE

        fax rate = system,   payload size =  20 bytes

        supported-language = ''

        preemption level = `routine'

        bandwidth:

            maximum = 64 KBits/sec, minimum = 64 KBits/sec

        voice class called-number:

            inbound = `', outbound = `'

        dial tone generation after remote onhook = enabled

        mobility=0, snr=, snr_noan=, snr_delay=0, snr_timeout=0

        snr calling-number local=disabled, snr ring-stop=disabled, snr answer-too-soon timer=0

        Time elapsed since last clearing of voice call statistics never

        Connect Time = 660, Charged Units = 0,

        Successful Calls = 0, Failed Calls = 0, Incomplete Calls = 0

        Accepted Calls = 1, Refused Calls = 0,

        Last Disconnect Cause is "10  ",

        Last Disconnect Text is "normal call clearing (16)",

        Last Setup Time = 73770867.

        Last Disconnect Time = 73774470.

Matched: 98414   Digits: 4   Matched pattern: ^98...$

Target:  

===========================================================

my configuration

=====>>>>>

Rout_RWH#show running-config

Building configuration...

Current configuration : 7942 bytes

!

! Last configuration change at 09:08:51 UTC Wed Jun 5 2013

version 15.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Rout_RWH

!

boot-start-marker

boot system flash c2900-universalk9-mz.SPA.153-2.T.bin

boot-end-marker

!

!

card type e1 0 1

enable password lan12CZ%33

!

no aaa new-model

network-clock-participate wic 1

!

ip cef

!

!

!

!

!

!

no ip domain lookup

ip domain name cisco.rwh.gmc.com.sa

no ipv6 cef

multilink bundle-name authenticated

!

!        

!        

!        

isdn switch-type primary-qsig

isdn logging

!        

!        

crypto pki trustpoint TP-self-signed-1126290077

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1126290077

revocation-check none

rsakeypair TP-self-signed-1126290077

!        

!        

crypto pki certificate chain TP-self-signed-1126290077

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31313236 32393030 3737301E 170D3132 30363239 31303137

  31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31323632

  39303037 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81009F65 490BDA15 D9548AB0 EFC22B7B D965D68B CAB38B89 7352955B 637ABFAE

  BB438824 84654369 DB6EEFCF 9B978464 A3B3B6D9 3B9438A7 C20C8A25 A23E9AD1

  4A172E5B 0FA2ABA6 E60C9AEF 9E4FCEA0 54EAAE92 D90EC78E E0696519 C1A85C99

  B425F088 3FDF4023 B68677CD 5E41214E AA62B943 99929C80 287FF1E7 8D2939F6

  11B70203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14AAE7C7 4D92628E 07F17D48 4D07BEC8 42F459C4 26301D06

  03551D0E 04160414 AAE7C74D 92628E07 F17D484D 07BEC842 F459C426 300D0609

  2A864886 F70D0101 05050003 8181003E 94051F89 97BD89D8 50378EF5 DB9D8600

  D1624F9A 559AC1E7 B3806480 140C6478 606BEAAB EFC17234 A3BD99EE BB940EFA

  9B3A394D BA52DEA6 413E079B 6C87B194 94331057 8775EDD9 93FCEA2A 7EAAF4BD

  81520758 56F631BC DBF9BD92 A9416D5C BE8E9DE8 EAA62339 F00555FE 1E4E2E77

  D5E64D4C 346E3200 DA54077A 02E2E0

        quit

voice-card 0

codec complexity high

!        

!        

!        

voice service voip

allow-connections h323 to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323    

!        

voice class h323 1

  h225 timeout tcp establish 3

!        

!        

!        

!        

!        

voice translation-profile income

translate called 1

!        

!        

!        

license udi pid CISCO2901/K9 sn FCZ1626C5PH

hw-module pvdm 0/0

!        

!        

!        

username cisco privilege 15 password 0 cisco

!        

redundancy

!        

!        

controller E1 0/1/0

clock source internal

pri-group timeslots 1-6,16

!        

controller E1 0/1/1

!        

ip ftp username anonymous

!        

!        

!        

!        

interface Loopback0

ip address 172.30.8.1 255.255.255.0

!        

interface Embedded-Service-Engine0/0

no ip address

shutdown

!        

interface GigabitEthernet0/0

description ***JED 12-JED12-IP98***$ETH-WAN$

ip address 87.101.203.138 255.255.255.252

duplex full

speed 100

!        

interface GigabitEthernet0/1

ip address 129.101.111.254 255.255.0.0

duplex full

speed 100

!        

interface Serial0/1/0:15

bandwidth 128

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn overlap-receiving T302 1000

isdn protocol-emulate network

isdn incoming-voice voice

!        

router bgp 64537

bgp log-neighbor-changes

neighbor 87.101.191.101 remote-as 35753

neighbor 87.101.191.101 version 4

neighbor 87.101.203.137 remote-as 35753

neighbor 87.101.203.137 version 4

!       

address-family ipv4

  redistribute connected

  neighbor 87.101.191.101 activate

  neighbor 87.101.203.137 activate

exit-address-family

!        

ip default-gateway 129.101.111.254

ip forward-protocol nd

!        

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!        

!        

!        

!        

access-list 23 permit 129.101.103.1

access-list 23 permit 10.10.10.0 0.0.0.7

access-list 23 permit any

!        

control-plane

!        

!        

voice-port 0/1/0:15

!       

!       

!       

!        

!        

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!        

mgcp profile default

!        

!        

dial-peer voice 2 voip

description Jeddah LL

destination-pattern 82

session target ipv4:172.30.1.1

codec g729br8

!        

dial-peer voice 3 voip

description Riyadh

destination-pattern 91

session target ipv4:172.30.2.1

codec g729br8

!        

dial-peer voice 4 voip

description Riyadh LL

destination-pattern 81

session target ipv4:172.30.2.1

codec g729br8

!        

dial-peer voice 5 voip

description Zahran

destination-pattern 93

session target ipv4:172.30.3.1

codec g729br8

!        

dial-peer voice 6 voip

description Zahran LL

destination-pattern 83

session target ipv4:172.30.3.1

codec g729br8

!        

dial-peer voice 7 voip

description JWH

destination-pattern 97

session target ipv4:172.30.7.1

codec g729br8

!        

dial-peer voice 8 voip

description JWH LL

destination-pattern 87

session target ipv4:172.30.7.1

codec g729br8

!        

dial-peer voice 12 voip

description Jeddah

destination-pattern 92...

session target ipv4:172.30.1.1

incoming called-number 98...

codec g729br8

!        

dial-peer voice 9 pots

description Local Line

destination-pattern 88

port 0/1/0:15

forward-digits 7

!        

dial-peer voice 11 pots

description Warehouse LL

destination-pattern 87

direct-inward-dial

port 0/1/0:15

forward-digits 7

!        

dial-peer voice 1 pots

description to_PBX

destination-pattern ^98...$

direct-inward-dial

port 0/1/0:15

forward-digits 3

!        

!        

!        

!        

gatekeeper

shutdown

!        

!        

credentials

!        

!        

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to

use.     

-----------------------------------------------------------------------

^C       

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN

CREDENTIALS

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want

to use.  

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE

TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C       

!        

line con 0

password lan12CZ%33

login   

line aux 0

password lan12CZ%33

login   

line 2   

no activation-character

no exec 

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 0 0

privilege level 15

password lan12CZ%33

logging synchronous

login   

transport input telnet ssh

line vty 5 15

exec-timeout 0 0

password lan12CZ%33

login   

transport input all

!        

scheduler allocate 20000 1000

!        

end      

1 REPLY

Re: Hello all

Hi,

Have you tried use an [incaming called-number .T] in dial peer?

dial-peer voice 10 pots

description [PBX_incoming_dialpeer]

incoming called-number .T

direct-inward-dial

port 0/1/0:15

Other information when you use dial-peer by default strip digit are enable. Please verifiy if the digits are goint to using the command

(show isdn history and show voice call status)

>#show isdn history

output:

---------------------------------------------------------------------------------------------------------------

                                ISDN CALL HISTORY

---------------------------------------------------------------------------------------------------------------

Call History contains all active calls, and a maximum of 100 inactive calls.

Inactive call data will be retained for a maximum of 15 minutes.

---------------------------------------------------------------------------------------------------------------

Call    Calling      Called       Remote  Seconds Seconds Seconds Charges

Type    Number       Number       Name    Used    Left    Idle    Units/Currency

---------------------------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------------------------

best regards

Daniel

Daniel Sobrinho
458
Views
15
Helpful
1
Replies