Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HELP: 8945 SIP to SCCP

I have 8945 SIP phones shipped with firmware SIP9-3-4. Compatibility with CME 9.1-10.0 shows they need 9-2-2 and I'd like to switch to SCCP. Anyone have the procedure for this? The 8945s seem to completely ignore the SCCP loads I have on the ISR. I have the firmware loaded, the paths set, and the device load specified, the DHCP 150/TFTP set and the device reflects this.

 

I have a case with TAC, but I think the SE on the case is a bit green.

 

Thanks,

 

Brian

 

3 REPLIES
Green

Brian, Have you tried

Brian,

 

Have you tried following this link:-

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm/cmeinstl.html#wp1066456

Hope this helps

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Thanks Alex. I had tried the

Thanks Alex. I had tried the procedure but no luck. There's another thread on this topic and all they say is to upgrade the IOS ... but they don't specify a version.  (https://supportforums.cisco.com/discussion/11790641/cp-8945-phone-not-registered)

I'm running 15.2(4)M6 (upgraded from 15.2(4)M5), but that doesn't help. Still waiting on TAC .. which is like watching grass grow.

 

 

 

 

New Member

Okay, problem solved. I had

Okay, problem solved. I had to switch TAC engineers as the first guy was spinning his wheels. SE#2 solved the problem in less than 5 minutes. Lost three days waiting patiently for this. But I digress...

 

Here's the solution:

In short the TFTP-Server paths needed to be updated with an alias.

We changed my TFTP entries from this:

tftp-server flash:/SCCP894x.9-2-2-0.bin1.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin2.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin3.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin4.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin5.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin6.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin7.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin8.sgn
tftp-server flash:/SCCP894x.9-2-2-0.loads
tftp-server flash:/BOOT894x.0-0-0-9.bin.sgn

TO THIS:
tftp-server flash:/SCCP894x.9-2-2-0.bin1.sgn alias SCCP894x.9-2-2-0.bin1.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin2.sgn alias SCCP894x.9-2-2-0.bin2.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin3.sgn alias SCCP894x.9-2-2-0.bin3.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin4.sgn alias SCCP894x.9-2-2-0.bin4.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin5.sgn alias SCCP894x.9-2-2-0.bin5.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin6.sgn alias SCCP894x.9-2-2-0.bin6.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin7.sgn alias SCCP894x.9-2-2-0.bin7.sgn
tftp-server flash:/SCCP894x.9-2-2-0.bin8.sgn alias SCCP894x.9-2-2-0.bin8.sgn
tftp-server flash:/SCCP894x.9-2-2-0.loads alias SCCP894x.9-2-2-0.loads
tftp-server flash:/BOOT894x.0-0-0-9.bin.sgn alias BOOT894x.0-0-0-9.bin.sgn

The 8945 phones immediately upgrade (or downgraded I should say) from SIP 9-3-4 to SCCP 9-2-2, and are now happily registered to CME.

 

Hope this helps someone down the road...

 

Brian

 

116
Views
0
Helpful
3
Replies