Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Hello All,

Could someone point out , what is wrong with this Configuration .

When I removed the Voice-hunt and call 4067062162 from outside the Phone did not ring , but when i replace Voice-hunt
and called again  it rang , but the BACD & AA did not work. The Router Version is Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(1)T,R and CME Version 8.8
I would be glad on your Positive support or clear explanation on what to make it works.;

controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24
!
controller T1 0/0/1
cablelength long 0db
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Connection to FIREWALL ETH Port 1
ip address 10.174.1.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Connection to POE Switch Port 47
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.172
encapsulation dot1Q 172
ip address 10.172.1.1 255.255.255.0
!
interface GigabitEthernet0/1.173
encapsulation dot1Q 173
ip address 10.173.1.1 255.255.255.0
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn outgoing display-ie
!
interface SM1/0
description Internal switch interface connected to Service Module
ip address 10.174.1.10 255.255.255.252
service-module ip address 10.174.1.9 255.255.255.252
!Application: CUE Running on SM
service-module ip default-gateway 10.174.1.10
!
interface SM1/1
description Internal switch interface connected to Service Module
no ip address
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:GUI
!
ip route 0.0.0.0 0.0.0.0 10.174.1.1
ip tacacs source-interface GigabitEthernet0/0
!


ip dhcp pool Voice
network 10.173.1.0 255.255.255.0
domain-name BACD.com
dns-server 172.29.10.72 172.29.10.73
default-router 10.173.1.1
option 150 ip 10.173.1.1
lease 3
!
ip dhcp pool Data
network 10.172.1.0 255.255.255.0
domain-name BACD.com
dns-server 172.29.10.72 172.29.10.73
default-router 10.172.1.1
lease 2

domain-name BACD.com
dns-server 172.29.10.72 172.29.10.73
default-router 10.173.1.1
option 150 ip 10.173.1.1
lease 3
!
ip dhcp pool Data
network 10.172.1.0 255.255.255.0
domain-name BACD.com
dns-server 172.29.10.72 172.29.10.73
default-router 10.172.1.1
lease 2


voice service voip
ip address trusted list
  ipv4 10.173.1.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
  call start slow
modem passthrough nse codec g711ulaw
sip
  registrar server

voice iec syslog
voice hunt-group 10 parallel
final 1003
list 1002,1003,1004,1005,1006,1007,1008,1009,1010,1011,1017,1018,1019,1020,1021,1022,1023,1024,1025
timeout 12
pilot 5000

voice translation-rule 1
rule 26 /^4067062162$/ /5000/
!
voice translation-rule 3
rule 1 // // type any international plan any isdn
!
!
voice translation-profile INCOMING
translate called 2
!
voice translation-profile INTL
translate calling 1
translate called 3
!
voice translation-profile OUTGOING
translate calling 1
!
application
service aa flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  param number-of-hunt-grps 3
  param handoff-string aa
  param dial-by-extension-option 1
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 4067062162
  paramspace english location flash:
  param second-greeting-time 60
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
  param max-time-call-retry 700
  param voice-mail 1234
  param service-name queue
!
service queue flash:app-b-acd-aa-3.0.0.2.tcl
  param aa-hunt3 5003
  param queue-len 15
  param aa-hunt1 5001
  param number-of-hunt-grps 3
  param aa-hunt2 5002
  param queue-manager-debugs 1
!

dial-peer voice 1 pots
translation-profile incoming INCOMING
incoming called-number .
direct-inward-dial
port 0/0/0:23


dial-peer voice 4401 voip
service aa
destination-pattern 4067062162
session target ipv4:10.1.173.1
incoming called-number 4067062162
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 4402 voip
service aa
destination-pattern 4067062162
session target ipv4:10.1.172.1
incoming called-number 4067062162
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 16 pots
service aa
destination-pattern 4067062162
direct-inward-dial
port 0/0/0:23

ephone-hunt 1 sequential
pilot 5001 secondary 4067062162
list 1003, 1004
timeout 2, 2
!
!
ephone-hunt 2 sequential
pilot 5002 secondary 4067062162
list 1005, 1007
timeout 3, 3
!
!
ephone-hunt 3 sequential
pilot 5003 secondary 4067062162
list 1002, 1006, 1008, 1009, 1010, 1011, 1012
timeout 6, 6, 6, 6, 6, 6, 6

Thanks

Dak

Everyone's tags (3)
12 REPLIES
Hall of Fame Super Gold

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Take "debug voice application scripts" with "terminal monitor".

New Member

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Hello Paolo,

I did as you sent ;

but no Output/Result shown. Here is the outcome;

CME-c2921#terminal monitor

CME-c2921#debug voice application scripts

                                                 ^

% Invalid input detected at '^' marker.

CME-c2921#debug voice application script

voip application script debugging is on

CME-c2921#

Thanks

Hall of Fame Super Gold

Re: Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

If no output, the call doesn't go to B/ACD, have a configuration mistake.

You need incoming called-number, not destination-pattern.

With that, you cause tromboning to PRI immediately.

New Member

Re: Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Hello Paolo,

When i tried with the "Incoming called -number " , No call was enable or any ringing coming.

Any idea what could  be please ?

Thanks

New Member

Re: Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Hello

Do you have clue why i received this message;

CME-c2921#audio-prompt load flash:app-b-acd-aa-3.0.0.2.tcl

Reload of flash:app-b-acd-aa-3.0.0.2.tcl status failed

audio-prompt flash:app-b-acd-aa-3.0.0.2.tcl not loaded - open (or format) failure

Hall of Fame Super Gold

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

audio-prompt is for audio files, not the tcl file.

Check what number telco is sending.

New Member

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

I will and get back to you latter

Thanks

New Member

Re: Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

The telco number is the same with pilot number

4067062162

Cheers

Hall of Fame Super Gold

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Check with "debug isdn q931".

New Member

Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Hello Paolo,

I realized some mistake in my configuration "service queue flash:app-b-acd-aa-3.0.0.2.tcl"  are the same for aa & queue , which is wrong.

I will correct this tomorrow and let you know

Cheers,

Dak

New Member

Re: Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

It is getting better ,but need to do some more digging

Here is the result ;

CME-c2921#show call application sessions

Session ID 13E

        Session name: service

            App: queue-TEST

           Type: Service

            Url: flash:app-b-acd-3.0.0.2.tcl

CME-c2921#

DEBUG OUTPUT;

CME-c2921#13 01:07:36.492: //-1//TCL :EE2C04D2AC000:/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<

CME-c2921#Apr 13 01:08:36.608: //-1//TCL :EE2C04D2AC000:/tcl_PutsObjCmd: TCL B-ACD:  >>> B-ACD Service Running <<<

CME-c2921#Apr 13 01:08:45.048: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:  ccAppShutdownMode: remove it from the queue

CME-c2921#

New Member

Re: Help on B-ACD app-b-acd-aa-3.0.0.2.tcl

Here is the Solution

Solution 1

dial-peer voice 1 pots

translation-profile incoming INCOMING

incoming called-number .%==>>This will make incoming call become wildcard that will allowed Pilot number Dial-peer

direct-inward-dial

port 0/0/0:23

Solution 2

dial-peer voice 16 pots
service aa
incoming called-number 4067062162 <<==This needs to be replace  by  incoming called-number
direct-inward-dial
port 0/0/0:23

And finaly in other CME I configured it was due to the number telecom is sending are 6 digit,but not on this one.

Regards,

DaK

2825
Views
0
Helpful
12
Replies