Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Help with config between a VG2xx and a Catalyst switch

I am new to the VoIP world and I have been ask to check our configs on the VG224, VG204, and VG248 and the connections to our Catalyst switches. What I have found is every one is different and I wanted to find out the best practice and correct way to configure the ports both on the VG side and the Catalyst side. The catalyst switches are 6500's and 4500's running IOS. Here are the Catalyst side configs I am seeing....

Site 1

interface GigabitEthernet0/45

description VG204_1

switchport mode access

service-policy output autoqos-voip-policy

qos trust device cisco-phone

qos trust cos

auto qos voip cisco-phone

tx-queue 3

priority high

shape percent 33

Site 2

interface GigabitEthernet2/12

switchport mode access

power inline never

spanning-tree portfast

Site 3

interface FastEthernet5/48

description VG224

switchport mode access

power inline never

spanning-tree portfast

Site 4

interface FastEthernet6/47

switchport

switchport mode access

no ip address

Here is what I am finding on the VG side

interface FastEthernet0/0

ip address 10.23.1.226 255.255.255.0

duplex auto

speed auto

Thoughts?

Mike

5 REPLIES

Re: Help with config between a VG2xx and a Catalyst switch

Actually what I am looking for.....Do I just configure as a normal switch port or do I need any special voice or QOS config? I am thinking I just need to config as a normal switchport.

Mike

Re: Help with config between a VG2xx and a Catalyst switch

The VG248 and VG224 - I would configure as a router. Just a basic switchport with switch mode access, switch access vlan, and spanning-tree port-fast.

The VG202/VG204, you can configure like a phone. I think it's possible for the VG224 also, but I haven't tested those specifically. The VG202/VG204 will use the voice VLAN and you can have them use SCCP auto registration among other things. In short, you can get them to act like normal phones.

hth,

nick

Re: Help with config between a VG2xx and a Catalyst switch

Which would be best....As a phone or just as a switchport.

Do it this way.....

interface GigabitEthernet0/45

description VG204_1

switchport mode access

service-policy output autoqos-voip-policy

qos trust device cisco-phone

qos trust cos

auto qos voip cisco-phone

tx-queue 3

priority high

shape percent 33

Or this way.....

interface GigabitEthernet0/45

description VG204_1

switchport mode access

spanning-tree portfast

Thanks,

Mike

Re: Help with config between a VG2xx and a Catalyst switch

It depends on what you would like to do - if you're running the VG202 in something other than SCCP you wouldn't want to use the SCCP auto registration feature.

Additionally, it may be easier just to configure them like all your other devices. But if you're deploying a few hundred of these you will probably want the auto-registration.

hth,

nick

Re: Help with config between a VG2xx and a Catalyst switch

We have less than 20. I will probally go ahead and config like my other devices.

Thanks for all your help.

Mike

1065
Views
9
Helpful
5
Replies
CreatePlease to create content