Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with multidirectory.asp problem


I've recently installed multidirectory.asp and am attempting to point to 2 clusters running DC Directory.

I created a new service and from an IPC subscribed to the service, I get the

1) All Directory Sear

2) Cluster-1 Directory

3) Cluster-3 Directory

When I select either of the directories, I am taken to the Search criteria page, then when I press submit (either specific or blank) Requesting flashes at the bottom of the screen, then the search page is returned again.

Any ideas? I'm running CCM 4.2(3)



New Member

Re: Help with multidirectory.asp problem

I've also tried this on a CCM 4.1(3) Cluster with a 7960 with the same results ~ Could it be a problem with the LdapUserId & LDAP Password?

I'm using the multidirectory.asp right out of the box as it comes with the 4.1.1 SDK, and the only thing I changed was the LdapServer (tried IP Address & Hostname) ... These are development servers, so I'm still using the default DC Directory login & Password of "directory manager" and "cisco"

I've tried using a separate user under users thought that doesn't want to work either ...

Re: Help with multidirectory.asp problem

We've found different models of phones parse the javascript code differently:

With our setup ccm4.1(3) & 4.? SDK, 7940/7960s work fine with multidirectory whereas 7912s fail as their asp/xml handling isn't as full as the 7940/7960s (so we slightly amended the script so its only run on 7940/7960 whereas anything else uses the standard xmldirectory.asp on the ccm; nb we even had issues with the 7912s understanding that redirect code which was fixed by upgrading their firmware.)

7941Gs also don't work as they handle the code differently (argh!) Trying to work around that now.

For diagnosis worth looking at the IIS webserver logs where the SDK was installed.

Only thing we changed in multidirectory was , & .


(ps anyone know I how I change my forum display name?!)