Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How can I use Cisco 2911 router as a sip proxy server to register as a trunk provider from remote site IP PBX

I have got two offices named Office A and Office B. Office A is using Cisco 2911 Router having trunk lines in it. Cisco 7960 IP phones running Sip firmware registered with this cisco 2911 router using CUCME. The Office B is using non cisco IP PBX registrar server and its own IP Phones. I would Like to connect this non CIsco IP PBX with Office A Cisco 2911 Router using VoIP Trunk. 

I want to create VoIP trunk from office B to Office A  so that B can connect with  Cisco 2911 router trunk lines and local extensions. Peering SIP trunk between Router A and B would be enough or I need to register SIP trunk using authentication credentials. 

Actually main aim of this project is to access Office A analog trunk lines (cisco router) from Office B. 

Can Anyone suggest  outline concept for doing this please. 

 

Thank You

 

Regards

 

 

 

Everyone's tags (3)
6 REPLIES
Cisco Employee

Hi Anupam,It basically

Hi Anupam,

It basically depends upon your non Cisco PBX if it really wants the SIP trunk to be authenticated or not.

In most cases, there won't be a need to register the SIP trunk. All you will have to do is to setup dial peers and have connectivity between the two offices.

HTH,

Nipun

New Member

H Nipun,Thanks for your

H Nipun,

Thanks for your suggestion.

I have both options on non cisco PBX. If I craete peer from non cisco router to cisco router then do I need to peer with public IP of Cisco router? As I have public ip on dialer 0 interface of cisco router. 

Non Cisco PBX is connected with dsl broadband router. port is forwarded to the pbx from dsl router. 

Can I do port forwarding on Cisco router from dialer0 interface to the port where all phones are registered?

 

Thank You

Regards

 

 

New Member

 Can anyone  please suggest

 

Can anyone  please suggest outline configuration needed to call from one office extension to another office extension using voice over IP calls?

 

Regards

Dude, This forum is not about

Dude,

 

This forum is not about outline configurations, you will need to do the hard yards. We will point you in the right direction.  You can post what you have so far, and we will help you making it work. Now you asked about public v private IP addressing on your 2911. really it doesnt matter what you use as the source/destination IP address, as long as there is connectivity.  from and to your 3rd party PBX.

 

post your config.

Please remember to rate useful posts, by clicking on the stars below.

New Member

Im Sorry for not posting all

Im Sorry for not posting all details. Please find configurations on Cisco Router below. 

I did connectivity between Cisco PBX and Non Cisco PBX by creating dial peers. Do you want me this dial peer configuration both side or WAN connectivity i.e. I should be able to ping  both sides public ip?

The configurations are as follows: 

 


Building configuration...


Current configuration : 11038 bytes
!
! Last configuration change at 18:51:52 UTC Sun Aug 24 2014 
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
network-clock-participate wic 0 
!
no ipv6 cef
ip source-route
ip cef
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.1.1 10.10.1.10
ip dhcp excluded-address 10.15.1.1 10.15.1.10
!
ip dhcp pool DATA
 network 10.10.1.0 255.255.255.0
 default-router 10.10.1.1 
!
ip dhcp pool VOICE
 network 10.15.1.0 255.255.255.0
 default-router 10.15.1.1 
 option 150 ip 10.15.1.1 
!
!
no ip domain lookup
ip name-server 78.143.192.10
ip name-server 78.143.192.20
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
trunk group ext
!
crypto pki token default removal timeout 0
!
!
voice-card 0
 codec complexity high
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 timeout ntf 500
  call preserve 
  h245 caps mode restricted
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface GigabitEthernet0/1.15
  bind media source-interface GigabitEthernet0/1.15
  registrar server expires max 3600 min 3600
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 mode cme
 source-address 10.15.1.1 port 5060
 max-dn 20
 max-pool 10
 load 7960-7940 P0S3-08-9-00
 authenticate register
 authenticate realm all
 call-forward system redirecting-expanded
 tftp-path flash:
 create profile sync 0004723960543943
 network-locale GB
 network-locale 1 GB
 network-locale 2 GB
!
voice register dn  1
 number 5000
 call-forward b2bua busy 5002  
 allow watch
 name SIP 1
!
voice register dn  3
 number 5002
 call-forward b2bua busy 5003  
 allow watch
 name SIP 3
!
voice register dn  4
 number 5003
 call-forward b2bua busy 5000  
 allow watch
 name SIP 4
!
voice register pool  1
 id mac 0003.6B54.BCD9
 type 7960
 number 1 dn 1
 dtmf-relay sip-notify
 username 5000 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice register pool  3
 id mac 0002.B9AF.C0F7
 type 7960
 number 1 dn 3
 dtmf-relay sip-notify
 username 5002 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice register pool  4
 id mac 0003.6B75.A91C
 type 7960
 number 1 dn 4
 dtmf-relay sip-notify
 username 5003 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice hunt-group 1 sequential
 final 5003
 list 5000,5002
 timeout 20 
 pilot 5900 
!
!
!
!
!
license udi pid CISCO2911/K9 sn FCZ163379BR
license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
hw-module pvdm 0/0
!
!
!
username xxxxxx privilege 15 secret 4 RItztkF0kItnl6GrGfyp9UBfMwc6PeNSfVkMYePCEkY
!
redundancy
!
!
!
!
controller VDSL 0/1/0
!

!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.15
 encapsulation dot1Q 15
 ip address 10.15.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn calling-number RedoQ
 isdn supp-service name calling
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn supp-service name calling
 isdn static-tei 0
!
interface ATM0/1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Ethernet0/1/0
 no ip address
 no fair-queue
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname D466314@hg70.btclick.com
 ppp chap password 0 redoqinfinity1
 no cdp enable
!
!
!
router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
 network 86.0.0.0
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 36000 requests 10000
ip http path flash:
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list 2 interface Dialer0 overload
ip nat inside source list 3 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 1.0.0.0 0.255.255.255
access-list 2 permit 10.0.0.0 0.255.255.255
access-list 3 permit any
!
!
!
!
!
tftp-server flash:OS79XX.txt
tftp-server flash:P003-08-9-00.bin
tftp-server flash:P003-08-9-00.sbn
tftp-server flash:P0S3-08-9-00.loads
tftp-server flash:P0S3-08-9-00.sb2
!
control-plane
!
!
voice-port 0/0/0
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/0/1
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/2/0
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
voice-port 0/2/1
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/0
 forward-digits all
!
dial-peer voice 3 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 07412626634
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 11 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/1
 forward-digits all
!
dial-peer voice 31 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 07412626634
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/1
!
dial-peer voice 100 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 101 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 5999 voip
 description ** cue voicemail pilot number **
 destination-pattern 5999
 session protocol sipv2
 session target ipv4:10.15.1.2
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 9281 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 9282 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 800 pots
 description *** Customer Care Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 801 pots
 description *** Customer Care Services Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 1000 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.1
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2001 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.11:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2002 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.1:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2003 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.12:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2004 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.13:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
!
!
!
dial-peer voice 2009 voip
 description *** grandsim ***
 destination-pattern 1001
 session target ipv4:86.182.113.26
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 2010 voip
 description *** grandsim  ***
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:86.182.113.26
 dtmf-relay sip-notify
 codec g711ulaw
!
!
presence
 presence call-list
!
!
!
gatekeeper
 shutdown
!

 

Regards
 

New Member

Do I really need VPN or MPLS

Do I really need VPN or MPLS between two sites? As I have got static public ip both sites to peer ip pbx using dial peers. 

I am able to peer two PBX now but I would like to use each others trunk connections. Is this possible in peering two PBX or I need to make pbx registrar server and register pbx with each other?

 

Please suggest me guys. Any type of suggestion is most welcome.

 

Regards

 

1825
Views
10
Helpful
6
Replies
CreatePlease to create content