Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How do I tell how much of a TX queue on a 4500 blade is being used?

Our main PBX medpro and clan cards are connected to a 4503 running 12.2(31)SGA.

It has a Sup II+ and two WS-X4524-GB-RJ45V modules.

The codec on the medpros is G-711 and the medpros are pumping out 200 - 300 calls. I'm allowing for 100kbps for each call, so I'm allowing for 30mbps of priority voice traffic on the up-links from the 4503 to the next hop router. I also am running L3 on the 4503.

Here is the pertinant QoS config statements.

qos dbl

qos map dscp 24 25 26 27 28 29 30 31 to tx-queue 4

qos map dscp 32 33 34 35 36 37 38 39 to tx-queue 4

qos map cos 3 to dscp 26

qos map cos 5 to dscp 46

qos

policy-map autoqos-voip-policy

class class-default

dbl

** typical medpro interface **

interface GigabitEthernet2/1

description ROC-MPX

switchport access vlan 626

switchport mode access

load-interval 30

speed 100

duplex full

qos trust dscp

auto qos voip trust

tx-queue 3

priority high

spanning-tree portfast

service-policy output autoqos-voip-policy

** Up-link interface to router **

interface GigabitEthernet2/24

description ROC-DW-A 4/6

no switchport

ip address 164.x.x.157 255.255.255.252

load-interval 30

duplex full

qos trust dscp

auto qos voip trust

tx-queue 3

priority high

spanning-tree portfast

service-policy output autoqos-voip-policy

Standard autoqos on the 4500 adds a 33% shaping command (which is really a policing command - it drops all packets that exceed 33%) which I took off because I don't want to police priority traffic. And I added the 'priority high' command to the tx-queue 3 which is supposedly the queue that COS-5/DSCP-46 is mapped to.

Now I need to know what is going on with the queues - how much of the tx-queue 3 is being used, etc. I cannot find any command that will show we that.

Is there one?

It doesn't seem that I can use class-maps and service-policies since they don't allow for 'priority' and 'bandwidth' statements. Otherwise I could use them and they supply lots of good statistics of what is going on with marked traffic.

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: How do I tell how much of a TX queue on a 4500 blade is bein

You cam see with the show interface

2 REPLIES
Silver

Re: How do I tell how much of a TX queue on a 4500 blade is bein

You cam see with the show interface

Community Member

Re: How do I tell how much of a TX queue on a 4500 blade is bein

You are correct. Using 'sh interface fx/x counters detail' gives total queue bytes and packets, and any queue drops.

I wish it also gave rates, like how many packets/sec average (determined by the load-interval value)per queue.

199
Views
0
Helpful
2
Replies
CreatePlease to create content