Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How reserve bandwidth for Voice

Hi All,

I try to do QoS on my routers for VoIP, but i can not overcome traffic congest issue.

I only have 256 kbps bandwidth and would like to reserve 128 kbps bandwidth for voice only. Emails or anyother traffic should not touch that bandwidth. Can I do that kind of things on cisco 1700 Router with IOS 12.3X?

14 REPLIES

Re: How reserve bandwidth for Voice

if have ur voice marked corectly which is by default marcked with dscp ef or 46

i will give u to ways

if u sure about marking do the following class map

class-map voice

match ip dscp ef

if not sure and u have ur voice i deffrent vlan that datat let say vlan 20 and vlan 20 ip range is 10.1.1.0 /24

do this class-map

ip access-list extended VVLAN

permit udp 10.1.1.0 0.0.0.255 any range 16384 32767

class-map voice

match access-group VVLAN

now creat an policy map

policy-map voice-policy

class voice

priority 128

class class-default

fair-queue

now just apply it on ur outise interface

like

interface [urport numner]

service-policy output voice-policy

the above conifg put the voice in piority queue LLQ so it will reserive 128 in case of conjestion and will be serveced first too

this is the ideal config for voice :)

just make sure from the marking i have put to cases for u of how to match the voice traffic

use either one or whatever way u want as long as u match the right traffic

for exra setup if u want u can match and reserv bandwith for call signaling aswel

like for example

ip access-list extended call-signaling

permit tcp any any range 1719 1720

permit tcp any any 2428

permit tcp any any range 2000 2002

then add it to ur policy like

policy-map voice-policy

class call-signaling

bandwidth 30

the above just reserve 30 Kb for call signaling but not put in priority queue!

and all the above classes will use more than the reserved bandwidth in case no conjestion and there is avalable bandwith

good luck

please, if helpful rate

Community Member

Re: How reserve bandwidth for Voice

Hi,

So the actual config is

policy-map voice-policy

class voice

priority 128

class class-default

fair-queue

interface [urport numner]

service-policy output voice-policy

Do I need to do VLAN in my Router?

advice me. I am not too good for Routers.. :)

thanks.

Re: How reserve bandwidth for Voice

ok

before we give priority or reservie bandwidth to a voice traffic we have to identify the voice traffic from other traffic

normalyy the switch connected to the phone dose this with the cisco phone

the swithc trust the cos coms from the phone and the cisco phone by default mark voice traffic with dscp ef or layer two cos 5

if now u have to have saparate vlan for voice and data

if u dont have it will work but here the problem it will be harder to clasifiy the traffic

so just give me an idea how is ur network is connected what and hwo they get IPs are all in the same IP network i mean phones and PCs

and do they connect to switch or how they connect to ur router

just send me these detaisl to let me help u more

thank you

Community Member

Re: How reserve bandwidth for Voice

OK.

I am using IP PABX that's connected to 1841 DSL Router which use for Internet.

After that router i have local 1760 cisco Router which is connected from singapore to Yangon via 256 kbps leased line.

From Yangon router, I connected ATA devices that one Ethernet input and two Rj11 output which we can connect with telephone handsets.

the traffic is between yangon to singapore two 1760 routers.

thanks,

Re: How reserve bandwidth for Voice

ok can just please tell me the voice traffic from where to where go ?

is the IP PABX connected to the local 1760 router?

do u have any voice diial peer configured if yes where ?

i just wanna know ur traffic path for voice

and dose the pbx has IP or range of IPs

sorry but i just wanna know more details to give more accurate answer

Community Member

Re: How reserve bandwidth for Voice

IP-PABX is connected with 1841 Router.

then fe cable connected to SG 1760 then connected to YGN 1760 with 256 leased line from sg to yangon.

As it is IP Base PABX, i really do not need to configure dial peer config. I just need to open some ports for voice traffic.

Voice can communicated once IP network is there.

Yeah I need to assign one IP for PABX. 192.168.30.x like that.

Thanks,

Re: How reserve bandwidth for Voice

ok cool

lets say the IP PABX ip range is 192.168.30.0/24

first we gonna match the traffic from the PABX then mark it i will mark and match all traffic from the PABX

u can marck only voice RTP traffic by useing the following ACL:

access-list 100 permit udp 192.168.30.0 255.255.255.0 any range 16384 32767

but the following one will match evry IP traffic from the PABX:

access-list 100 permit IP 192.168.30.0 255.255.255.0 any

class-map PABX

match access-group 100

plolicy-map PABX-marking

class PABX

set ip dscp ef

now u have to apply this policy to the interface connected to the PABX on the SG 1760 fe

like

interface fe 0/1

service-policy input PABX-marking

now after the PABX traffic enter this interface it will be mark as dscp ef (46)

so for the outbound policy we cam match it easily

for bandwidth reservation do

class-map voip

match ip dscp ef

policy-map voip

class voip

priority 128

class class-default

fair-queue

now go to the lease line interface let say serial 1/1 for example

interface serial 1/1

service-policy output voip

and becareful in the first ACL u have to match the traffic exactly regarding the right IPs

good luck

please, if helpful Rate

Community Member

Re: How reserve bandwidth for Voice

Hi,

Appreciated for your reply.

But PABX is connected with 1841 Router with FE port. Not to 1760.

From 1841 to 1760 I have another FE port connected. then SG 1760 serial to Yangon 1760 Serial.

I want to draw the diagram here. :)

Thanks a lot.

Re: How reserve bandwidth for Voice

then put the input marking class-map, policy map and ACL on the 1841 router and apply it to the interface connected to the PABX fastethernet in the input direction the same

so now u gonna make the marking config on the 1841 and the resrvition on the 1760

did u got ??

if u need any more details post it here

good luck

if helpful Rate

Community Member

Re: How reserve bandwidth for Voice

Ok,

Can I do like this?

Just forget about 1841 Router that connected to IP-PABX and

access-list 100 permit udp 192.168.30.0 255.255.255.0 any range 16384 32767

access-list 100 permit IP 192.168.30.0 255.255.255.0 any

class-map PABX

match access-group 100

plolicy-map PABX-marking

class PABX

set ip dscp ef

interface fe 0/1

service-policy input PABX-marking

All above config will be configured in 1760 router which has fe connection to 1841 router.

Then,

class-map voip

match ip dscp ef

policy-map voip

class voip

priority 128

class class-default

fair-queue

interface serial 1/1

service-policy output voip

to same SG 1760 router serial.

How about like that?

I also need to that config at Yangon end rite?

Re: How reserve bandwidth for Voice

sure u can and very good

aboyuut he other site

u need to do marking on the traffic coming from the phones or ATA mark it the same idea and give it priority on the outbound direction on the remote 1760 router

this will be two way

good luck

hope this helpful :)

Community Member

Re: How reserve bandwidth for Voice

My plan is to add one more fe port only for ATAs in Yangon router.now it is mixed with data and implement what u advice.

will let u know when i finished !!

Thanks a lot.

u r the man.

Bronze

Re: How reserve bandwidth for Voice

great explanation there. nice and to the point

Community Member

Re: How reserve bandwidth for Voice

Hi Man,

:( the config is not applicable for me.

Bandwidth is not actually reserve and voice quality is the same.

I changed my network design like

PABX--> 1700 Ethernet-->1700 Serial(SG) --> 1760 Serial (YGN)--> 1760 Ethernet --> two ATAs.

Now pabx n atas are in different ethernet port of each routers.

any more advice?

563
Views
5
Helpful
14
Replies
CreatePlease to create content