Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

how to control which sip account to use for outbound call

hi, i have 3 sip accounts from the same provider and each of these accounts have their own caller-id. how can i control which sip account to use for outbound calls based on the destination number under CME 8.6?

 

UC520#sh run
Building configuration...


Current configuration : 33675 bytes
!
! Last configuration change at 23:31:10 PCTime Mon Sep 15 2014 by admin
! NVRAM config last updated at 23:33:26 PCTime Mon Sep 15 2014 by admin
! NVRAM config last updated at 23:33:26 PCTime Mon Sep 15 2014 by admin
version 15.1
parser config cache interface
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname UC520
!
boot-start-marker
boot-end-marker
!
!
logging buffered 4096
enable secret 4 4LYLBj/m9tJslfvnut0KB75uPWP8/sM
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone PCTime 8 0
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-*****
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-*****
 revocation-check none
 rsakeypair TP-self-signed-*****
!
!
crypto pki certificate chain TP-self-signed-*****
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  ***********************************************************************
        quit
dot11 syslog
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip dhcp pool phone
 import all
 network 10.1.1.0 255.255.255.0
 default-router 10.1.1.1
 option 150 ip 10.1.1.1
 dns-server 103.11.48.190 103.11.48.126
 domain-name 103.11.48.190
!
!
!
ip domain name sip.didlogic.net
ip name-server 103.11.48.190
ip name-server 103.11.48.126
ip inspect WAAS flush-timeout 10
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
!
!
stcapp supplementary-services
 port 0/0/3
  fallback-dn 205
!
!
!
!
trunk group ALL_FXO
 max-retry 5
 voice-class cause-code 1
 hunt-scheme sequential
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through 

g711ulaw
 sip
  registrar server expires max 600 min 60
  localhost dns:sip.didlogic.net
  outbound-proxy dns:sip.sg.didlogic.net
  no update-callerid
!
voice class codec 1
 codec preference 1 g711ulaw
!
voice class custom-cptone CCAleavetone
 dualtone conference
  frequency 400 800
  cadence 400 50 200 50 200 50
!
voice class custom-cptone CCAjointone
 dualtone conference
  frequency 600 900
  cadence 300 150 300 100 300 50
!
!
voice class cause-code 1
 no-circuit
!
voice register global
 mode cme
 source-address 10.1.1.1 port 5060
 no outbound-proxy
 max-dn 56
 max-pool 14
 load 9971 sip9971.9-4-1-9
 authenticate register
 timezone 43
 date-format D/M/Y
 hold-alert
 voicemail 100
 url directory http://10.1.1.1/localdirectory
 tftp-path flash:
 create profile sync 0005017394511016
!
voice register dn  1
 translation-profile incoming SIP_Passthrough
 number 105
 call-forward b2bua busy 100
 call-forward b2bua noan 100 timeout 20
 call-forward b2bua unregistered 100
 name Living Room
 no-reg
 label Living Room
!
voice register dn  2
 translation-profile incoming SIP_Passthrough
 number 102
 call-forward b2bua busy 100
 call-forward b2bua noan 100 timeout 10
 call-forward b2bua unregistered 100
 name Master Bedroom
 no-reg
 label Mommy
!
voice register dn  3
 translation-profile incoming SIP_Passthrough
 number 103
 call-forward b2bua busy 100
 call-forward b2bua noan 100 timeout 20
 call-forward b2bua unregistered 100
 name Nana Bedroom
 no-reg
 label Christiana
!
voice register dn  4
 translation-profile incoming SIP_Passthrough
 number 104
 call-forward b2bua busy 100
 call-forward b2bua noan 100 timeout 20
 call-forward b2bua unregistered 100
 name Dining Hall
 no-reg
 label Dining Hall
!
voice register pool  1
 id mac 08CC.6830.BF71
 session-transport tcp
 type 9971
 number 1 dn 1
 dtmf-relay rtp-nte
 username LivingRoom password cisco
 codec g711ulaw
 camera
 video
!
voice register pool  2
 id mac B4E9.B08C.A754
 session-transport tcp
 type 9971
 number 1 dn 2
 dtmf-relay rtp-nte
 username Liezel password cisco
 codec g711ulaw
 camera
 video
!
voice register pool  3
 id mac 5017.FF96.7EE6
 session-transport tcp
 type 9971
 number 1 dn 3
 dtmf-relay rtp-nte
 username christiana password cisco
 codec g711ulaw
 camera
 video
!
voice register pool  4
 id mac 5017.FF96.7A7B
 session-transport tcp
 type 9971
 number 1 dn 4
 dtmf-relay rtp-nte
 username DiningHall password cisco
 codec g711ulaw
 camera
 video
!
voice hunt-group 1 parallel
 final 701
 list 205,104,105
 timeout 12
 pilot 700
!
!
voice hunt-group 2 parallel
 final 102
 list 102,103,104,105,205
 timeout 12
 pilot 701
!
!
!
!
voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
 access-list 2
 translation-profile incoming SIP_Incoming
!
voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL
 access-list 3
!
voice translation-rule 1
 rule 1 /\(^9\)/ //
!
voice translation-rule 2
 rule 1 /^9\(.*\)/ /65\1/
!
voice translation-rule 3
 rule 1 /^65......../ /965\2/
!
voice translation-rule 4
 rule 1 /1713******6/ /700/
!
voice translation-rule 5
 rule 1 /61********5/ /700/
!
voice translation-rule 6
 rule 1 /44*********2/ /700/
!
voice translation-rule 410
 rule 1 /^9\(.*\)/ /\1/
 rule 2 /^8\(.*\)/ /\1/
 rule 15 /^...$/ /65*******0/
!
voice translation-rule 411
 rule 1 /^9\(.*\)/ /ABCD9\1/
 rule 2 /^8\(.*\)/ /ABCD8\1/
!
voice translation-rule 412
 rule 1 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 422
 rule 15 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 1000
 rule 1 /.*/ //
!
voice translation-rule 1111
 rule 15 /^.*$/ /65*******0/
!
voice translation-rule 1112
 rule 1 /^9/ //
 rule 2 /^8/ //
!
voice translation-rule 2222
!
voice translation-rule 3265
 rule 1 /\(^..............$\)/ /8\1/
 rule 2 /\(^.............$\)/ /8\1/
 rule 3 /\(^............$\)/ /8\1/
 rule 4 /\(^...........$\)/ /8\1/
 rule 5 /\(^..........$\)/ /8\1/
 rule 6 /\(^.........$\)/ /8\1/
 rule 7 /\(^........$\)/ /9\1/
 rule 8 /\(^.......$\)/ /9\1/
 rule 9 /\(^......$\)/ /9\1/
 rule 10 /\(^.....$\)/ /9\1/
 rule 11 /\(^....$\)/ /9\1/
 rule 15 /\(^ABCD$\)/ /ABCD\1/
!
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
 translate calling 1111
!
voice translation-profile CallBlocking
 translate called 2222
!
voice translation-profile DiscardDigit9
 translate called 1
!
voice translation-profile INCOMING_CallerID_PROFILE
 translate calling 3265
!
voice translation-profile Incoming_AU-BG_Called_5
 translate calling 3265
 translate called 5
!
voice translation-profile Incoming_UK-BG_Called_6
 translate calling 3265
 translate called 6
!
voice translation-profile Incoming_US-BG_Called_4
 translate calling 3265
 translate called 4
!
voice translation-profile Local_SIP_Call_Add_65
 translate called 2
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
 translate called 1112
!
voice translation-profile PSTN_CallForwarding
 translate redirect-target 410
 translate redirect-called 410
!
voice translation-profile PSTN_Outgoing
 translate calling 1111
 translate called 1112
 translate redirect-target 410
 translate redirect-called 410
!
voice translation-profile SIP_Incoming
 translate called 411
!
voice translation-profile SIP_Passthrough
 translate called 412
!
voice translation-profile SIP_Passthrough_CallBlocking
 translate called 422
!
voice translation-profile nondialable
 translate called 1000
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
fax interface-type fax-mail
!
!
license udi pid UC520-8U-4FXO-K9 sn FTX1213Y07D
archive
 log config
  logging enable
  logging size 600
  hidekeys
username admin privilege 15 secret 4 4LYLBj/m9tsM
!
!
no ip ftp passive
ip tftp source-interface Loopback0
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.252
 ip virtual-reassembly in
!
interface FastEthernet0/0
 ip address dhcp
 ip virtual-reassembly in
 load-interval 30
 duplex full
 speed 100
!
interface Integrated-Service-Engine0/0
 description cue is initialized with default IMAP group
 ip unnumbered Loopback0
 ip virtual-reassembly in
 service-module ip address 10.1.10.1 255.255.255.252
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/1
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/2
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/3
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/4
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/5
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/6
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/7
 switchport voice vlan 100
 no ip address
 macro description cisco-phone
 spanning-tree portfast
!
interface FastEthernet0/1/8
 switchport mode trunk
 switchport voice vlan 100
 no ip address
 macro description cisco-switch
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
 ip virtual-reassembly in
!
interface Vlan99
 ip address 192.168.99.2 255.255.255.0
 ip virtual-reassembly in
!
interface Vlan100
 ip address 10.1.1.1 255.255.255.0
 ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
ip dns server
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
access-list 1 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 1 remark SDM_ACL Category=1
access-list 1 permit 192.168.1.2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 192.168.1.2
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 2 permit 10.1.1.0 0.0.0.255
access-list 2 permit 10.1.10.0 0.0.0.3
access-list 3 permit 162.217.100.10
access-list 3 permit 192.170.159.194
access-list 3 permit 192.170.152.170
access-list 3 permit 95.154.254.93
access-list 3 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL
access-list 3 remark SDM_ACL Category=1
access-list 3 permit 101.0.103.146
access-list 3 permit 119.9.12.222
access-list 3 permit 176.74.184.153
access-list 3 permit 72.251.241.166
access-list 3 permit 207.198.125.133
access-list 3 deny   any
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 100 deny   ip 192.168.1.0 0.0.0.255 any
!
!
!
!
snmp-server community public RO
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias 

en_bacd_xferto_operator.au
tftp-server flash:/dkern9971.100609R2-9-4-1-9.sebn
tftp-server flash:/Desktops/CampusNight.png alias CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png alias TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png alias CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png alias TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png alias CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png alias TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png alias Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png alias TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png alias MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png alias TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png alias NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png alias TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml alias 320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml alias 320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml alias 320x216x16/List.xml
tftp-server flash:/phones/9971/sip9971.9-4-1-9.loads
tftp-server flash:/phones/9971/sboot9971.031610R1-9-4-1-9.sebn
tftp-server flash:/phones/9971/skern9971.022809R2-9-4-1-9.sebn
tftp-server flash:/phones/9971/rootfs9971.9-4-1-9.sebn
tftp-server flash:/phones/9971/kern9971.9-4-1-9.sebn
tftp-server flash:/phones/9971/dkern9971.100609R2-9-4-1-9.sebn
radius-server attribute 31 send nas-port-detail
!
!
!
control-plane
!
call threshold interface FastEthernet0/0 int-calls low 14 high 14
!
voice-port 0/0/0
 cptone SG
 station-id number 204
 caller-id enable
!
voice-port 0/0/1
 cptone SG
 station-id number 203
 caller-id enable
!
voice-port 0/0/2
 cptone SG
 station-id number 202
 caller-id enable
!
voice-port 0/0/3
 cptone SG
 timeouts ringing infinity
 description Panasonic Wireless Phone
 caller-id enable
!
voice-port 0/1/0
 trunk-group ALL_FXO 61
 translation-profile incoming INCOMING_CallerID_PROFILE
 cptone SG
 connection plar opx 700
 description Configured by CCA 4 FXO-0/1/0-Custom-BG
 caller-id enable
!
voice-port 0/1/1
 trunk-group ALL_FXO 62
 translation-profile incoming INCOMING_CallerID_PROFILE
 cptone SG
 connection plar opx 700
 description Configured by CCA 4 FXO-0/1/1-Custom-BG
 caller-id enable
!
voice-port 0/1/2
 trunk-group ALL_FXO 63
 translation-profile incoming INCOMING_CallerID_PROFILE
 cptone SG
 connection plar opx 700
 description Configured by CCA 4 FXO-0/1/2-Custom-BG
 caller-id enable
!
voice-port 0/1/3
 trunk-group ALL_FXO 64
 translation-profile incoming INCOMING_CallerID_PROFILE
 cptone SG
 connection plar opx 700
 description Configured by CCA 4 FXO-0/1/3-Custom-BG
 caller-id enable
!
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control -15
 description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 4.0
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register confprof1
 associate profile 2 register mtp001b8fac16a0
!
dspfarm profile 2 transcode
 description CCA transcoding for SIP Trunk DIDLogic
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 6
 associate application SCCP
!
dspfarm profile 1 conference
 description DO NOT MODIFY, active CCA conference profile - CCA2.0 codec711
 codec g711ulaw
 codec g711alaw
 maximum conference-participants 32
 conference-join custom-cptone CCAjointone
 conference-leave custom-cptone CCAleavetone
 associate application SCCP
 shutdown
!
dial-peer cor custom
 name internal
 name local
 name local-plus
 name international
 name national
 name national-plus
 name emergency
 name toll-free
!
!
dial-peer cor list call-internal
 member internal
!
dial-peer cor list call-local
 member local
!
dial-peer cor list call-local-plus
 member local-plus
!
dial-peer cor list call-national
 member national
!
dial-peer cor list call-national-plus
 member national-plus
!
dial-peer cor list call-international
 member international
!
dial-peer cor list call-emergency
 member emergency
!
dial-peer cor list call-toll-free
 member toll-free
!
dial-peer cor list user-internal
 member internal
 member emergency
!
dial-peer cor list user-local
 member internal
 member local
 member emergency
 member toll-free
!
dial-peer cor list user-local-plus
 member internal
 member local
 member local-plus
 member emergency
 member toll-free
!
dial-peer cor list user-national
 member internal
 member local
 member local-plus
 member national
 member emergency
 member toll-free
!
dial-peer cor list user-national-plus
 member internal
 member local
 member local-plus
 member national
 member national-plus
 member emergency
 member toll-free
!
dial-peer cor list user-international
 member internal
 member local
 member local-plus
 member international
 member national
 member national-plus
 member emergency
 member toll-free
!
!
dial-peer voice 1 pots
 destination-pattern 204
 port 0/0/0
 no sip-register
!
dial-peer voice 2 pots
 destination-pattern 203
 port 0/0/1
 no sip-register
!
dial-peer voice 3 pots
 destination-pattern 202
 port 0/0/2
 no sip-register
!
dial-peer voice 4 pots
 destination-pattern 201
 port 0/0/3
 no sip-register
!
dial-peer voice 5 pots
 description ** MOH Port **
 destination-pattern ABC
 port 0/4/0
 no sip-register
!
dial-peer voice 6 pots
 description tcatch all dial peer for BRI/PRIv
 translation-profile incoming nondialable
 incoming called-number .%
 direct-inward-dial
!
dial-peer voice 50 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/0
!
dial-peer voice 51 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/1
!
dial-peer voice 52 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/2
!
dial-peer voice 53 pots
 description ** incoming dial peer **
 incoming called-number ^AAAA$
 port 0/1/3
!
dial-peer voice 54 pots
 description ** FXO pots dial-peer **
 destination-pattern A0
 port 0/1/0
 no sip-register
!
dial-peer voice 55 pots
 description ** FXO pots dial-peer **
 destination-pattern A1
 port 0/1/1
 no sip-register
!
dial-peer voice 56 pots
 description ** FXO pots dial-peer **
 destination-pattern A2
 port 0/1/2
 no sip-register
!
dial-peer voice 57 pots
 description ** FXO pots dial-peer **
 destination-pattern A3
 port 0/1/3
 no sip-register
!
dial-peer voice 2000 voip
 description ** cue voicemail pilot number **
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 voice-class sip outbound-proxy ipv4:10.1.10.1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1000 voip
 permission term
 description ** Incoming call from SIP trunk (DIDLogic) **
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through 

g711ulaw
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1001 voip
 corlist outgoing call-local
 description ** star code to SIP trunk (DIDLogic) **
 destination-pattern *..
 session protocol sipv2
 session target sip-server
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through 

g711ulaw
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1003 voip
 description ** Passthrough Inbound Calls for PSTN from CUE **
 translation-profile incoming SIP_Passthrough
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number ABCDT
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1005 voip
 description ** Passthrough Inbound Calls for MWI from CUE **
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number A80T
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1009 voip
 description ** Passthrough Inbound Calls for Internal Extensions from CUE **
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number ^...$
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 1002 voip
 corlist outgoing call-local
 description ** star code to SIP trunk (DIDLogic) **
 preference 1
 destination-pattern *..
 session protocol sipv2
 session target dns:sip.hk.didlogic.net
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 fax rate 14400
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through 

g711ulaw
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 99 pots
 description Panasonic Wireless Phone
 service stcapp
 port 0/0/3
 forward-digits 0
!
dial-peer voice 58 pots
 trunkgroup ALL_FXO
 corlist outgoing call-local
 description **CCA*Local+Int'l*Local**
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 5
 destination-pattern 9[1-9]T
 forward-digits all
 no sip-register
!
dial-peer voice 1020 voip
 corlist outgoing call-international
 description **CCA*Local+Int'l*International**
 translation-profile outgoing PSTN_Outgoing
 preference 2
 destination-pattern 8[1-9]T
 session protocol sipv2
 session target dns:sip.hk.didlogic.net
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 1021 voip
 corlist outgoing call-international
 description **CCA*Local+Int'l*International**
 translation-profile outgoing PSTN_Outgoing
 preference 1
 destination-pattern 8[1-9]T
 session protocol sipv2
 session target sip-server
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 3000 voip
 description Incoming_US-BG
 translation-profile incoming Incoming_US-BG_Called_4
 session protocol sipv2
 session target sip-server
 incoming called-number 1713*******6
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 3001 voip
 description Incoming_AU-BG
 translation-profile incoming Incoming_AU-BG_Called_5
 session protocol sipv2
 session target sip-server
 incoming called-number 61********5
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
dial-peer voice 3002 voip
 description Incoming_UK-BG
 translation-profile incoming Incoming_UK-BG_Called_6
 session protocol sipv2
 session target sip-server
 incoming called-number 44*********2
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 ip qos dscp cs5 media
 ip qos dscp cs4 signaling
 no vad
!
!
no dial-peer outbound status-check pots
sip-ua
 credentials username 05917 password 7 003E401454585 realm sip.sg.didlogic.net
 credentials username 93267 password 7 033E0819560C7 realm sip.sg.didlogic.net
 credentials username 55140 password 7 046158145F221 realm sip.sg.didlogic.net
 keepalive target dns:sip.sg.didlogic.net
 authentication username 05917 password 7 023C57495B055 realm 

sip.sg.didlogic.net
 no remote-party-id
 retry invite 2
 retry register 10
 timers connect 100
 timers keepalive active 100
 registrar dns:sip.sg.didlogic.net expires 3600
 sip-server dns:sip.sg.didlogic.net
 connection-reuse
 host-registrar
!
!
!
telephony-service
 sdspfarm conference mute-on 111 mute-off 222
 sdspfarm units 5
 sdspfarm transcode sessions 6
 sdspfarm tag 1 confprof1
 sdspfarm tag 2 mtp001b8fac16a0
 conference hardware
 video
 fxo hook-flash
 max-ephones 14
 max-dn 56
 ip source-address 10.1.1.1 port 2000
 auto assign 1 to 1 type bri
 calling-number initiator
 service phone videoCapability 1
 service phone ehookenable 1
 service phone webAccess 0
 service dnis overlay
 service dnis dir-lookup
 service dss
 timeouts interdigit 2
 system message UC520
 url services http://10.1.10.1/voiceview/common/login.do
 url authentication http://10.1.10.2/CCMCIP/authenticate.asp
 load 521G-524G cp524g-8-1-17
 time-zone 43
 date-format dd-mm-yy
 keepalive 30 auxiliary 4
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 moh flash:/media/music-on-hold.au
 multicast moh 239.10.16.16 port 2000
 web admin system name cisco secret 5 $1$7PJ3$MLovPhyY/TvmgYJc72WwI/
 dn-webedit
 time-webedit
 transfer-system full-consult dss
 transfer-pattern 9.T
 transfer-pattern .T
 secondary-dialtone 9
 night-service day Sun 17:00 09:00
 night-service day Mon 17:00 09:00
 night-service day Tue 17:00 09:00
 night-service day Wed 17:00 09:00
 night-service day Thu 17:00 09:00
 night-service day Fri 17:00 09:00
 night-service day Sat 17:00 09:00
 fac standard
 create cnf-files version-stamp 7960 Jul 27 2014 00:27:04
!
!
ephone-template  15
 url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
 softkeys remote-in-use  Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
 button-layout 7931 2
!
!
ephone-template  16
 url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
 softkeys remote-in-use  Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
!
!
ephone-template  17
 url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
 softkeys remote-in-use  CBarge Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
!
!
ephone-template  18
 url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
 softkeys remote-in-use  CBarge Newcall
 softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
 softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
 button-layout 7931 2
!
!
ephone-dn  1  octo-line
 number 205 no-reg primary
 label Wireless Phone
 description Panasonic Wireless Phone
 name Wireless Phone
!
!
ephone-dn  9
 number BCD no-reg primary
 description MoH
 moh out-call ABC
!
!
ephone-dn  42  octo-line
 number 770 no-reg primary
 conference meetme unlocked
 preference 3
!
!
ephone-dn  43  octo-line
 number 770 no-reg primary
 conference meetme unlocked
 preference 2
 no huntstop
!
!
ephone-dn  44  octo-line
 number 770 no-reg primary
 conference meetme unlocked
 preference 1
 no huntstop
!
!
ephone-dn  45  octo-line
 number 770 no-reg primary
 conference meetme unlocked
 no huntstop
!
!
ephone-dn  46  octo-line
 number C001 no-reg primary
 conference ad-hoc
 preference 3
!
!
ephone-dn  47  octo-line
 number C001 no-reg primary
 conference ad-hoc
 preference 2
 no huntstop
!
!
ephone-dn  48  octo-line
 number C001 no-reg primary
 conference ad-hoc
 preference 1
 no huntstop
!
!
ephone-dn  49  octo-line
 number C001 no-reg primary
 conference ad-hoc
 no huntstop
!
!
ephone-dn  54
 number 300 no-reg primary
 park-slot timeout 30 limit 2 transfer 700 retry 30 limit 2
 label Call Park
!
!
ephone-dn  55
 number A801... no-reg primary
 mwi off
!
!
ephone-dn  56
 number A800... no-reg primary
 mwi on
!
!
ephone  1
 device-security-mode none
 mac-address B8FA.C16A.0003
 ephone-template 16
 max-calls-per-button 2
 username "WiPhone" password cisco
 type anl
 button  1:1
!
!
alias exec cca_voice_mode PBX
alias exec cca_vm_notification schedule from_time=00 to_time=24
banner login ^CCisco Configuration Assistant. Version: 3.2 (3). Sat Jul 05 11:16:36 SGT 

2014^C
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
line vty 0 4
 transport preferred none
 transport input all
line vty 5 100
 transport preferred none
 transport input all
!
ntp master
ntp peer 192.168.1.1
ntp peer pool.ntp.org
end

UC520#

Everyone's tags (1)
11 REPLIES
Hall of Fame Super Gold

That's what the Dialing Route

Post removed due to low score.  

 

I post with good intention.  A low score means the possibility of an incorrect response. 

New Member

Hi Leo, what dialing route

Hi Leo, what dialing route specifically? if you can give an example that would be great.

currently, the only control i have is this one authentication i have under sip-ua. authentication using dial-peers doesn't seem to work for me.

This link might be helpful

New Member

I have read that link before,

I have read that link before, from what i understand it only helps you for redundancy but no advice on how to control which account to use

Hi.That's not only for

Hi.

That's not only for redundancy, but also for path preference. 

Infact using preference keyword under dial-peer with the same destination pattern, vg will select dialpeer based on priority

 

HTH

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"
New Member

Thanks Carlo for your reply.I

Thanks Carlo for your reply.

I have read again the link and you are correct that in using the preferred command together with localhost under POTS dial-peer, I can now select which correct path to choose for my outbound calls. I'm just not very strong with dial-peer and translation rules at the moment.

 

I will try this solution during the weekend and let you know. But it would have been better if there was a sample configuration for this option.

Hall of Fame Super Gold

At home, I have a call server

Post removed due to low score.  

 

I post with good intention.  A low score means the possibility of an incorrect response. 

New Member

all those options are also

all those options are also available on CME through translation rules and dial-peer routing, however i am not able to select which type of sip account to use since it's under one sip provider. if it was under two different providers then it would have been possible AFAIK

New Member

anybody else can help with

anybody else can help with this?

New Member

anyone?

anyone?

New Member

Would really appreciate it if

I have updated the first post with the configuration.

 

Would really appreciate it if anybody can help solve my problem or guide me to the right solution.

338
Views
12
Helpful
11
Replies
CreatePlease to create content