Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

How to fake ISDN b-channels as busy out of the pri-group timeslots definition ?

Hi, Cisco Support Community,

This is my first post here, so I hope I won't make mistakes... First, thanks for reading me.

I wanted to reuse an old 2811 to act as a SIP gateway on an ISDN primary rate interface. This router is featured with 2 PVDM2-8 modules, so that we're able to handle up to 16 simultaneous calls. So I ordered a pri with 10 channels, which is supposed to be more than enough for our usage.
Everything works fine, excepted that I discovered that the PRI which was delivered to us is a full one, meaning 30 B channels.
As a result, as incoming calls are dispatched round robin by the isdn line provider, when incoming calls start to be presented on b-channel 16, the call is rejected by the router with a "channel unavailable" message... The only way to have a successful incoming call is then to have 15 more unsuccessful tries so that the calls are presented on B-channel 1 again :-/

I have to wait for monday to deal with the line provider to sort this out, but meanwhile, I was trying to find a workaround.
My first try was to use B-channel negotiation on the serial interface (isdn negotiate-bchan resend-setup), but it seems that b channel negociation is disabled on the provider side.

So the other obvious solution would be to fake channels 17 to 31 as busy (isdn busy b_channel xx) ... But as the pri-group timeslots are 1-16, the related serial interface is serial0/0/0:15, and I'm unable to set busy B-channels over 15. And of course, I have no way to define pri-group timeslots 1-31 as I have not enough DSPs to handle more than 16.
I also tried to use the ds0 busyout directive within the E1 controller configuration, but while the command is accepted, it does not appear in the configuration

Below is my running configuration... If some of you can help, this would be much appreciated. Current IOS on the router is Version 12.3(11)T3
Kind regards,

Philippe Martorell

 

--- cut here ---

 

Current configuration : 4311 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname RTR-xyz-abc
!
boot-start-marker
boot-end-marker
!
enable secret 5 xx
!
username user1 privilege 15 secret 5 xx
username user3 privilege 15 secret 5 xx
username user1 privilege 15 secret 5 xx
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
aaa new-model
!
!
aaa authentication login default local
aaa session-id common
ip subnet-zero
!
!
ip cef
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ftp-server write-enable
isdn switch-type primary-net5
!
voice-card 0
 dspfarm
 no local-bypass
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service voip
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
 sip
  no call service stop
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
!
!
!
!
!
!
!
!
!
!
!
controller E1 0/0/0
 pri-group timeslots 1-16
!
translation-rule 1
 Rule 1 ..% 900 international international
 Rule 2 ..% 90 national national
!
!
translation-rule 2
 Rule 1 ..% 02212345
!
!
!
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
 ip address 172.16.31.200 255.255.255.0
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 ip address 10.0.1.200 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 no ip address
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn map address .* plan unknown type unknown
 isdn negotiate-bchan resend-setup
 isdn outgoing-voice info-transfer-capability 3.1kHz-audio
 no cdp enable
!
ip default-gateway 172.16.31.254
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.31.254
!
no ip http server
!
snmp-server community xx RO
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
 no echo-cancel enable
 playout-delay maximum 170
 playout-delay nominal 80
 playout-delay minimum low
 cptone CH
 bearer-cap 3100Hz
!
no mgcp piggyback message
!
!
!
dial-peer voice 1 pots
 application session
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 456389160 voip
 destination-pattern 6[0-8]
 translate-outgoing calling 1
 translate-outgoing called 2
 rtp payload-type cisco-codec-fax-ind 124
 rtp payload-type nte 96
 no modem passthrough
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.200.3.21
 dtmf-relay rtp-nte
 fax rate disable
 no vad
!
dial-peer voice 999999 voip
 answer-address 0.
 rtp payload-type cisco-codec-fax-ind 124
 rtp payload-type nte 96
 no modem passthrough
 voice-class codec 1
 session protocol sipv2
 dtmf-relay rtp-nte
 fax rate disable
 fax protocol pass-through g711ulaw
 no vad
!
dial-peer voice 9912 pots
 destination-pattern 99123T
 progress_ind alert enable 8
 port 0/0/0:15
!
dial-peer voice 9920 pots
 destination-pattern 99222T
 clid restrict
 clid restrict
 port 0/0/0:15
!
dial-peer voice 456389162 voip
 destination-pattern 69
 translate-outgoing calling 1
 translate-outgoing called 2
 rtp payload-type cisco-codec-fax-ind 124
 rtp payload-type nte 96
 modem passthrough nse codec g711ulaw
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.200.3.21
 dtmf-relay h245-alphanumeric
 fax-relay ecm disable
 fax rate 9600
 fax nsf 000000
 fax protocol t38 ls-redundancy 2 hs-redundancy 2 fallback none
 no vad
!
gateway
 timer receive-rtp 1200
!
sip-ua
 max-forwards 15
 sip-server ipv4:10.200.3.21
!
banner login ^CCC
WARNING: This is a private network.
 Unauthorized access is prohibited.
 Use of this system constitutes your
 consent to interception, monitoring,
 and recording for official purposes
 of information related to such use,
 including criminal investigations.
-----------------------------------------------------------------------
^C
!
line con 0
line aux 0
line vty 0 4
 password 7 xx
!
scheduler allocate 20000 1000
!
end

 

 

 

 

6 REPLIES
Cisco Employee

Hi,Please check: https:/

Hi,

Please check:

 

https://supportforums.cisco.com/document/25666/how-busy-out-b-channel-isdn-pri-ios-gateways

&

http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-communications-manager-callmanager/71647-busy-out-c-chan-ccm.html

 

Is this helps please rate.

 

HTH

Chris.

 

Hi,Thanks for your answer,

Hi,

Thanks for your answer, but unfortunately, this did not help. commands ds0 busyout are accepted, but not taken into account :

RTR-505-012#conf t
*Apr  7 10:23:04.361: %SYS-5-CONFIG_I: Configured from console by sysadmin9 on vty0 (172.16.0.88)
Enter configuration commands, one per line.  End with CNTL/Z.
RTR-505-012(config)#controller e1 0/0/0
RTR-505-012(config-controller)#ds0 busyout 17-31
RTR-505-012(config-controller)#do sh run | begin controller
controller E1 0/0/0
 pri-group timeslots 1-16
!

And the "isdn service b_channel state" commands in the serial interface context are rejected

RTR-505-012(config-controller)#interface Serial0/0/0:15
RTR-505-012(config-if)#isdn service b_channel 16 state 2
%The service state of reserved channel 16 on DSL 0 can not be changed.


While the "show isdn service" status shows channels 16 to 30 are out of service, some incoming calls are still directed to these channels by the provider :

RTR-505-012#show isdn service
PRI Channel Statistics:
ISDN Se0/0/0:15, Channel [1-31]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3 3
   Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

 

*Apr  7 10:20:45.509: %ISDN-6-CHAN_UNAVAILABLE: Interface Se0/0/0:15 Requested Channel 19 is not available
*Apr  7 10:20:53.353: %ISDN-6-CHAN_UNAVAILABLE: Interface Se0/0/0:15 Requested Channel 20 is not available

 

I'll try to sort this out with the provider today.

Thanks,

Philippe.

 

VIP Super Bronze

Channel 16 is your signalling

Channel 16 is your signalling channel, you cant change the state. s0/0/0:15--that refers to your signalling channel (and its 16 since the channel count starts from 0)..

Router(config)#interface serial 0/0/0:15

Router(config-if)#isdn service b_channel 19 state 2 state 2

Router(config-if)#isdn service b_channel 20 state 2 state 2

This may no even solve your problem, because when your provider will still send calls to those channels, and when it receives out of service on them, the end user will just get a busy signal.I doubt if it will try another channel and even if it does it has to try almost half the channel to get a working one..I am sure the call would have been dropped by then.

You need to sort this out at the telco. Let them know what you dont have a full PRI and either change your circuit to a fractional one or send calls only to the channels you have available. You wont get any where by re-engineering..

 

 

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Dear Ayodeji,Thanks for the

Dear Ayodeji,

Thanks for the tip. You're right, timelot 16 is D-channel... In my mind, B_channel 16 was timeslot 17 :)
I tired again, but no luck still: Channels over 16 do reject the command as well.

I talked with the provider (Swisscom), which is the first in my life letting me know that the number of usable channles is 30, and can't be reduced... Well, in fact, I'm sure they can, but hard for them to get out of standards. Seems I'll definitely have to change the PVDM to 32 and reconfigure :-/

Thanks for your help anyway.
Philippe.

RTR-505-012(config-if)#isdn service b_channel 18 state 2 ?
  hard       Change the service state and clear the call.
  immediate  Send the service message right away (default)
  soft       Change the service state once the channel becomes idle.
  <cr>

RTR-505-012(config-if)#isdn service b_channel 18 state 2
%The service state of reserved channel 18 on DSL 0 can not be changed.

 

 

VIP Super Bronze

I just looked at your config

I just looked at your config again. You dont have channels 17-31, so you cant busy them out. You only have channels 1-16. That is why the gateway is saying it is reserved. So if the telco cant help you, then you need more dsps.
 

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Hi again,Yes, it seems I have

Hi again,

Yes, it seems I have finally no other choice but adding DSPs... Just grabbed a spare PVDM2-32, will replace my both PVDM2-8. Thank you all for your kind help.

Philippe.

1736
Views
0
Helpful
6
Replies
CreatePlease to create content