Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

how to list contents of DVD in CUCM server drive

Is there some CLI command to simply list the contents - whatever they may be - of the DVD sitting in the tray?  I asked the remote user to insert the DVD containing the latest device pack (for CUCM 6.0.1) and yet I keep getting "no valid upgrade options were found". 

Yes, I've tried putting on the dev pack via SFTP, but it just doesn't work.  After downloading the fila, and 'verifying' it, the screen reverts to the previous screen - the one where you specify DVD/CD or remote filesys, username, path, etc., etc.  This is a CUCM-BE 6.0 server, and I've had the exact same issue on a full CUCM 7.0 server.  Seems the DevPack only likes to install via DVD.  And I'd like to determine whether the remote people have indeed placed the correct DVD in the correct server.

Thanks in advance . . .


Re: how to list contents of DVD in CUCM server drive


this might take a bit, but once you have access you should be able to see anything you want

I won't take credit for it, I'm not that bright.  I found the link here:

This guy is much smarter!




Re: how to list contents of DVD in CUCM server drive

I would recommend taking that DVD out of the drive and checking the contents on another server. You may want to burn another copy just to be sure it wasn't a bad burn.

If after doing that it still doesn't work you may want to contact TAC. There were some problems in certain CUCM versions where certain upgrades werent properly detected.

If all else fails you can see if the CUCM server can detect a phone load file, or an upgrade file instead of the device pack file.

Community Member

Re: how to list contents of DVD in CUCM server drive

Quick update:

There is a problem with the current device pack file for 6.0.1 as posted on CCO.  The problem filename is cmterm-devicepack6.0.1.3125-1.cop.sgn - - I downloaded it twice, and it passed MD5 both times.  But each time trying to apply via SFTP it would fail (with no meaningful message until you dig into the install log). 

When I finally tried the next-oldest device pack (cmterm-devicepack6.0.1.3121-1.cop.sgn) it installed flawlessly via SFTP. 

I never found out how to simply list contents of the DVD via CLI or any other way (at least, any method sanctioned by Cisco), other than have the remote user take it out of the tray and insert it into a non-appliance box.  But thought the above info might be helpful to some.

CreatePlease to create content