Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to send complete caller id on Cisco CME...

Hi,

we have a Cisco CME 8.6.

Now, when internal DN make an external call, it present only a general customer's number without user DN (for example only 0612345 and not 0612345XX).

How we can send complete user number to external PSTN (or cell) destination?

We need this to permit a recall from remote destination direct to internal user, without any operator's actions.

thanks!

11 REPLIES

How to send complete caller id on Cisco CME...

Can you post your configuration? Sometimes the carrier will overwrite your ANI due to the DID not being a number that they assigned to you or because they're under the impression that you want all calls to show up as the primary business number.

HTH

Regards,

Yosh

HTH Regards, Yosh
New Member

How to send complete caller id on Cisco CME...

This is my config (with only interesting parts)


UC560#sho run
UC560#sho running-config
Building configuration...

!
!
!

!
clock timezone gmt 1 0
clock summer-time GMT recurring
network-clock-participate wic 1
network-clock-select 1 BRI0/1/0
network-clock-select 2 BRI0/1/1
!
!

dot11 syslog
ip source-route
ip cef
!
!
!
!
!
ip inspect WAAS flush-timeout 10
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
!
isdn switch-type basic-net3
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
sip     
  no update-callerid
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
voice register global
mode cme
source-address 10.1.1.254 port 5060
load 9971 sip9971.9-2-2
load 9951 sip9951.9-2-2
load 8961 sip8961.9-2-2
!
!
!
voice translation-rule 1000
rule 1 /.*/ //
!
!
voice translation-profile nondialable
translate called 1000
!
!
voice-card 0
!
fax interface-type fax-mail
!
!
license udi pid UC560-BRI-K9 sn
license accept end user agreement
archive
log config
  logging enable
  logging size 600
  hidekeys
vtp mode client
username admin privilege 15 secret
!
!
ip tftp source-interface GigabitEthernet0/1/0
!
translation-rule 1
Rule 1 00 0
Rule 2 01 1
Rule 3 000 00
Rule 4 0199 199
Rule 5 0178 178
!
!        
translation-rule 2
Rule 1 03 3
!
!
translation-rule 3
Rule 1 0800 800
Rule 2 0899 899
Rule 3 0848 848
Rule 4 0892 892
Rule 5 0895 895
Rule 6 0894 894
Rule 7 0899800 899800
Rule 8 0803 803
Rule 9 0840 840
!
!
!
interface GigabitEthernet0/1/0
switchport access vlan 100
switchport voice vlan 100
no ip address
!
interface GigabitEthernet0/1/1
switchport mode trunk
switchport voice vlan 100
no ip address
shutdown
macro description cisco-switch
!
interface GigabitEthernet0/1/2
no ip address
shutdown
macro description cisco-desktop
spanning-tree portfast
!
interface GigabitEthernet0/1/3
description Interface used to communicate with integrated service module
switchport access vlan 90
no ip address
shutdown
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
interface BRI0/1/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn sending-complete
isdn static-tei 0
!
interface BRI0/1/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn sending-complete
isdn static-tei 0
!
interface Vlan1
no ip address
!
interface Vlan100
description $FW_INSIDE$
ip address 10.1.1.254 255.255.255.0
ip nat outside
ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
ip dns server
ip nat inside source list 1 interface Vlan100 overload
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
access-list 1 permit 10.1.10.0 0.0.0.3
!
!
!
!

!
!
!
control-plane
!
!
voice-port 0/0/0
caller-id enable
!
voice-port 0/0/1
caller-id enable
!
voice-port 0/0/2
caller-id enable
!
voice-port 0/0/3
caller-id enable
!
voice-port 0/1/0
compand-type a-law
cptone IT
bearer-cap Speech
!
voice-port 0/1/1
compand-type a-law
cptone IT
bearer-cap Speech
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.254 identifier 1 version 3.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
dial-peer voice 1 pots
destination-pattern 21.
incoming called-number (pstn ext. user's number with one "dot", one variable)
direct-inward-dial
port 0/1/1
!
dial-peer voice 2 pots
destination-pattern 21.
incoming called-number (pstn ext. user's number with one "dot", one variable)
direct-inward-dial
port 0/1/0
!
dial-peer voice 3 pots
destination-pattern 20.
incoming called-number (pstn ext. user's number with one "dot", one variable)
direct-inward-dial
port 0/1/1
!
dial-peer voice 4 pots
destination-pattern 20.
incoming called-number (pstn ext. user's number with one "dot", one variable)
direct-inward-dial
port 0/1/0
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 6 pots
description tcatch all dial peer for BRI/PRIv
translation-profile incoming nondialable
incoming called-number .%
direct-inward-dial
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 299
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 2012 voip
description ** cue prompt manager number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 299
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 10 pots
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
translate-outgoing called 1
direct-inward-dial
port 0/1/0
forward-digits all
!
dial-peer voice 11 pots
destination-pattern 0T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
translate-outgoing called 1
direct-inward-dial
port 0/1/1
forward-digits all
!
dial-peer voice 12 pots
destination-pattern 03T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
translate-outgoing called 2
direct-inward-dial
port 0/1/0
forward-digits all
!
dial-peer voice 13 pots
destination-pattern 03T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
translate-outgoing called 2
direct-inward-dial
port 0/1/1
forward-digits all
!
dial-peer voice 14 pots
destination-pattern 08T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
translate-outgoing called 3
direct-inward-dial
port 0/1/0
forward-digits all
!
dial-peer voice 15 pots
destination-pattern 08T
progress_ind alert enable 8
progress_ind progress enable 8
progress_ind connect enable 8
translate-outgoing called 3
direct-inward-dial
port 0/1/1
forward-digits all
!
!
no dial-peer outbound status-check pots
presence
presence call-list
!
!        
!
telephony-service
video
fxo hook-flash
max-ephones 138
max-dn 600
ip source-address 10.1.1.254 port 2000
auto assign 1 to 1 type bri
calling-number initiator
service phone videoCapability 1
service phone ehookenable 1
service dnis overlay
service dnis dir-lookup
service dss
timeouts interdigit 5
system message
user-locale IT
network-locale IT
load 7914 S00105000400
load 7915-12 B015-1-0-4
load 7915-24 B015-1-0-4
load 7916-12 B016-1-0-4
load 7916-24 B016-1-0-4
load 7906 SCCP11.9-2-1S
load 7911 SCCP11.9-2-1S
load 7921 CP7921G-1.4.1SR1
load 7925 CP7925G-1.4.1SR1
load 7931 SCCP31.9-1-1SR1S
load 7936 cmterm_7936.3-3-21-0
load 7937 apps37sccp.1-4-4-0
load 7960-7940 P00308010200
load 7941 SCCP41.9-1-1SR1S
load 7941GE SCCP41.9-1-1SR1S
load 7942 SCCP42.9-1-1SR1S
load 7945 SCCP45.9-1-1SR1S
load 7961 SCCP41.9-1-1SR1S
load 7961GE SCCP41.9-1-1SR1S
load 7962 SCCP42.9-1-1SR1S
load 7965 SCCP45.9-1-1SR1S
load 7970 SCCP70.9-1-1SR1S
load 7971 SCCP70.9-1-1SR1S
load 7975 SCCP75.9-1-1SR1S
load 521G-524G cp524g-8-1-17
load 525G spa525g-7-4-9c
load 501G spa50x-30x-7-4-9c
load 502G spa50x-30x-7-4-9c
load 504G spa50x-30x-7-4-9c
load 508G spa50x-30x-7-4-9c
load 509G spa50x-30x-7-4-9c
load 525G2 spa525g-7-4-9c
load 301 spa50x-30x-7-4-9c
load 303 spa50x-30x-7-4-9c
load 6921 SCCP69xx.9-1-1-2-sr
load 6941 SCCP69xx.9-1-1-2-sr
load 6961 SCCP69xx.9-1-1-2-sr
load 6901 SCCP6901.9-1-1-0
load 6911 SCCP6911.9-1-1-0
time-zone 23
time-format 24
date-format dd-mm-yy
keepalive 30 auxiliary 4
voicemail 299
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name cisco secret 5
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
transfer-pattern .T
transfer-pattern 0.T
transfer-pattern 6... blind
secondary-dialtone 0
after-hours pstn-prefix 4 4
night-service code *1234
night-service day Sun 17:00 09:00
night-service day Mon 09:00 19:00
night-service day Tue 09:00 19:00
night-service day Wed 09:00 19:00
night-service day Thu 09:00 19:00
night-service day Fri 09:00 19:00
night-service day Sat 17:00 09:00

fac standard
create cnf-files version-stamp 7960 Sep 27 2013 14:04:25
!
!
ephone-template  1
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM LiveRcd Confrn Acct Park
!
!
ephone-template  15
button-layout 7931 2
!
!
ephone-dn  1  dual-line
number 201 secondary (complete pstn ext. user's number) no-reg primary
label 201
description
name
allow watch
!
!        
xxxxxxxxxxxxxxxxxxx
!
ephone-dn  30
number (complete pstn root number)
description Centralino (operator)
call-forward all 205
!        
!
!
!
ephone  1
device-security-mode none
video
mac-address xxxxxxxxxxxxxxx
ephone-template 1
max-calls-per-button 2
type 504G
button  1:7 2m2 3m6 4m3
!
!
!
ephone  2
device-security-mode none
video
mac-address xxxxxxxxxxxxxxx
ephone-template 1
max-calls-per-button 2
type 524G
button  1:8 2m6 3m7 4m2
!
!


UC560#exit

thanks!

How to send complete caller id on Cisco CME...

Can you also post "debug isdn q931" logs for an outgoing call

Thanks

Manish

New Member

How to send complete caller id on Cisco CME...


UC560#debug isdn q931
debug isdn q931 is  ON.
UC560#
UC560#
008945: Mar  5 16:28:07.575: ISDN BR0/1/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Calling num 205
008946: Mar  5 16:28:07.575: ISDN BR0/1/0 Q931: Sending SETUP  callref = 0x0018 callID = 0x927F switch = basic-net3 interface = User
008947: Mar  5 16:28:07.575: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8  callref = 0x18
Bearer Capability i = 0x8090A3
  Standard = CCITT
  Transfer Capability = Speech 
  Transfer Mode = Circuit
  Transfer Rate = 64 kbit/s
Channel ID i = 0x81
  Preferred, B1
Progress Ind i = 0x8183 - Origination address is non-ISDN 
Calling Party Number i = 0x0080, '205'
  Plan:Unknown, Type:Unknown
Called Party Number i = 0x80, '335xxxxxxxx( my cellular)'
  Plan:Unknown, Type:Unknown
Sending Complete
008948: Mar  5 16:28:07.615: ISDN BR0/1/0 Q931: RX <- CALL_PROC pd = 8  callref = 0x98
Channel ID i = 0x89
  Exclusive, B1
008949: Mar  5 16:28:12.583: ISDN BR0/1/0 Q931: RX <- PROGRESS pd = 8  callref = 0x98
Progress Ind i = 0x8188 - In-band info or appropriate now available
008950: Mar  5 16:28:12.599: ISDN BR0/1/0 Q931: RX <- ALERTING pd = 8  callref = 0x98
Progress Ind i = 0x8188 - In-band info or appropriate now available
008951: Mar  5 16:28:26.939: ISDN BR0/1/0 Q931: TX -> DISCONNECT pd = 8  callref = 0x18
Cause i = 0x8090 - Normal call clearing
008952: Mar  5 16:28:26.963: ISDN BR0/1/0 Q931: RX <- RELEASE pd = 8  callref = 0x98
Cause i = 0x8290 - Normal call clearing
008953: Mar  5 16:28:26.963: ISDN BR0/1/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x18
UC560#
UC560#

Number 205 is a user IP Phone DN.

My cellular shows a "root" pstn customer number and not a user's direct (complete) pstn number.

Thanks!

New Member

Re: How to send complete caller id on Cisco CME...

Hi,

anyone have news for me...?

We must modify "Calling Party Number"...?

And, if so, how we can do it..?

Thanks!

Re: How to send complete caller id on Cisco CME...

Hi,

You can achieve this in multiple ways:-

1). Under ephone-dn, you can give description as your full number so that whenever call through that DN is made the outgoing calling number will be your description number.

ephone-dn 1

number XXX

description 0612345XXX

exit

Then restart the phone to be in effective.

OR

2). Create Translation profile in which you will create rule to change your calling number.

This profile you can apply to your POTS dial-peer.

dial-peer voice XXX pots

translation profile outgoing ABC

exit

voice translation-rule BB

rule 1 /^XXX/ /0612345\0/

exit

voice translation-profile ABC

translate calling BB

exit

Regards,
Nishant Savalia

Regards, Nishant Savalia
New Member

Hi,with a description

Hi,

with a description modified, nothing.

and rule 1 /^XXX/ /0612345\0/  I've received an error at "^".

Command unrecognized.

thanks!

New Member

Hi, any others idea for?Now

Hi,

 

any others idea for?

Now we have asked to provider if they are ready for present complete number.

And they permit complete number.

thanks!

Re: How to send complete caller id on Cisco CME...

Hello,

Apply this config on your router.

If your DID number starts with 0612345xxx. (or you can modify according to your requirement)

voice translation-rule 1

rule 1 /^\(2..\)$/ /0612345\1/

!

voice translation-profile CallingNumberTranslation

translate calling 1

And then apply this translation profile under outgoing dial-peer towards PSTN. In you case it will be DP 10,11,12,13,14 and 15.

dial-peer voice xx pots

translation-profile outgoing CallingNumberTranslation

Check "debug isdn q931" , if you see your calling number correct there (as required) but on external destination you still see problem with the last digits then you need to get in touch with Telco for this. Share this debug output with them and tell them that i am sending correct calling number towards PSTN but your network is clipping last digits.

Rate all helpful post.

Thanks

Manish

New Member

Hi,using rule 1 /^\(2..\)$/

Hi,

using rule 1 /^\(2..\)$/ /0612345\1/

we obtain this:

 

Mar 11 14:28:47.885: ISDN BR0/1/1 Q931: TX -> SETUP pd = 8  callref = 0x71
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x81
                Preferred, B1
        Progress Ind i = 0x8183 - Origination address is non-ISDN
        Calling Party Number i = 0x0080, '061234567205'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '335(my cell)'
                Plan:Unknown, Type:Unknown
        Sending Complete
009811: Mar 11 14:28:47.929: ISDN BR0/1/1 Q931: RX <- CALL_PROC pd = 8  callref = 0xF1
        Channel ID i = 0x89
                Exclusive, B1
009812: Mar 11 14:28:52.857: ISDN BR0/1/1 Q931: RX <- PROGRESS pd = 8  callref = 0xF1
        Progress Ind i = 0x8188 - In-band info or appropriate now available
009813: Mar 11 14:28:52.873: ISDN BR0/1/1 Q931: RX <- ALERTING pd = 8  callref = 0xF1
        Progress Ind i = 0x8188 - In-band info or appropriate now available
009814: Mar 11 14:29:03.961: ISDN BR0/1/1 Q931: TX -> DISCONNECT pd = 8  callref = 0x71
        Cause i = 0x8090 - Normal call clearing
009815: Mar 11 14:29:03.985: ISDN BR0/1/1 Q931: RX <- RELEASE pd = 8  callref = 0xF1
        Cause i = 0x8290 - Normal call clearing
009816: Mar 11 14:29:03.985: ISDN BR0/1/1 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x71
 

that was a wrong number.

At the end of 061234567 we need only one number and not all internal DN (that doesn't exsist on PSTN) so

0612345675 is correct, 061234567205 is wrong...

How we can modify this roule?

Thanks!

 

If you want all calling

If you want all calling number to represented as  0612345675. use this...

rule 1 /^2../ /0612345675/

 

Or you want starting 9 digits remain as it is and the last digit picked from the calling DN then use this...

rule 1 /^2.\(.\)$/ /061234567\1/

 

Rate all helpful post.

 

Thanks

Manish

 

582
Views
0
Helpful
11
Replies