Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to start implementing Auto QOS for Nec Ip Phone

Hello we are using nec DT700 IP phone here on cisco switch

We have 1 core 3750 and 5 switch 3560 interconnecting with trunk port

Here how we presently config ip phone port switch

PC AND Phone

switchport trunk encapsulation dot1q

switchport trunk native vlan 30

switchport trunk allowed vlan 30,33

switchport mode trunk

spanning-tree portfast

Phone only

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 30,33

switchport mode trunk

spanning-tree portfast

I don't really know nothing about qos and auto qos

What do you think i should do ?

Is it too complicated to implement auto qos without knowing anything about how it work ?

Thanks for helpoing me !

1 REPLY

How to start implementing Auto QOS for Nec Ip Phone

This example comes from the NEC manual and maybe helps a little, but is bit strange because the choices of bandwidth and DSCP:

Current Configuration : 2023 bytes
version 12.3
hostname Cisco2621
|

class-map match-any VoIPClass (1) match ip dscp cs5 (2) policy-map VoIPPolicy (3) class VoIPClass (4) priority 50 (5) class class-default (6) fair-queue (7)

|
interface FastEthernet0/0
 description Connects to Dallas LAN
 ip address 192.168.1.1 255.255.255.0
|

interface Serial0/0
description Connects to Fort Worth via Kilostream bandwidth 256 (8) ip address 10.0.0.1 255.255.0.0
service-policy output VoIPPolicy (9) encapsulation ppp

|
ip route 0.0.0.0 0.0.0.0 10.0.0.2

Configuration Example Explanation:

  1. Defines a Class Map called VoIPClass.

  2. Matches any packets that have the ToS field set to IP Precedence 5 / DSCP 40 and assigns them to VoIPClass.

  3. Defines a Policy Map called VoIPPolicy.

  4. Creates a Class called VoIPClass and assigns this to the VoIPPolicy.

  5. Allocates 50Kbps of bandwidth to the VoIPClass.

6 & 7.Determines that any data that does not match VoIPClass should be processed using the “fair-queue” method (i.e., No Prioritization).

8. 9.

Determines the amount of bandwidth available on the Serial interface – essential for the QoS calculations.

Applies the VoIP Policy to any packets that exit the serial interface. This means that data being received (input) does not use this policy.

PM me our email address and I can share the document with you.

Brandon

-- please remember to rate and mark answered helpful posts --
1340
Views
0
Helpful
1
Replies
CreatePlease to create content