Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

i need know frequency on fxo trunk

i have problem on fxo gateway

when i  make call out side on pstn the ip phone make connect direct and billing server make bill the call

i need know how to frequency on ksa

frquency ring out

frequency outside the mobile is close

frequency wrong number

frequency disconnect signal

  • IP Telephony
1 ACCEPTED SOLUTION

Accepted Solutions

Re: i need know frequency on fxo trunk

Hello Haytham

1-Can you use the below link to get all required tones?.

http://www.3amsystems.com/wireline/tone-search.htm?


2- Please find the below :-

voice class custom-cptone STC

dualtone busy

  frequency 425 425

  cadence 500 500

dualtone ringback

  frequency 425 425

  cadence 1000 4000

dualtone reorder

  frequency 425 425

  cadence 250 250

dualtone out-of-service

  frequency 425 425 

  cadence 320 320

dualtone disconnect

  frequency 425 425

  cadence 500 500

!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone STC

supervisory dualtone-detect-params 2

no battery-reversal

cptone SA

timeouts initial 5

timeouts interdigit 3

timeouts call-disconnect 3

timeouts ringing 5

timeouts wait-release 1

timing hookflash-out 50

timing guard-out 300

timing sup-disconnect 300

connection plar opx 8800

impedance complex2

caller-id enable

Thank you

Please rate all useful information

6 REPLIES

Re: i need know frequency on fxo trunk

Hello Haytham

1-Can you use the below link to get all required tones?.

http://www.3amsystems.com/wireline/tone-search.htm?


2- Please find the below :-

voice class custom-cptone STC

dualtone busy

  frequency 425 425

  cadence 500 500

dualtone ringback

  frequency 425 425

  cadence 1000 4000

dualtone reorder

  frequency 425 425

  cadence 250 250

dualtone out-of-service

  frequency 425 425 

  cadence 320 320

dualtone disconnect

  frequency 425 425

  cadence 500 500

!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone STC

supervisory dualtone-detect-params 2

no battery-reversal

cptone SA

timeouts initial 5

timeouts interdigit 3

timeouts call-disconnect 3

timeouts ringing 5

timeouts wait-release 1

timing hookflash-out 50

timing guard-out 300

timing sup-disconnect 300

connection plar opx 8800

impedance complex2

caller-id enable

Thank you

Please rate all useful information

i need know frequency on fxo trunk

Hi,

Try with fxo port empty configuration

add

cptone [your country]

It should work normall

You'll need frequency if you face fxo disconnect issue

Regards

Haitham

New Member

i need know frequency on fxo trunk

dear eng islam

thanks for help

when call come on router directly remove number 9 make connect direct same after change confiuration

if you found problem tell me

this configuration on router

!
! Last configuration change at 20:33:40 UTC Tue Oct 29 2013
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname voicegateway1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$R/VE$zJggecBnCmnKxPqfgRvU71
!
no aaa new-model
!
no ipv6 cef
!
!
!
!
!
ip cef
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group VIC2-4FXO
!
crypto pki token default removal timeout 0
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
codec preference 4 g729br8
!
voice class h323 1
  h225 timeout tcp establish 3
  h225 timeout setup 3
!
voice class custom-cptone STC
dualtone busy
  frequency 425 425
  cadence 500 500
dualtone ringback
  frequency 425 425
  cadence 1000 4000
dualtone reorder
  frequency 425 425
  cadence 250 250
dualtone out-of-service
  frequency 425 425
  cadence 320 320
dualtone disconnect
  frequency 425 425
  cadence 500 500
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FGL160610FE
hw-module pvdm 0/0
!
hw-module sm 1
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 172.16.12.3 255.255.252.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.16.12.3
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 172.16.12.254
!
!
!
!
control-plane
!
!
voice-port 0/0/0
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8187887
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/1
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8187778
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/0/2
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8187777
caller-id enable
!
voice-port 0/0/3
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8189001
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/1/0
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8189009
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/1/1
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8188007
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/1/2
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8188006
caller-id enable
!
voice-port 0/1/3
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8188004
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/2/0
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
description line 8188002
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/2/1
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 0/2/2
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
caller-id enable
!
voice-port 0/2/3
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
voice-port 1/0/4
!
voice-port 1/0/5
!
voice-port 1/0/6
!
voice-port 1/0/7
!
voice-port 1/0/8
trunk-group VIC2-4FXO
supervisory disconnect dualtone mid-call
supervisory custom-cptone STC
no battery-reversal
cptone SA
timeouts initial 5
timeouts interdigit 3
timeouts call-disconnect 3
timeouts ringing 5
timeouts wait-release 1
timing hookflash-out 50
timing guard-out 300
timing sup-disconnect 300
connection plar opx 8400
impedance complex2
caller-id enable
caller-id alerting dsp-pre-allocate
!
voice-port 1/0/9
!
voice-port 1/0/10
!
voice-port 1/0/11
!
voice-port 1/0/12
!
voice-port 1/0/13
!
voice-port 1/0/16
!
voice-port 1/0/17
!
voice-port 1/0/18
!
voice-port 1/0/19
!
voice-port 1/0/20
!
voice-port 1/0/21
!
!
!
!
!
!
mgcp profile default
!
!
dial-peer voice 3 voip
description Local extensions
preference 1
destination-pattern ....
session target ipv4:172.16.12.11
voice-class codec 1 
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 4 voip
description Local extensions
destination-pattern ....
session target ipv4:172.16.12.12
voice-class codec 1 
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 51 pots
trunkgroup VIC2-4FXO
destination-pattern 9[2-8]......
forward-digits 7
!
dial-peer voice 52 pots
trunkgroup VIC2-4FXO
destination-pattern 90[123467].......
forward-digits 10
!
dial-peer voice 53 pots
trunkgroup VIC2-4FXO
destination-pattern 905........
forward-digits 10
!
dial-peer voice 54 pots
trunkgroup VIC2-4FXO
destination-pattern 800.......
forward-digits 10
!
dial-peer voice 55 pots
trunkgroup VIC2-4FXO
destination-pattern 9200.....
forward-digits 9
!
dial-peer voice 56 pots
trunkgroup VIC2-4FXO
destination-pattern 99..
forward-digits 3
!
dial-peer voice 57 pots
trunkgroup VIC2-4FXO
destination-pattern 00T
no digit-strip
forward-digits all
!
!
gateway
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password terminal
login
transport input all
!
scheduler allocate 20000 1000
!

New Member

i need know frequency on fxo trunk

eng islam

supervisory dualtone-detect-params 2

order not complete

i need order

voice class dualtone-detect-params 2

i need know frequency on fxo trunk

I would try the cptone suggestion for your country. If that doesn't work you might need to do a PCM capture and listen to it in audacity to extract the exact frequencies, although it's rarely needed.

Making the World a better place, one call at a time.

New Member

i need know frequency on fxo trunk

eng islam

order is working

but frequency out-off service not correct

876
Views
0
Helpful
6
Replies
This widget could not be displayed.