Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

In/Out Bound Calls Config

I need some help with setting up my 2821 to route call via CUCM 7 on the FXO port.  I have a few IP phones registered with CUCM 7, I just installed the Vic2-2FXO card, but not sure what I need to do in order to be able to make/recieved calls from the PBX.

I don't have anything configured on my router yet, just not sure where to start.

2821#show run

Building configuration...

Current configuration : 2011 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2821

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

ip cef

!

no ip dhcp use vrf connected

!

ip dhcp pool Home_Network

   network 192.168.1.0 255.255.255.0

   option 150 ip 192.168.1.245

   default-router 192.168.1.1

!

!

ip domain name jjkkcc.com

ip name-server 192.168.1.250

ip name-server 68.105.28.16

ip name-server 68.105.29.16

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2821 sn FTX1033A2QR

username woodjl1650 privilege 15 secret 5 $1$mVDP$.Re5.yF4HDkGPQJBiGSDy.

!

redundancy

!

!

ip ssh version 2

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 192.168.1.119 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.0.119 255.255.255.0

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 125000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 125000

!

ip forward-protocol nd

ip http server

no ip http secure-server

ip http path flash:gui

!

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!

logging esm config

!

!

!

!

!

!

control-plane

!

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 192.168.1.245

ccm-manager config

!

mgcp

mgcp call-agent CUCM7 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package mt-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

!

mgcp profile default

!

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input ssh

!

scheduler allocate 20000 1000

end

2821#

  • IP Telephony
5 REPLIES
Hall of Fame Super Silver

In/Out Bound Calls Config

Looks like you got some MGCP config which is one of the protocols you can use, all you need to do is configure the MGCP in CUCM as a gateway and build route patterns/route list/route group pointing to it. 

Make sure the route patterns are in a partition that is accessible from the CSS assigned to the phone.

HTHm

Chris

New Member

In/Out Bound Calls Config

Can my VIC2-2FXO card be plugged into the HWIV slot or can install it in the NM-HDV?

Hall of Fame Super Silver

In/Out Bound Calls Config

Yes, it can go to one of the HWIC slots, you need to ensure you have PVDMs in the router though as TDM based voice connection such as FXO requires digital signal processing.  Issue "sh inventory" to see if you have a PVMD card inside the router.

HTH,

Chris

New Member

In/Out Bound Calls Config

So it looks like I have PVDM, correct?

2821#

*Sep 21 17:04:01.427: %SYS-5-CONFIG_I: Configured from console by consolesh inventory

NAME: "2821 chassis", DESCR: "2821 chassis"

PID: CISCO2821         , VID: V03 , SN: FTX1033A2QR

NAME: "WAN Interface Card - Serial 2A/S on Slot 0 SubSlot 0", DESCR: "WAN Interface Card - Serial 2A/S"

PID: WIC-2A/S=         , VID: 1.0, SN: 31582321

NAME: "High Density Voice on Slot 1", DESCR: "High Density Voice"

PID:                   , VID: 1.1, SN: JAB05220DLX

NAME: "PVDM 3-C549 Simm on Slot 1 SubSlot 1", DESCR: "PVDM 3-C549 Simm"

PID: PVDM-12=          , VID:    , SN:

NAME: "PVDM 3-C549 Simm on Slot 1 SubSlot 2", DESCR: "PVDM 3-C549 Simm"

PID: PVDM-12=          , VID:    , SN:

NAME: "PVDM 3-C549 Simm on Slot 1 SubSlot 3", DESCR: "PVDM 3-C549 Simm"

PID: PVDM-12=          , VID:    , SN:

In/Out Bound Calls Config

Yes, there are PVDMs on the router, however, DSPs c549 are not supported on 2800/3800 platfroms:

http://www.cisco.com/en/US/products/hw/gatecont/ps2250/products_tech_note09186a008011537d.shtml#c549dsp

  • The C549 DSP is supported on these voice platforms:

    • Cisco AS5800

    • Cisco AS5300 double-density VFC

    • Cisco 2600/3600/VG-200 Digital T1/E1 High Density Voice Network             Module

    • Cisco 7200/7500 Digital T1/E1 High Capacity Voice port adapter             (PA)

    • Cisco 1750, 1751, and 1760 routers

    • Cisco MC3810 HCM (High-density Compression             Module)

    You'll need PVDM version 2 for the 2821:

    http://www.cisco.com/en/US/prod/collateral/routers/ps5854/ps5882/product_data_sheet0900aecd8016fa68_ps5854_Products_Data_Sheet.html

    Packet Voice DSP Module (PVDM) Slots on Motherboard

    • Slots for Cisco PVDM2 Modules (DSP Modules) are integrated on the motherboard, freeing slots on the router for other services.

    HTH

    --
    Jorge Armijo

    Please remember to rate helpful responses and identify helpful or correct answers.

    -- Jorge Armijo Please remember to rate helpful responses and identify helpful or correct answers.
    227
    Views
    0
    Helpful
    5
    Replies
    This widget could not be displayed.