Cisco Support Community
Community Member

inability to create or delete a CUC user


I inherited a CUCM & CUC lab version 7.  CUC processes calls OK, but I hear a verbal error message after listening to messages in a mailbox,

"This system is temporarily unable to complete your call.  Call again later.  Goodbye." 

Besides that message, I found an inability to create or delete a CUC user "-database.error.-271".  Otherwise, the system appears to work OK.

In Cisco Unity Connection Administration Version I see the following error within System Settings>Licenses:

There was an unexpected failure executing a database stored procedure execute procedure UnityDirDb:csp_LicenseStatusModify ( pObjectId = 'bd69252c-b930-4c54-8514-2caa8de5d94e', pComplianceTime = '2010-08-03 22:30:00.886', pNextExpiryTime = '2014-04-19 23:59:59.0' ); . Please restart your system or contact support personnel if this failure continues.

I was able to restart the system successfully, but the error message persisted.

I ran the license report and see similar errors.  I imagine we have a licensing issue, but no one (apparently) has altered any licenses since CUC worked normally several weeks ago.  The licenses appear to be valid, but I notice one is marked as 'failed' to load.

If I wanted to take this on myself, what else could I investigate?  The CUC is a single node.

admin:show cuc cluster status

Server Name  Member ID  Server State  Internal State  Reason
-----------  ---------  ------------  --------------  ------
cuc6         0          Primary       Pri Active      Normal



Re: inability to create or delete a CUC user

The error you noted indicates that you were given a TEMPORARY license for Unity Connection and not a permanent one.  If you have a temp license, it has both a expiration date for when the license expires and a grace expiration date that gives you a set amount of time to either obtain a new license or the system stops operating.  According to your error:

ComplianceTime = '2010-08-03 22:30:00.886', pNextExpiryTime = '2014-04-19 23:59:59.

Your license expired on 4/19/2010 and the reason everything worked fine up until recently is because the grace period/compliance time to obtain a new license expired today 8/3/2010.

You'll need to contact and open a TAC case to resolve.  For what its worth, if you do not need a full blown license in your lab - then there is a demo license which allows 10 users and 2 ports.  Otherwise, you'll need to make that license official.


Please rate helpful posts!

Community Member

inability to create or delete a CUC user


Initially we thought that the demo license that had expired, but the licenses on the server are permanent and thus won’t expire.  The version of the Unity Connection server was 7.0(1).  Turns out there is a known bug in this version, please reference Unity Connection bug “CSCsx32588” for version 7.0(1).  Thanks to the diligence of the local SEs in Richfield for finding this.


If you are using this version of code and experience this issue, here is the method to determine if this is the result of this known bug:

Issue the following from the console:

run cuc dbquery unitydyndb select * from vw_tableinformation

This will return a table of all the tables in unitydyndb.  To analyze the disk utilization, look for the column titled dbspacepagesfree.  This value should always be greater than zero.  If it is close to zero then we know a problem is brewing.

Another command to issue is:

show cuc dbserver disk

This will return a list of the system partitions.  Look for the column titled Free MB.  This should also always be greater than zero.  If it is close to zero then we know a problem is brewing.  Typically the only tables which grow into a state where you would want to check it is the dynamic database.  In issuing the above two commands, if you see the dbspacepagesfree is zero, and the Free MB for dyn and /var/opt/cisco/connection/db/dyn_dbs is zero then you are running into this defect.


Open a TAC case referencing Unity Connection bug “CSCsx32588” for version 7.0(1).  TAC can restore functionality temporarily until the known bug occurs again.  For a more permanent solution, you can take steps to prepare an upgrade to a more recent supported version of code for CUCM and CUC.  Thanks again to TAC and local local SE.

CreatePlease to create content