Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

inbound SIP call and Greetings

Hi all

I have the following setup :

PSTN--------SIPTRUNK -------2901----H323-------CUCM8.6-------Internal

The outbound calls not active in this session as per my managment requests

The direct call for each extension is fine 22846XX

if somebody from out side call any extension with voice mail / or calling to operator 2284600 with greeting message , he cannot insert any digit, I have tested the unity connection from inside it works fine,

"Welcome to ABC company if you know the extension dial it now , or press 0 for assestent"  when I press 0 or any extension I cant see any redierction or call transfere to the enrered ext.

all expected debugs in the attached file and here is the running

any idea is appreciated

Current configuration : 4892 bytes

!

! Last configuration change at 22:53:53 UTC Wed Oct 2 2013

! NVRAM config last updated at 22:53:55 UTC Wed Oct 2 2013

! NVRAM config last updated at 22:53:55 UTC Wed Oct 2 2013

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG

!

boot-start-marker

boot-end-marker

!

!

enable password admin

!

no aaa new-model

!

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 172.16.24.1 172.16.24.10

ip dhcp excluded-address 172.16.24.40 172.16.24.50

!

ip dhcp pool IPT

network 172.16.24.0 255.255.255.0

default-router 172.16.24.1

option 150 ip 172.16.24.42

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

!

trunk group XXX

hunt-scheme random

!

crypto pki token default removal timeout 0

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

ip address trusted list

  ipv4 10.208.9.69

  ipv4 172.29.30.130

  ipv4 0.0.0.0 0.0.0.0

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol none

h323

sip

bind control source-interface GigabitEthernet0/1

  bind media source-interface GigabitEthernet0/1

  header-passing

  error-passthru

  early-offer forced

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 timeout setup 3

!

voice class sip-profiles 1

request INVITE sip-header P-Asserted-Identity remove

request INVITE sip-header Allow-Header modify ", UPDATE" ""

request REINVITE sip-header Allow-Header modify ", UPDATE" ""

response 180 sip-header Allow-Header modify ", UPDATE" ""

response 200 sip-header Allow-Header modify ", UPDATE" ""

!

voice class custom-cptone fxo_call_disconnect

dualtone disconnect

  frequency 425

  cadence 250 250

!

!

!

voice translation-rule 1

rule 1 /22846../ /666/

!

!

voice translation-profile 1

translate calling 1

translate called 1

!

!

license udi pid CISCO2901/K9 sn FCZ164790AB

license accept end user agreement

license boot module c2900 technology-package uck9

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

!

!

!

translation-rule 1

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 172.16.24.3 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip h323-id VG

h323-gateway voip bind srcaddr 172.16.24.3

!

interface GigabitEthernet0/1

ip address 172.29.30.130 255.255.255.252

duplex auto

speed auto

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 10.208.9.69 255.255.255.255 172.29.30.129

ip route 10.209.4.56 255.255.255.252 172.29.30.129

ip route 172.16.26.0 255.255.255.0 172.16.24.1

!

!

!

!

!

!

!

control-plane

!

!

voice-port 0/0/0

trunk-group XXX

cptone SA

caller-id enable

voice-port 0/0/1

trunk-group XXX

cptone SA

caller-id enable

!

voice-port 0/0/2

trunk-group XXX

cptone SA

caller-id enable

!

voice-port 0/0/3

trunk-group XXX

cptone SA

caller-id enable

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 172.16.24.42 identifier 1 priority 1 version 7.0

sccp

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 3 register hw_txd1

associate profile 1 register hw_mtp1

associate profile 2 register hw_cnf1

!

dspfarm profile 3 transcode universal 

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

rsvp

maximum sessions 4

associate application SCCP

!

dspfarm profile 2 conference 

codec g729br8

codec g729r8

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

maximum sessions 2

associate application SCCP

!

dspfarm profile 1 mtp 

codec g711ulaw

rsvp

maximum sessions software 8

associate application SCCP

!

dial-peer voice 3400 voip

translation-profile incoming 1

destination-pattern [1-6]..

session target ipv4:172.16.24.42

incoming called-number 22846..

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 5001 pots

trunkgroup EMPOWER

destination-pattern 05........

no digit-strip

!

dial-peer voice 5002 pots

trunkgroup XXX

destination-pattern [1-9]......

no digit-strip

!

dial-peer voice 5004 pots

trunkgroup XXX

destination-pattern 00T

no digit-strip

!

dial-peer voice 5410 voip

session protocol sipv2

session target ipv4:10.208.9.69

session transport udp

dtmf-relay sip-notify

codec g711ulaw

!

!

sip-ua

registrar ipv4:172.29.30.130 expires 3600

sip-server ipv4:10.208.9.69:5060

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

1 REPLY
Cisco Employee

inbound SIP call and Greetings

Hi,

I had a quick look at the debugs and could see multiple calls.

As per the following call flow and the running config, dial peer 5410 (with SIPv2) should be selected for the incoming leg and dial peer 3400 should be selected for the outgoing leg.

ITSP -> SIP -> GW -> H323 -> CUCM 

However, the dial peer 3400 is getting selected for the incoming leg (because of the command: incoming called-number 22846..)

Incoming dial peer=3400

Oct  2 22:35:25.874: //-1/xxxxxxxxxxxx/CCAPI/ccGetUriDataFromTDContainer:

   urlp=3139FDC4, urlp->original_url=sip:2284600@172.29.30.130;user=phoneInterface=0x2B2803A0, Call Info(

   Calling Number=sip:559669904@172.29.30.130;user=phone,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=sip:2284600@172.29.30.130;user=phone(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=3400, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=26206

Outgoing dial peer selected is also 3400

Oct  2 22:35:25.878: //-1/xxxxxxxxxxxx/CCAPI/ccGetUriDataFromTDContainer:

   urlp=31A83A70, urlp->original_url=sip:559669904@172.29.30.130;user=phoneInterface=0x2B55F444, Interface Type=1, Destination=, Mode=0x0,

   Call Params(Calling Number=sip:559669904@172.29.30.130;user=phone,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=666(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=3400, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

Oct  2 22:35:25.878: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Is there any specific reason that you have added the "incoming called-number 22846.." to the h323 Voip Dial peer (3400) and no pattern configured to the SIP dial peer 5410?

If no, can you try to remove the command "incoming called-number 22846.." from dial peer 3400 and add it to dial peer 5410.

Also, please collect detailed call manager traces and the following debugs for one single test call initiated from a PSTN phone.

deb ccsip messages

deb voice ccapi inout

deb h225 asn1

deb h245 asn1

HTH,

Jagpreet Singh Barmi

192
Views
0
Helpful
1
Replies
CreatePlease to create content