Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Inbound SIP trunk help needed

Good morning everyone!

Hopefully someone can take a look at this and show me where I may have gone wrong.

 

I am using flowroute as my trunk provider. I can make outbound calls just fine.

 

When I attempt to make inbound calls to our DID I get a message saying"You have reached a non working number, announcement 14 switch 4119-7"

 

I have flowroute set to point inbound on that did to my external IP, and when i run debug voice ccapi all I see the inbound call come into the router and match dial-peer 4 (my inbound voip peer), however the call does not go to extension 102 (our receptionist)

 

Attached is my config and the output from debug voice ccapi all

router1#debug voice ccapi all
voip ccapi all debugging is on
router1#
Sep  9 13:38:23.195: //-1/xxxxxxxxxxxx/CCAPI/ccSetupReqDataTDFreeHelper:
   data=4C539600
Sep  9 13:38:23.195: //-1/xxxxxxxxxxxx/CCAPI/ccFreeTdRequestDataSip:
   sipDatap = 4C539604
Sep  9 13:38:23.195: //-1/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   CALL_ERROR_INFORMATIONAL; Call Id Is Invalid=-1
Sep  9 13:38:23.195: //0/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   Call Entry Is Not Found
Sep  9 13:38:23.195: //-1/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   CALL_ERROR_INFORMATIONAL; Call Id Is Invalid=-1
Sep  9 13:38:23.195: //-1/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   CALL_ERROR_INFORMATIONAL; Call Id Is Invalid=-1
Sep  9 13:38:23.199: //50477/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   Call Entry Is Not Found
Sep  9 13:38:23.199: //-1/xxxxxxxxxxxx/CCAPI/cc_set_post_tagdata:
Sep  9 13:38:23.199: //50477/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   Call Entry Is Not Found
Sep  9 13:38:23.199: //-1/xxxxxxxxxxxx/CCAPI/cc_set_post_tagdata:
   CALL_ERROR; Avlist Set Is Failed
Sep  9 13:38:23.199: //50477/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   Call Entry Is Not Found
Sep  9 13:38:23.199: //-1/6743583688FD/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=+12145579949
   ----- ccCallInfo IE subfields -----
   cisco-ani=+12145579949
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=19729965165
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Sep  9 13:38:23.203: //-1/6743583688FD/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x4A00F130, Call Info(
   Calling Number=+12145579949,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=19729965165(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=4, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=50477
Sep  9 13:38:23.203: //-1/6743583688FD/CCAPI/cc_api_call_setup_ind_common:
   Interface Type=0, Protocol=3
Sep  9 13:38:23.203: //-1/6743583688FD/CCAPI/ccCheckClipClir:
   In: Calling Number=+12145579949(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Sep  9 13:38:23.203: //-1/6743583688FD/CCAPI/ccCheckClipClir:
   Calling Party Number Is User Provided
Sep  9 13:38:23.203: //-1/6743583688FD/CCAPI/ccCheckClipClir:
   Out: Calling Number=+12145579949(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Sep  9 13:38:23.203: //-1/6743583688FD/CCAPI/cc_api_call_setup_ind_common:
   After Number Translation Checking:
   Calling Number=+12145579949(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=19729965165(TON=Unknown, NPI=Unknown)
Sep  9 13:38:23.203: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep  9 13:38:23.203: :cc_get_feature_vsa malloc success
Sep  9 13:38:23.203: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep  9 13:38:23.203:  cc_get_feature_vsa count is 1
Sep  9 13:38:23.203: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep  9 13:38:23.203: :FEATURE_VSA attributes are: feature_name:0,feature_time:1224289208,feature_id:474
Sep  9 13:38:23.203: //50477/xxxxxxxxxxxx/CCAPI/cc_insert_call_entry:
   Total Call Count=0, Call Entry(Call Count On=FALSE, Incoming Call=TRUE)
Sep  9 13:38:23.203: //50477/xxxxxxxxxxxx/CCAPI/cc_insert_call_entry:
   Total Call Count=1
Sep  9 13:38:23.203: //-1/xxxxxxxxxxxx/CCAPI/cc_init_call_entry:

Sep  9 13:38:23.203:  call_init_entry calle is 4BC14108,callid is 50477
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_init_call_entry:
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_insert_guid_pod_entry:
   Incoming=TRUE, Call Id=50477
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=+12145579949(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=19729965165(TON=Unknown, NPI=Unknown))
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_api_insert_call_active_entry:
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_incr_if_call_volume:
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_incr_if_call_volume:
   Remote IP Address
Sep  9 13:38:23.203: //50477/6743583688FD/CCAPI/cc_incr_if_call_volume:
   Total Call Count=1, Voip Call Count=1, MMoip Call Count=0
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/cc_process_call_setup_ind:
   Event=0x4B1E6A50
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_registration_lookup:
   Matching Parameters; Called Number=19729965165, Call Transfer Consult Id=
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Searching Node;
   Called Number=19729965165, Call Transfer Consult Id=
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_compare:

Sep  9 13:38:23.207: Comparing SSOpCode; 0x50 and 0x0
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_compare:

Sep  9 13:38:23.207: Comparing SSOpCode; 0x12 and 0x0
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 19729965165
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_compare:

Sep  9 13:38:23.207: Comparing SSOpCode; 0x50 and 0x0
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_compare:

Sep  9 13:38:23.207: Comparing SSOpCode; 0x12 and 0x0
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_registration_lookup:
   No Matching Node
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/cc_set_post_tagdata:
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallSetContext:
   Context=0x4C73F784
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 50477 with tag 4 to app "_ManagedAppProcess_TOLLFRAUD_APP"
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallActiveUpdateNumbers:
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallActiveUpdateNumbers:
Sep  9 13:38:23.207: //-1/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   CALL_ERROR_INFORMATIONAL; Call Id Is Invalid=-1
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallDisconnect:
   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallDisconnect:
   Start Calling Accounting;
   Call Entry(Incoming=TRUE)
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallDisconnect:
   Cause Value=21, Call Entry(Disconnect Cause=0)
Sep  9 13:38:23.207: //50477/6743583688FD/CCAPI/ccCallDisconnect:
   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)
Sep  9 13:38:23.251: //-1/xxxxxxxxxxxx/CCAPI/cc_api_icpif:
   ExpectFactor=0xA
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_api_insert_call_history:
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/ccGetCallActiveByCallID:
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_decr_if_call_volume:
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_decr_if_call_volume:
   Remote IP Address
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_decr_if_call_volume:
   Total Call Count=0, Voip Call Count=0, MMoip Call Count=0
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4A00F130, Tag=0x0, Call Id=50477,
   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_disconnect_notify:
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/callStackPop:exit@4886
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_delete_guid_pod_entry:
   Incoming=TRUE
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_delete_guid_pod_entry:exit@1165
Sep  9 13:38:23.255: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep  9 13:38:23.255: :cc_free_feature_vsa freeing 48F92BB0
Sep  9 13:38:23.255: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep  9 13:38:23.255:  vsacount in free is 0
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_delete_call_entry:
   Total Call Count=1, Call Entry(Call Count On=FALSE, Incoming Call=TRUE)
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_delete_call_entry:
   Total Call Count=0
Sep  9 13:38:23.255: //50477/6743583688FD/CCAPI/cc_delete_call_entry:
   Deleting profileTable[0x4C4A6570]
Sep  9 13:38:23.259: //0/xxxxxxxxxxxx/CCAPI/cc_get_call_entry:
   Call Entry Is Not Found
Sep  9 13:38:23.259: //0/xxxxxxxxxxxx/CCAPI/cc_api_call_preempt_done:
   CALL_ERROR_INFORMATIONAL; Call Entry Is Not Found

 

router1#sh run
Building configuration...


Current configuration : 5430 bytes
!
! Last configuration change at 13:42:23 UTC Tue Sep 9 2014
! NVRAM config last updated at 13:35:37 UTC Tue Sep 9 2014
! NVRAM config last updated at 13:35:37 UTC Tue Sep 9 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.1.100.1 10.1.100.50
ip dhcp excluded-address 10.1.1.1 10.1.1.49
!
ip dhcp pool Data
 network 10.1.1.0 255.255.255.0
 dns-server 10.1.1.20
 option 150 ip 10.1.1.1
 default-router 10.1.1.1
!
!
ip domain name legacy.local
ip name-server 8.8.8.8
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
 ip address trusted list
  ipv4 214.115.69.0 255.255.255.0
  ipv4 70.167.153.130 255.255.255.255
  ipv4 24.240.233.212 255.255.255.255
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.3
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 h245-address on-connect
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw
!
!
!
!
voice translation-rule 1
 rule 1 /^9/ //
!
voice translation-rule 2
 rule 1 /19729965165/ /102/
!
!
voice translation-profile inboundprofile
 translate called 2
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2821 sn xx
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex full
 speed 100
!
interface GigabitEthernet0/1
 ip address 71.170.37.123 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 h323-gateway voip bind srcaddr 71.170.37.123
!
interface Service-Engine1/0
 ip unnumbered GigabitEthernet0/0
 service-module ip address 10.1.1.2 255.255.255.0
 service-module ip default-gateway 10.1.1.1
!
ip default-gateway 71.170.37.1
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/GUI
!
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip nat inside source list 2 interface GigabitEthernet0/1 overload
ip nat inside source list 3 interface GigabitEthernet0/1 overload
ip nat inside source static tcp 10.1.1.22 25 71.170.37.123 25 extendable
ip nat inside source static tcp 10.1.1.22 443 71.170.37.123 443 extendable
ip nat inside source static tcp 10.1.1.20 1723 71.170.37.123 1723 extendable
ip route 0.0.0.0 0.0.0.0 71.170.37.1
ip route 10.1.1.2 255.255.255.255 Service-Engine1/0
!
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 2 permit 10.1.100.0 0.0.0.255
access-list 3 permit 10.1.200.0 0.0.0.255
!
!
!
!
!
tftp-server flash:/IP_Phones/7940_7960/Sccp/P0030801SR02.bin
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
!
mgcp profile default
!
!
dial-peer voice 2 voip
 destination-pattern 1[2-9].........
 translate-outgoing called 1
 session protocol sipv2
 session target dns:sip.flowroute.com
 voice-class codec 1
 dtmf-relay rtp-nte digit-drop
 dtmf-interworking standard
!
dial-peer voice 3 voip
 destination-pattern 2...
 session protocol sipv2
 session target ipv4:10.1.1.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 4 voip
 translation-profile incoming inboundprofile
 session protocol sipv2
 session target sip-server
 incoming called-number .%
!
!
sip-ua
 authentication username xx password 7 xx realm sip.flowroute.com
 calling-info pstn-to-sip from number set 19729965165
 no remote-party-id
 registrar dns:sip.flowroute.com expires 3600
!
!
!
telephony-service
 video
  maximum bit-rate 256
 max-ephones 58
 max-dn 192
 ip source-address 10.1.1.1 port 2000
 ip qos dscp af31 signal
 service phone videoCapability 1
 system message Legacy Vinyl Windows
 cnf-file perphone
 load 7960-7940 P0030801SR02
 time-zone 8
 voicemail 2000
 max-conferences 8 gain -6
 dn-webedit
 time-webedit
 transfer-system full-consult
 secondary-dialtone 9
 create cnf-files version-stamp 7960 Sep 03 2014 19:37:20
!
!
ephone-dn  1  dual-line
 number 110
 description Heath 110
 name Heath 
 call-forward busy 2000
 call-forward noan 2000 timeout 10
!
!
ephone-dn  2  dual-line
 number 102 
 description David 
 name David 
 call-forward busy 2000
 call-forward noan 2000 timeout 10
!
!
ephone-dn  98
 number 8001....
 mwi off
!
!
ephone-dn  99
 number 8000....
 mwi on
!
!
ephone  1
 device-security-mode none
 mac-address 9048.9A8C.25A5
 type CIPC
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 0011.920E.11B7
 type 7940
 button  1:1
!
!
!
ephone  3
 device-security-mode none
 mac-address 000E.D7D8.785C
 type 7940
 button  1:2
!
!
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
ntp master
ntp update-calendar
ntp server pool.ntp.org
ntp server 0.us.pool.ntp.org
ntp server 2.us.pool.ntp.org
end

router1#

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi, The calls is blocked by

Hi,

 

The calls is blocked by Toll Fraud App.

 

 >>>>CCAPI handed cid 50477 with tag 4 to app "_ManagedAppProcess_TOLLFRAUD_APP"

 

voice service voip
 ip address trusted list
  ipv4 214.115.69.0 255.255.255.0
  ipv4 70.167.153.130 255.255.255.255
  ipv4 24.240.233.212 255.255.255.255

 

you need to add the IP address of "sip.flowroute.com" from where the calls are coming in under IP Trust list as above.

 

Reference: http://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/112083-tollfraud-ios.html#t3

 

 

//Suresh Please rate all the useful posts.
2 REPLIES

Hi, The calls is blocked by

Hi,

 

The calls is blocked by Toll Fraud App.

 

 >>>>CCAPI handed cid 50477 with tag 4 to app "_ManagedAppProcess_TOLLFRAUD_APP"

 

voice service voip
 ip address trusted list
  ipv4 214.115.69.0 255.255.255.0
  ipv4 70.167.153.130 255.255.255.255
  ipv4 24.240.233.212 255.255.255.255

 

you need to add the IP address of "sip.flowroute.com" from where the calls are coming in under IP Trust list as above.

 

Reference: http://www.cisco.com/c/en/us/support/docs/voice/call-routing-dial-plans/112083-tollfraud-ios.html#t3

 

 

//Suresh Please rate all the useful posts.
New Member

That was it! thanks! I think

That was it! thanks! I think sip.flowroute.com added some new IPs since last time i messed with it. 

589
Views
0
Helpful
2
Replies