Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inbound SRST call backs

Let me see if I can explain what I am trying to do, with my SRST.  I have configured Device pools and Route Patterns that use the SRST router to call 911 from ip phones in the class rooms.  This is working Great, I have a hard line to the phone port on the SRST router setup so when a phone in the school dials 911 they all go through the hard line correctly sending 911 services to the correct location, no problem here.  The problem is when we have a 911 hang up, and 911 operator calls back they dial the hard line number that is attached to the router and they get no answer or busy and they send some one out all the time.  My question, is there a way to forward call backs from this line to a internal extension manned by a receptionist or a live body.  I am running Call Manager 7.1.  I hope this makes sense and any help will be great.

9 REPLIES
Hall of Fame Super Silver

Inbound SRST call backs

What is the "hard line" is this an FXO trunk line? What protocol are you using to control the GW, i.e. MGCP/H323/SIP?

Chris

New Member

Inbound SRST call backs

It is an FXS port, and I am using h323/

Hall of Fame Super Silver

Inbound SRST call backs

FXS line connected to telco for e911?  Is it FXS/DID with DID number riding on it?  Are is there specific number for each circuit and possibly a FXO circuit?

Chris

New Member

Inbound SRST call backs

Never mind I just looked at the back of the router,  It is a fxo port and I have a dedicated DID line coming into it, from the telco.

Hall of Fame Super Silver

Inbound SRST call backs

Then what you do is configure the port with plar config "connection plar opx XXXX" where XXXX is the destination you want the call go to.

HTH, please rate all useful posts!

Chris

New Member

Inbound SRST call backs

It is not working, here is my router config.  it is a 2800 router.  The 5493 is the extension I want it to ring at.

Current configuration : 2672 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RES.SRST

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$LCbf$DbPaVzKa6WqIwjCr9Wgmz1

!

aaa new-model

!

!

aaa authentication login default group radius local

aaa authentication enable default group radius enable

aaa authorization exec default group radius local

aaa accounting suppress null-username

aaa accounting exec default start-stop group radius

aaa accounting system default start-stop group radius

!

aaa session-id common

clock timezone CST -6

clock summer-time CDT recurring

ip cef

!

!

!

!

ip domain name hutto.txed.net

!

!

trunk group  POTS

max-calls any 2

hunt-scheme sequential

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username calence privilege 15 secret 5 $1$Vd3/$dJklNe9OFI3FgAKesnbXX0

username admin privilege 15 secret 5 $1$R/fk$tkqaLI6SHbc5bpeRxt0rg.

!

!

!

!

!

interface FastEthernet0/0

ip address 10.140.100.2 255.255.254.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.140.100.2

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/3/0

no ip address

shutdown

no fair-queue

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.140.100.1

!

!

ip http server

no ip http secure-server

!

!

!

radius-server host 10.64.86.5 auth-port 1645 acct-port 1646 key 7 12311003065B4D170E

radius-server host 10.64.84.99 auth-port 1645 acct-port 1646 key 7 12311003065B4D170E

!

control-plane

!

!

!

voice-port 0/1/0

trunk-group POTS 7

timing hookflash-out 500

connection plar opx 5493

description POTS line

!

voice-port 0/1/1

trunk-group POTS 5

timing hookflash-out 500

connection plar opx 5493

description POTS line

!

voice-port 0/2/0

!

voice-port 0/2/1

!

!

!

!

!

dial-peer voice 911 pots

trunkgroup POTS

description *** Outbound 911 ***

destination-pattern 911

forward-digits 3

!

dial-peer voice 9911 pots

trunkgroup POTS

description *** Outbound 911 ***

destination-pattern 9911

forward-digits 3

!

dial-peer voice 100 pots

trunkgroup POTS

description *** Outbound local ***

destination-pattern 9[2-9]......

forward-digits 7

!

dial-peer voice 50 voip

destination-pattern [1-8]...

session target ipv4:10.55.100.5

incoming called-number .T

!

dial-peer voice 51 voip

preference 2

destination-pattern [1-8]...

session target ipv4:10.200.100.5

incoming called-number .T

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.140.100.2 port 2000

max-ephones 25

max-dn 50

system message primary SRST - Fallback

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp clock-period 17178111

ntp server 10.64.84.1

end

Hall of Fame Super Silver

Inbound SRST call backs

So, what is extension 5493 defined as on CUCM?

Does the CSS applied to the H323 on CUCM have access to the parition assigned ot 5943? 

Chris

New Member

Inbound SRST call backs

Not sure what you ment by definded on CUCM.  Partitions? CSS?, How can I tell what CSS is applied to the H323 on CUCM.  I did not configure this router, it was done a while back.

Hall of Fame Super Silver

Inbound SRST call backs

Your GW configuration points to DN 5493, what is that DN in CUCM defined as?

When the call arrives to this GW, via voip dial-peer it redirects the call to CUCM, CUCM has the GW defined as H323 GW with name being the IP address of the GW, it has Calling Search Space applied to it. You need to ensure that the applied CSS lists partition that is assigned to the 5493 extension.

HTH,

Chris

382
Views
0
Helpful
9
Replies
CreatePlease login to create content