Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Incoming Call Dial-Peer

I can't seem to get my CME to route my incoming calls to my phones.  I would like to have 1001 and 1002 both ring when the telephone # is dialed.  Can you please help me figure out what is wrong?  I can call out just fine, just not able to receive any calls.  Cisco 2821 / C2800NM-ADVENTERPRISEK9-M Version 15.1(4)M8 / CME 8.0 / Phone = 7975

 

DID # = 7852465184 and 9137129524

 

 

Building configuration...


Current configuration : 8366 bytes
!
! Last configuration change at 23:48:10 CST Sun Jun 29 2014 by woodjl1650
! NVRAM config last updated at 23:48:11 CST Sun Jun 29 2014 by woodjl1650
! NVRAM config last updated at 23:48:11 CST Sun Jun 29 2014 by woodjl1650
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.151-4.M8.bin
boot system flash:c2800nm-ipvoice_ivs-mz.151-3.T2.bin
boot-end-marker
!
!
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
clock timezone CST -6 0
clock summer-time CST recurring
!
dot11 syslog
no ip source-route
!
!
no ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.20
ip dhcp excluded-address 192.168.1.200 192.168.1.252
!
ip dhcp pool HomeLAN
 network 192.168.1.0 255.255.255.0
 domain-name jjkkcc.org
 default-router 192.168.1.2
 dns-server 209.244.0.3 8.8.8.8 4.2.2.2
 option 150 ip 192.168.1.2
!
!
ip domain name jjkkcc.org
ip name-server 8.8.8.8
ip name-server 4.2.2.2
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
voice rtp send-recv
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 sip
  registrar server expires max 120 min 60
  localhost dns:sip.flowroute.com
  outbound-proxy dns:sip.flowroute.com
  early-offer forced
  midcall-signaling passthru
  sip-profiles 100
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
voice class sip-profiles 100
 response ANY sdp-header Audio-Attribute modify "sendonly" "sendrecv"
 request ANY sdp-header Audio-Attribute modify "sendonly" "sendrecv"
 response ANY sdp-header Audio-Attribute modify "sendonly" "sendrecv"
 request ANY sdp-header Audio-Attribute modify "sendonly" "sendrecv"
!
!
!
!
!
voice-card 0
 dspfarm
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2821 sn FTX1033A2QR
username woodjl1650 privilege 15 secret 5 $1$U/hT$kJDcp7OubFSJG6YaU1w82.
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.1.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
no ip forward-protocol nd
ip http server
no ip http secure-server
!
!
ip nat inside source list NAT interface GigabitEthernet0/0 overload
ip nat inside source static tcp 192.168.1.6 80 interface GigabitEthernet0/0 80
ip nat inside source static tcp 192.168.1.6 32400 interface GigabitEthernet0/0 32400
ip nat inside source static tcp 192.168.1.16 4040 interface GigabitEthernet0/0 4040
ip nat inside source static tcp 192.168.1.250 443 interface GigabitEthernet0/0 443
!
ip access-list standard NAT
 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
!
tftp-server flash:apps11.8-5-3TH1-6.sbn
tftp-server flash:cnu11.8-5-3TH1-6.sbn
tftp-server flash:cvm11sccp.8-5-3TH1-6.sbn
tftp-server flash:dsp11.8-5-3TH1-6.sbn
tftp-server flash:jar11sccp.8-5-3TH1-6.sbn
tftp-server flash:SCCP11.8-5-3S.loads
tftp-server flash:term06.default.loads
tftp-server flash:term11.default.loads
tftp-server flash:MISCH-1.3.3.SBN
tftp-server flash:CP7921G-1.3.3.LOADS
tftp-server flash:CP7925G-1.3.3.LOADS
tftp-server flash:term42.default.loads
tftp-server flash:term62.default.loads
tftp-server flash:SCCP42.8-5-3S.loads
tftp-server flash:term31.default.loads
tftp-server flash:term41.default.loads
tftp-server flash:term45.default.loads
tftp-server flash:term61.default.loads
tftp-server flash:term65.default.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:term75.default.loads
tftp-server flash:SCCP31.8-5-3S.loads
tftp-server flash:SCCP41.8-5-3S.loads
tftp-server flash:SCCP45.8-5-3S.loads
tftp-server flash:SCCP70.8-5-3S.loads
tftp-server flash:SCCP75.8-5-3S.loads
tftp-server flash:SCCP69xx.8-5-3-0.loads
tftp-server flash:apps37sccp.1-3-4-0.bin
tftp-server flash:apps31.8-5-3TH1-6.sbn
tftp-server flash:apps42.8-5-3TH1-6.sbn
tftp-server flash:apps45.8-5-3TH1-6.sbn
tftp-server flash:apps75.8-5-3TH1-6.sbn
tftp-server flash:apps41.8-5-3TH1-6.sbn
tftp-server flash:apps70.8-5-3TH1-6.sbn
tftp-server flash:APPSH-1.3.3.SBN
tftp-server flash:APPS-1.3.3.SBN
tftp-server flash:SYSH-1.3.3.SBN
tftp-server flash:cvm70sccp.8-5-3TH1-6.sbn
tftp-server flash:cvm41sccp.8-5-3TH1-6.sbn
tftp-server flash:cvm45sccp.8-5-3TH1-6.sbn
tftp-server flash:cvm75sccp.8-5-3TH1-6.sbn
tftp-server flash:cvm31sccp.8-5-3TH1-6.sbn
tftp-server flash:cvm42sccp.8-5-3TH1-6.sbn
tftp-server flash:SYS-1.3.3.SBN
tftp-server flash:WLANH-1.3.3.SBN
tftp-server flash:GUIH-1.3.3.SBN
tftp-server flash:jar75sccp.8-5-3TH1-6.sbn
tftp-server flash:jar45sccp.8-5-3TH1-6.sbn
tftp-server flash:GUI-1.3.3.SBN
tftp-server flash:jar70sccp.8-5-3TH1-6.sbn
tftp-server flash:jar42sccp.8-5-3TH1-6.sbn
tftp-server flash:jar41sccp.8-5-3TH1-6.sbn
tftp-server flash:jar31sccp.8-5-3TH1-6.sbn
tftp-server flash:WLAN-1.3.3.SBN
tftp-server flash:TNUXH-1.3.3.SBN
tftp-server flash:TNUX-1.3.3.SBN
tftp-server flash:dsp41.8-5-3TH1-6.sbn
tftp-server flash:dsp70.8-5-3TH1-6.sbn
tftp-server flash:cnu45.8-5-3TH1-6.sbn
tftp-server flash:cnu42.8-5-3TH1-6.sbn
tftp-server flash:cnu75.8-5-3TH1-6.sbn
tftp-server flash:cnu31.8-5-3TH1-6.sbn
tftp-server flash:cnu70.8-5-3TH1-6.sbn
tftp-server flash:cnu41.8-5-3TH1-6.sbn
tftp-server flash:dsp31.8-5-3TH1-6.sbn
tftp-server flash:dsp42.8-5-3TH1-6.sbn
tftp-server flash:dsp45.8-5-3TH1-6.sbn
tftp-server flash:dsp75.8-5-3TH1-6.sbn
!
!
!
control-plane
!
!
no ccm-manager fax protocol cisco
!
no mgcp timer receive-rtcp
!
mgcp profile default
!
!
dial-peer voice 100 voip
 description Incoming dialpeer and 1+10 digits
 destination-pattern ^1[2-9]..[2-9]......$
 session protocol sipv2
 session target ipv4:216.115.69.144
 incoming called-number .T
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
dial-peer voice 101 voip
 description 10-digit local Calls
 destination-pattern ^[2-9]..[2-9]......$
 session protocol sipv2
 session target ipv4:216.115.69.144
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
dial-peer voice 102 voip
 description International Calls
 destination-pattern ^011T
 session protocol sipv2
 session target ipv4:216.115.69.144
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
dial-peer voice 103 voip
 description N11 Calls
 destination-pattern ^[2-9]11$
 session protocol sipv2
 session target ipv4:216.115.69.144
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
dial-peer voice 300 voip
 description 913712XXXX calls to CME
 huntstop
 destination-pattern ^913712....$
 session protocol sipv2
 session target dns:sip.flowroute.com
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
dial-peer voice 301 voip
 description 785246XXXX calls to CME
 huntstop
 destination-pattern ^785246....$
 session protocol sipv2
 session target dns:sip.flowroute.com
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
!
sip-ua
 credentials xxxxxxxxxxxx
 authentication xxxxxxxxxxxxx
 no remote-party-id
 retry invite 2
 retry register 10
 timers connect 100
 registrar dns:216.115.69.144 expires 3600
 sip-server dns:sip.flowroute.com
 host-registrar
!
!
!
telephony-service
 max-ephones 25
 max-dn 25
 ip source-address 192.168.1.2 port 2000
 load 7975 flash:SCCP75.8-5-3S.loads
 max-conferences 8 gain -6
 web admin system name admin secret 5 $1$LKD7$gxjAOF/zTy/CHVSfR0/cr0
 dn-webedit
 time-webedit
 transfer-system full-consult
!
!
ephone-dn  1
 number 1001
 label Office
 name Office
!
!
ephone  1
 device-security-mode none
 description Home Office
 mac-address C062.6B62.143A
 type 7975
 button  1:1
!
!
!
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 transport input telnet
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 96.226.242.9
ntp server 216.229.0.179
end

 

Thank you in advance

Everyone's tags (3)
10 REPLIES
Cisco Employee

Hello!1. Are u sure you

Hello!

1. Are u sure you recieve incoming calls? Did u try to use 'debug voice dial-peer', 'debug voice ccapi inout', 'debug ccsip messages'?

2. As I understand, u need to configure hunt group for DNs '1001', '1002'. If yes, you should use:

voice hunt-group 1 parallel

pilot 1) u  can try to use DID;

        2) u can configure voice-translation rules to point to some hunt-numbers and then put these numbers.

list 1001, 1002

may be some additional commands will be needed...

 

Regards,

Kirill

New Member

Still nothing, added the hunt

Still nothing, added the hunt group but still no incoming calls.

SIP #1) 7852465184

SIP #2) 9137129524

I'm pretty sure it has something to do with my dial-peer and routing, but not sure.  I am rather new to VOIP so any config changes or suggestion on my current config would be greatly appreciated.

Attached is my current config via txt document

 

Thank you in advance.

 

Cisco Employee

Do u have any incoming calls

Hello!

Do u have any incoming calls to your CME? not to hunt-number...

Explain, how do u test this hunt-group? 

Do u need all calls going to these numbers to be forwarded to hunt-group?

Why do u need this dial-peers:

dial-peer voice 300 voip
 description 913712XXXX calls to CME
 huntstop
 destination-pattern ^913712....$
 session protocol sipv2
 session target dns:sip.flowroute.com
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
!
dial-peer voice 301 voip
 description 785246XXXX calls to CME
 huntstop
 destination-pattern ^785246....$
 session protocol sipv2
 session target dns:sip.flowroute.com
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte

Do u have additional box with CME installed?

 

Try next...

1) configure translation-profile:

voice translation-rule 999
 rule 1 /7852465184/ /5001/

voice translation-profile 999
 translate called 999 

 

2) add it to test dial-peer

dial-peer voice 999 voip
 description Incoming test
 session protocol sipv2
 session target ipv4:216.115.69.144 - correct IP-address forTelco
 incoming called-number 7852465184 - if Telco sends this number in DNIS
 translation-profile incoming 999
 voice-class codec 1
 voice-class sip early-offer forced
 dtmf-relay rtp-nte

And test existing hunt-group...

Please, post 'debug ccssip messages' shile testing.

 

Regards,

Kirill

New Member

I removed my CUCM and just

I removed my CUCM and just using the CME now.  I tried called my DID's through my cell phone and I get a call can not be completed or a busy tone.  Tried the debugging command, but nothing showed up when I dialed those numbers.  I would like to have the IP phones 1001-1003 ring when one of the DID is dialed.

Cisco Employee

Possibly, you don't recieve

Possibly, you don't recieve any calls from Telco...

How do u connect to ur router? using telnet, ssh? did u issue 'term mon' before debug?

Does router show nothing whilr debugging outgoing call?

 

regards,

Kirill

New Member

Attached is the debug

Attached is the debug

Cisco Employee

Has it ever worked?Because if

Has it ever worked?

Because if you don't see any SIP messages while calling in, I suppose there is problem with SIP-provider.

Regards,

Kirill

New Member

I haven't gotten it configure

I haven't gotten it configure propperly, so I haven't been able to get it work.  I finally got some messages to show up (see attached).

Also attached is my current config

Cisco Employee

Hello!Try to create dial-peer

Hello!

Try to create dial-peer common with dial-peer voice 1 voip.

You need to:

1) put voice class-codec with g711/g729;

2) make incoming-called number +17852465184 

 

Please, post debug ccsip all and debug voice ccapi inout;

Regards,

Kirill

New Member

Could my codec be the issues

Could my codec be the issues?

Attached is the "debug ccsip messages"

 

415
Views
0
Helpful
10
Replies
CreatePlease to create content