Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Incoming call fails on SRST mode

Hi there,

Need some eyes troubleshooting an issue here - all incoming calls fails while on SRST, it a new implementation. Can you browse through through my configs and advice as to where am i going wrong:

- Tested the translation rule with success

- Initial had the rule attached on the voice port - no luck, moved it to dial-peer 20 still no luck

- Added .... on my rule - still no luck:

voice translation-rule 1

rule 1 /^7...$/ /011874..../

NB: We use 10 digits internal and telco sends 4.

Building configuration...


Current configuration : 7482 bytes
!
! Last configuration change at 14:05:53 UTC Fri May 11 2012
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname xxxxxx
!
boot-start-marker
boot system flash c2800nm-spservicesk9-mz.150-1.M4.bin
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 10000000
no logging rate-limit
no logging console
!
no aaa new-model
clock timezone UTC 2
network-clock-participate wic 0
network-clock-participate wic 1
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-4ess
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
voice iec syslog
!
voice translation-rule 1
rule 1 /^7...$/ /011874&/
rule 2 /^7.../ /011874&/
!
!
voice translation-profile SRST_call_Handling
translate calling 1
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
crypto pki token default removal timeout 0

!
!
license udi pid CISCO2851 sn FHK1502F0P3
license accept end user agreement

!
!        
controller E1 0/0/0
pri-group timeslots 1-31 service mgcp
description ### Connection to PSTN ###
!
controller E1 0/1/0
pri-group timeslots 1-23 service mgcp
!
!
!
!
!
!
interface GigabitEthernet0/0
description Connection to LAN
ip address 10.106.143.20 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn sending-complete
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn sending-complete
no cdp enable
!
ip default-gateway 10.106.143.1
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip route 0.0.0.0 0.0.0.0 10.106.143.1
!
logging history notifications
logging trap notifications
logging facility local5
logging 10.110.14.1
access-list 22 permit 10.110.14.2
access-list 22 permit 10.110.14.3
access-list 22 permit 10.110.14.1
access-list 22 permit 10.110.14.4
!
snmp-server community murrobmon2006 RO 24
snmp-server community mrpass RO 22
snmp-server location 22 Skeen Blvd, Bedfordview, Johannesburg

!
!
control-plane
!
!
voice-port 0/0/0:15
translation-profile incoming SRST_call_Handling
echo-cancel coverage 64
!
voice-port 0/1/0:15
echo-cancel coverage 64
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.110.8.160
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 10.110.8.160 
ccm-manager config
!
mgcp
mgcp call-agent 10.110.8.161 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.110.8.161 identifier 1 version 7.0
sccp ccm 10.110.8.160 identifier 2 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 3 register CFBb414892428c0
associate profile 2 register MTPb414892428c0
associate profile 1 register TRNb414892428c0
keepalive retries 20
switchback method immediate
switchback interval 15
signaling dscp af31
!
dspfarm profile 1 transcode 
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 4
associate application SCCP
!
dspfarm profile 3 conference 
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 4
associate application SCCP
!
dspfarm profile 2 mtp 
codec g711ulaw
maximum sessions software 250
associate application SCCP
!
dial-peer voice 10 pots
preference 3
destination-pattern .T
port 0/0/0:15
forward-digits all
!
dial-peer voice 100 voip
destination-pattern .T
session target ipv4:10.110.8.160
voice-class codec 1
dtmf-relay h245-alphanumeric
!
dial-peer voice 200 voip
preference 1
destination-pattern .T
session target ipv4:10.110.8.161
voice-class codec 1
dtmf-relay h245-alphanumeric
!
dial-peer voice 20 pots
translation-profile incoming SRST_call_Handling
preference 1
service mgcpapp
destination-pattern .T
direct-inward-dial
port 0/0/0:15
forward-digits all
!
!
gateway
timer receive-rtp 1200
!
!
call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 10.106.143.20 port 2000
max-ephones 110
max-dn 200
!
end

DEBUG OUTPUT:

*May 11 11:17:50.487: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x1F2A
                Sending Complete
                Bearer Capability i = 0x9090A3
                                Standard = CCITT
                                Transfer Capability = 3.1kHz Audio
                                Transfer Mode = Circuit
                                Transfer Rate = 64 kbit/s
                Channel ID i = 0xA9838C
                                Exclusive, Channel 12
                Progress Ind i = 0x8283 - Origination address is non-ISDN 
                Called Party Number i = 0x81, '7333'
                                Plan:ISDN, Type:Unknown
010051: *May 11 11:17:50.491: ISDN Se0/0/0:15 Q931: Received SETUP  callref = 0x9F2A callID = 0x0029 switch = primary-net5 interface = User
010052: *May 11 11:17:50.499: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x9F2A
                Channel ID i = 0xA9838C
                                Exclusive, Channel 12
010053: *May 11 11:17:50.499: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x9F2A
010054: *May 11 11:17:50.527: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x1F2A
010055: *May 11 11:17:50.527: %ISDN-6-CONNECT: Interface Serial0/0/0:11 is now connected to N/A N/A
010056: *May 11 11:18:05.307: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x1F2A
                Cause i = 0x8A90 - Normal call clearing
                Progress Ind i = 0x8288 - In-band info or appropriate now available
010057: *May 11 11:18:05.311: %ISDN-6-DISCONNECT: Interface Serial0/0/0:11  disconnected from unknown , call lasted 14 seconds
010058: *May 11 11:18:05.311: ISDN Se0/0/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0x29
010059: *May 11 11:18:05.315: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x9F2A
010060: *May 11 11:18:05.327: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x1F2A
010061: *May 11 11:18:43.911: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x1F2B
                Sending Complete
                Bearer Capability i = 0x8090A3
                                Standard = CCITT
                                Transfer Capability = Speech 
                                Transfer Mode = Circuit
                                Transfer Rate = 64 kbit/s
                Channel ID i = 0xA98385
                                Exclusive, Channel 5
                Called Party Number i = 0x81, '7321'
                                Plan:ISDN, Type:Unknown
                High Layer Compat i = 0x9181
010062: *May 11 11:18:43.911: ISDN Se0/0/0:15 Q931: Received SETUP  callref = 0x9F2B callID = 0x002A switch = primary-net5 interface = User
010063: *May 11 11:18:43.923: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x9F2B
                Channel ID i = 0xA98385
                                Exclusive, Channel 5
010064: *May 11 11:18:43.923: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x9F2B
010065: *May 11 11:18:43.947: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x1F2B
010066: *May 11 11:18:43.947: %ISDN-6-CONNECT: Interface Serial0/0/0:4 is now connected to N/A N/A
010067: *May 11 11:18:54.999: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x1F2C
                Sending Complete
                Bearer Capability i = 0x8090A3
                                Standard = CCITT
                                Transfer Capability = Speech 
                                Transfer Mode = Circuit
                                Transfer Rate = 64 kbit/s
                Channel ID i = 0xA9839C
                                Exclusive, Channel 28
                Called Party Number i = 0x81, '7377'
                                Plan:ISDN, Type:Unknown
010068: *May 11 11:18:54.999: ISDN Se0/0/0:15 Q931: Received SETUP  callref = 0x9F2C callID = 0x002B switch = primary-net5 interface = User
010069: *May 11 11:18:55.011: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x9F2C
                Channel ID i = 0xA9839C
                                Exclusive, Channel 28
010070: *May 11 11:18:55.011: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8  callref = 0x9F2C
010071: *May 11 11:18:55.039: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8  callref = 0x1F2C
010072: *May 11 11:18:55.039: %ISDN-6-CONNECT: Interface Serial0/0/0:27 is now connected to N/A N/A
010073: *May 11 11:18:57.219: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0x1F2B
                Cause i = 0x8090 - Normal call clearing
                Progress Ind i = 0x8288 - In-band info or appropriate now available
010074: *May 11 11:18:57.219: %ISDN-6-DISCONNECT: Interface Serial0/0/0:4  disconnected from unknown , call lasted 13 seconds
010075: *May 11 11:18:57.219: ISDN Se0/0/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0x2A
010076: *May 11 11:18:57.227: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8  callref = 0x9F2B
010077: *May 11 11:18:57.239: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x1F2B

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Incoming call fails on SRST mode

have you tested your translation rule?

try entering the following;

test voice translation-rule 1 7333

does the output match the DN you are trying to call?

Please rate if helpful

10 REPLIES
Bronze

Incoming call fails on SRST mode

have you tested your translation rule?

try entering the following;

test voice translation-rule 1 7333

does the output match the DN you are trying to call?

Please rate if helpful

Incoming call fails on SRST mode

Sorry, hit correct answer by mistake.

I did test the translation rule and yes - it matches the correct DN.

Green

Incoming call fails on SRST mode

Hi,

Can you try changing the SRST voice profile

!

voice translation-profile SRST_call_Handling

no translate calling 1

!

!

voice translation-profile SRST_call_Handling

translate called 1

!

The 7xxx is a CALLED number

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Green

Incoming call fails on SRST mode

Hi,

Have you tried my suggested change

!

voice translation-profile SRST_call_Handling

no translate calling 1

!

translate called 1

!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

Incoming call fails on SRST mode

Thanks Alex,

I have updated that and will be testing if it works - will keep u posted. Should it not work - what else could be the cause?

Green

Incoming call fails on SRST mode

Hi,

Thanks for the update.

If this fix does not work.

Can you please post the "debug isdn q931" of a failed call

Good luck with the testing.

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

Re: Incoming call fails on SRST mode

The testing didn't go well - unfortunately i couldn't get traces as i was doing this remotely (lost connectivity to the GW).

While waiting for another day for testing, what could lead to SRST fails with a engage tone? Is there a document with possible symptomes?

Super Bronze

Re: Incoming call fails on SRST mode

Hi

Typically it's a problem with your translations. The best way to test remotely is to (carefully) apply an access list that blocks all traffic from the voice VLAN at the remote site and from the router's IPs to the CUCM servers. That way it goes into SRST, you don't interrupt the data traffic, and you can test and properly remotely debug the calls as you test them.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Incoming call fails on SRST mode

Still, it fails. it give a continous tone then engagement tone.

Green

Incoming call fails on SRST mode

Hi,

Can you add a DP to match incoming calls

Something like this

!

dial-peer voice 1 pots

description *** FOR INCOMING CALL MATCHING ***

incoming called-number .

direct-inward-dial

port 0/0/0:15

!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
1217
Views
0
Helpful
10
Replies
CreatePlease to create content