Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Incoming call to ext# from FXO port

We currently have department that has multible FXO ports sent to a Hunt Pilot, and it is working fine.

I would like to change it to it being directed to a single extension, then the single extension being

routed to the Hunt Pilot. Then final destination is unimportant to this post. Just thought it would

cut down on the confusion about what I am asking. I do not wish to make any changes to the outgoing

calls for this extension or department.

Here is the original configuration for one of the ports in question.

voice-port 0/1/3

connection plar 7805

description Maintenance 3

caller-id enable

(7805 is the Hunt Pilot that calls a list of phones in a Line Group, and it is working).

I made the simple change below, expecting it to work, but the FXO port answers, but never rings the phone.

(180400 is the extension number I wish the call to be rounted to).

voice-port 0/1/3

connection plar 180400

description Maintenance 3

caller-id enable

What am I missing?

It is a 2921 Voice Router, with OS version 15-1-3

Remember it is working when sent the the Hunt Pilot, and outgoing calls are not

routed to this FXO port, and are working the way we want them to.

Thanks,

Lynn Hedspeth

8 REPLIES
Hall of Fame Super Silver

Incoming call to ext# from FXO port

You need to make sure that you have a dial-peer matching the 180400 destination.

HTH,

Chris

New Member

Re: Incoming call to ext# from FXO port

I tried the following with the same results.

dial-peer voice 5 pots

destination-pattern 180400

port 0/1/3

I am a little confused, about the need for a destination-pattern if

I am not calling outward. But I tried the above.

Lynn Hedspeth

Hall of Fame Super Silver

Re: Incoming call to ext# from FXO port

You are attempting to loop the call back onto the same port, your dial-peer needs to point to most likely your CUCM (you did not explain your topology). Please post your full config.

Chris

New Member

Re: Incoming call to ext# from FXO port

voice-port 0/1/3 is the one I am testing, but once it is working I will need to make the same changes to 2 other ports.

voice-port 0/1/0 and 0/1/3 will eventually need to have the same destination.

I removed the dial-peer entry I made earlier after it didn't work, so you won't find it in the following config text.

What I am trying to accomplish is. Originally those 3 ports were routed to a Hunt Pilot (7805) which rings all the phones in that department. I want to change it so it only rings the secretaries phone/extension. It is an IP phone extension 180400. The original configuration was working, we just desided to change how or who it rings to. So it was already working, I just need to change the destination. I have only changed one of the ports while testing.

Here is the complete config:

Thanks

Lynn Hedspeth

CCS-CO-VoiceGateway-01#show run

Building configuration...

Current configuration : 8644 bytes

!

version 15.1

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service linenumber

service sequence-numbers

!

hostname CCS-CO-VoiceGateway-01

!

boot-start-marker

boot-end-marker

!

!

card type t1 0 0

no logging console

enable secret 5 $1$oRG0$R6DVgjti2uVcdMLsAZqyS.

!

aaa new-model        !

!

aaa authentication login default local line

aaa authorization console

aaa authorization exec default local none

!

!

!

!

!

aaa session-id common

clock timezone EST -5 0

clock summer-time DST recurring

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

network-clock-select 2 T1 0/0/1

!

no ipv6 cef

no ip source-route

ip cef

!

!

!

!

ip domain name catawba.nc.us

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

trunk group FXO

!

crypto pki token default removal timeout 0

!

!

voice-card 0

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

h323

  h225 display-ie ccm-compatible

modem passthrough nse codec g711ulaw

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g729br8

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!

!

application

global

  service alternate Default

!

!

license udi pid CISCO2921/K9 sn FTX1503A0D3

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

archive

log config

  hidekeys

username kngadmin privilege 15 secret 5 $1$DQsH$dsMc1EOCyZ8nvtYjlp03m/

username ccsadmin privilege 15 secret 5 $1$mpW.$XtSDzGCWLAET3UulnolgY/

!

redundancy

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24

!

controller T1 0/0/1

cablelength long 0db

pri-group timeslots 1-24

!

!

!

!

!

interface GigabitEthernet0/0

description Voice LAN

ip address 172.25.180.2 255.255.255.0

ip virtual-reassembly in

duplex auto

speed auto

no snmp trap link-status

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.25.180.2

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn map address 011* plan unknown type unknown

isdn supp-service name calling

no cdp enable

!

interface Serial0/0/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn map address 011* plan unknown type unknown

isdn supp-service name calling

no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 172.25.180.1

!

!

!

!

!

control-plane

!

!

voice-port 0/0/0:23

bearer-cap Speech

!

voice-port 0/1/0

connection plar 7805

description Maintenance 1

caller-id enable

!

voice-port 0/1/1

connection plar 7801

description Transportation 1

caller-id enable

!

voice-port 0/1/2

connection plar 7805

description Maintenance 2

caller-id enable

!

voice-port 0/1/3

connection plar 180404

description Maintenance 3

caller-id enable

!

voice-port 0/0/1:23

bearer-cap Speech

!

voice-port 0/2/0

connection plar 7801

description Transportation 2

caller-id enable

!

voice-port 0/2/1

!

!

mgcp fax t38 ecm

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 172.25.180.11 identifier 2 priority 2 version 7.0

sccp ccm 172.25.180.10 identifier 1 priority 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register CO_Xcoder

!

dspfarm profile 1 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 6

associate application SCCP

!

dial-peer voice 1 voip

preference 1

destination-pattern [1-8]...

session target ipv4:172.25.180.10

incoming called-number ..........

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

dial-peer voice 101 pots

preference 1

destination-pattern 9[2-9].........

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 10

!

dial-peer voice 102 pots

preference 1

destination-pattern 91[2-9].........

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 11

!

dial-peer voice 103 pots

preference 1

destination-pattern 9011.T

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

prefix 011

!

dial-peer voice 104 pots

preference 1

destination-pattern 9[4-9]11

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 3

!

dial-peer voice 105 pots

preference 1

destination-pattern 911

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 3

!

dial-peer voice 2 voip

preference 1

destination-pattern [0-8]...

session target ipv4:172.25.180.10

incoming called-number ..........

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

dial-peer voice 201 pots

preference 2

destination-pattern 9[2-9].........

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 10

!

dial-peer voice 202 pots

preference 2

destination-pattern 91[2-9].........

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 11

!

dial-peer voice 203 pots

preference 2

destination-pattern 9011.T

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

prefix 011

!

dial-peer voice 204 pots

preference 2

destination-pattern 9[4-9]11

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 3

!

dial-peer voice 205 pots

preference 2

destination-pattern 911

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 3

!

dial-peer voice 801 pots

preference 1

destination-pattern 9828.......

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 10

!

dial-peer voice 802 pots

preference 2

destination-pattern 9828.......

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 10

!

dial-peer voice 803 pots

preference 1

destination-pattern 9704.......

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 10

!

dial-peer voice 804 pots

preference 2

destination-pattern 9704.......

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 10

!

dial-peer voice 701 pots

preference 3

destination-pattern 9[2-9]T

incoming called-number ..........

direct-inward-dial

port 0/0/1:23

forward-digits 7

!

dial-peer voice 702 pots

preference 4

destination-pattern 9[2-9]T

incoming called-number ..........

direct-inward-dial

port 0/0/0:23

forward-digits 7

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 4 gain -6

transfer-system full-consult

timeouts interdigit 4

ip source-address 172.25.180.2 port 2000

max-ephones 110

max-dn 150

system message primary CM Fallback Mode

keepalive 15

voicemail 8000

alias 1 .... to 180200

alias 2 7045 to 180413

!

!

banner login ^C

     ******************************************************************

     *                                                                *

     *                     AUTHORIZED ACCESS ONLY                     *

     *                                                                *

     *    This system and all of its components are restricted to     *

     *   authorized users for legitimate business purposes and are    *

     *   subject to audit. Persons who violate this policy will be    *

     *  subject to the disciplinary process. The actual or attempted  *

     *  unauthorized access, use modification or copying of computer  *

     *       systems is a violation of Federal and State laws.        *

     *                                                                *

     ******************************************************************

^C

!

line con 0

line aux 0

line vty 0 4

exec-timeout 15 0

transport input telnet ssh

transport output all

line vty 5 15

exec-timeout 15 0

transport input telnet ssh

transport output all

!

scheduler allocate 20000 1000

ntp source GigabitEthernet0/0

ntp server 10.100.0.2 prefer

end

CCS-CO-VoiceGateway-01#               

CCS-CO-VoiceGateway-01#exit

Hall of Fame Super Silver

Incoming call to ext# from FXO port

Well, you have some overlapping dial-peers, dial-peer 1 and 2 that would match the original number 7805, if you want 180400 to go to the same destination you need to create duplicate of one of these dial-peers (whichever one you actually want to use) and set the destination-pattern to something like "destination-pattern 180400" or "180...", etc.

HTH,

Chris

New Member

Incoming call to ext# from FXO port

I greatly appreciate your help, and advise.

I copied dial-peer 1 as suggested, edited the dial-peer name, and the destination-pattern to

the commands below.

dial-peer voice 3 voip

preference 1

destination-pattern 180400

session target ipv4:172.25.180.10

incoming called-number ..........

voice-class codec 1

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

I am still having the same problem. Rings 2 times, FXO port picks up, and

then nothing else happens. I can change the

voice-port 0/1/3

connection plar 7805    (back to 7805 Hunt Pilot from 180400 extension and the call will go thru to the line group ok).

So I know the incoming line and port are working.

By the way the complete config I sent you had 180404 instead. Because I was using a spare extension in my office to test with. I have matched the same extension numbers in both the "voice-port" and "dial-peer" locations.

Thanks,

Lynn Hedspeth

Hall of Fame Super Silver

Incoming call to ext# from FXO port

Where should the call got to? CUCM? If so, what it it's IP address?

You say the FXO rings, is the call actually arriving on this port?

Please post "debug voice dialpeer" and "debug vpm signal"

HTH,

Chris

New Member

Re: Incoming call to ext# from FXO port

I had it working by a workaround I thought of this morning. I changed the number that is sent to a 4 digit random number that is passed by the original "dial-peer voice 1 voip". Then added a translation pattern in the CUCM to send the new 4 digit "7099" to the final distination of 180400. It works, but I would still like to know why it won't pass 180400 directly from the router.

We are sending this to the CUCM, and the ip address is 172.25.180.10 which is correct in the dial peer you had me create.

As far as I can tell the call is being answered by the FXO port.

The "debug voice dialpeer", and "debug vpm signal" outputs are below. 1 after the other.

Thanks,

Lynn Hedspeth

DEBUG VOICE DIALPEER LOG

Log Buffer (8192 bytes):

000431: *Jul  4 15:30:27.192 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000432: *Jul  4 15:30:27.192 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000433: *Jul  4 15:30:27.192 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000434: *Jul  4 15:30:27.192 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
000435: *Jul  4 15:30:27.192 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000436: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000437: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000438: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000439: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
000440: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=1
     3: Dial-peer Tag=2
000441: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000442: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000443: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000444: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
000445: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000446: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=180400, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000447: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000448: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000449: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
000450: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000451: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=180400, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
000452: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=3
000453: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000454: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Calling Number=180400, Called Number=, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
000455: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=3
000456: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000457: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000458: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000459: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000460: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
000461: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000462: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000463: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000464: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000465: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=1, saf_dndb_lookup=1, dp_result=0
000466: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000467: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=, Peer Info Type=DIALPEER_INFO_SPEECH
000468: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
000469: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
000470: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=NO_MATCH(-1)
000471: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000472: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000473: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000474: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000475: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000476: *Jul  4 15:30:36.544 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=, Peer Info Type=DIALPEER_INFO_SPEECH
000477: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
000478: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
000479: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=NO_MATCH(-1)
000480: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000481: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000482: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000483: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000484: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
CCS-CO-VoiceGateway-01#no debug voice dialpeer
voip dialpeer default debugging is off

******************************************************************************************

DEBUG VPM SIGNAL LOG


Log Buffer (8192 bytes):
DP_MATCH_ORIGINATE; Incoming Dial-peer=3
000456: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000457: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000458: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000459: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000460: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
000461: *Jul  4 15:30:27.196 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000462: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000463: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000464: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000465: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchSafModulePlugin:
   dialstring=180400, saf_enabled=1, saf_dndb_lookup=1, dp_result=0
000466: *Jul  4 15:30:27.196 DST: //-1/03B22F018106/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000467: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=, Peer Info Type=DIALPEER_INFO_SPEECH
000468: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
000469: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
000470: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=NO_MATCH(-1)
000471: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000472: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000473: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000474: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000475: *Jul  4 15:30:27.204 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000476: *Jul  4 15:30:36.544 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=, Peer Info Type=DIALPEER_INFO_SPEECH
000477: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
000478: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
000479: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=NO_MATCH(-1)
000480: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=180400, Peer Info Type=DIALPEER_INFO_SPEECH
000481: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=180400
000482: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
000483: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
   dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
000484: *Jul  4 15:30:36.548 DST: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=3
     2: Dial-peer Tag=2
     3: Dial-peer Tag=1
000485: *Jul  4 15:34:48.763 DST: %SYS-5-CONFIG_I: Configured from console by ccsadministrator on vty0 (10.100.254.13)
000486: *Jul  4 15:38:09.606 DST: %SYS-5-CONFIG_I: Configured from console by ccsadministrator on vty0 (10.100.254.13)
000487: *Jul  4 15:39:44.262 DST: htsp_process_event: [0/1/3, FXOLS_ONHOOK, E_DSP_SIG_0000]fxols_onhook_ringing
000488: *Jul  4 15:39:44.262 DST: htsp_timer - 125 msec
000489: *Jul  4 15:39:44.390 DST: htsp_process_event: [0/1/3, FXOLS_WAIT_RING_MIN, E_HTSP_EVENT_TIMER]fxols_wait_ring_min_timer
000490: *Jul  4 15:39:44.390 DST: htsp_timer - 10000 msec
000491: *Jul  4 15:39:44.390 DST: htsp_timer3 - 5600 msec
000492: *Jul  4 15:39:44.390 DST: [0/1/3] htsp_start_caller_id_rx:BELLCORE
000493: *Jul  4 15:39:44.390 DST: htsp_start_caller_id_rx create dsp_stream_manager
000494: *Jul  4 15:39:44.390 DST: [0/1/3] htsp_dsm_create_success  returns 1
000495: *Jul  4 15:39:46.070 DST: htsp_process_event: [0/1/3, FXOLS_RINGING, E_DSP_SIG_0100]
000496: *Jul  4 15:39:46.070 DST: fxols_ringing_not
000497: *Jul  4 15:39:46.070 DST: htsp_timer_stop
000498: *Jul  4 15:39:46.070 DST: htsp_timer - 10000 msec
000499: *Jul  4 15:39:49.990 DST: htsp_process_event: [0/1/3, FXOLS_RINGING, E_HTSP_EVENT_TIMER3]fxols_snoop_clid_stop
000500: *Jul  4 15:39:49.990 DST: htsp_timer_stop3
000501: *Jul  4 15:39:50.002 DST: htsp_process_event: [0/1/3, FXOLS_RINGING, E_DSP_SIG_0000]
000502: *Jul  4 15:39:52.130 DST: htsp_process_event: [0/1/3, FXOLS_RINGING, E_DSP_SIG_0100]
000503: *Jul  4 15:39:52.130 DST: fxols_ringing_not
000504: *Jul  4 15:39:52.130 DST: htsp_timer_stop
000505: *Jul  4 15:39:52.130 DST: htsp_timer_stop3
000506: *Jul  4 15:39:52.130 DST: [0/1/3] htsp_stop_caller_id_rx. message length 0htsp_setup_ind
000507: *Jul  4 15:39:52.130 DST: [0/1/3] get_fxo_caller_id:Caller ID receive failed.  parseCallerIDString:no data.
000508: *Jul  4 15:39:52.130 DST: [0/1/3] get_local_station_id calling num= calling name= calling time=07/04 15:39  orig called=
000509: *Jul  4 15:39:52.130 DST: [0/1/3] htsp_dsm_close_done
000510: *Jul  4 15:39:52.130 DST: htsp_process_event: [0/1/3, FXOLS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]
000511: *Jul  4 15:39:52.130 DST: fxols_wait_setup_ack:
000512: *Jul  4 15:39:52.130 DST: [0/1/3] set signal state = 0xC timestamp = 0fxols_check_auto_call
000513: *Jul  4 15:39:52.134 DST: htsp_process_event: [0/1/3, FXOLS_PROCEEDING, E_HTSP_PROCEEDING]fxols_offhook_proc
000514: *Jul  4 15:39:52.134 DST: htsp_timer - 120000 msec
000515: *Jul  4 15:39:52.142 DST: htsp_call_bridged invokedhtsp_progress_notify
000516: *Jul  4 15:39:52.146 DST: htsp_process_event: [0/1/3, FXOLS_PROCEEDING, E_HTSP_VOICE_CUT_THROUGH]fxols_proc_voice
000517: *Jul  4 15:40:01.470 DST: htsp_call_bridged invokedhtsp_progress_notify
000518: *Jul  4 15:40:01.478 DST: htsp_process_event: [0/1/3, FXOLS_PROCEEDING, E_HTSP_VOICE_CUT_THROUGH]fxols_proc_voice
000519: *Jul  4 15:40:09.590 DST: htsp_process_event: [0/1/3, FXOLS_PROCEEDING, E_DSP_SIG_1100]fxols_offhook_disc
000520: *Jul  4 15:40:09.590 DST: htsp_timer2 - 350 msec
000521: *Jul  4 15:40:09.942 DST: htsp_process_event: [0/1/3, FXOLS_PROCEEDING, E_HTSP_EVENT_TIMER2]fxols_disc_confirm
000522: *Jul  4 15:40:09.942 DST: htsp_timer_stop
000523: *Jul  4 15:40:09.942 DST: htsp_timer_stop2
000524: *Jul  4 15:40:09.942 DST: htsp_timer_stop3
000525: *Jul  4 15:40:09.958 DST: htsp_process_event: [0/1/3, FXOLS_PROCEEDING, E_HTSP_RELEASE_REQ]fxols_offhook_release
000526: *Jul  4 15:40:09.958 DST: htsp_timer_stop
000527: *Jul  4 15:40:09.958 DST: htsp_timer_stop2
000528: *Jul  4 15:40:09.958 DST: htsp_timer_stop3
000529: *Jul  4 15:40:09.958 DST: [0/1/3] set signal state = 0x4 timestamp = 0
000530: *Jul  4 15:40:09.958 DST: htsp_timer - 2000 msec
000531: *Jul  4 15:40:11.958 DST: htsp_process_event: [0/1/3, FXOLS_GUARD_OUT, E_HTSP_EVENT_TIMER]fxols_guard_out_timeout
000532: *Jul  4 15:40:11.958 DST: htsp_process_event: [0/1/3, FXOLS_ONHOOK, E_DSP_SIG_0100]
CCS-CO-VoiceGateway-01#no debug vpm signal
Voice Port Module signaling debugging is disabled
CCS-CO-VoiceGateway-01#

378
Views
0
Helpful
8
Replies
CreatePlease login to create content