Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Incoming calls from SIP Trunk fails to CME

Hi Folks,

I have a SIP Trunk, Cisco 877 and an old 2611XM for VoIP running CME 4.1.  The routers are set up like Fibre->877->2611XM.  I've finally got some things working on my setup, I can make internal, POTS and outgoing SIP calls.

I've got 10 numbers allocated to the SIP trunk and 8 lines.  Each external number should be a DDI for an internal extension, the last 4 digits of the external number is the internal extension..  Outgoing calls all come from a single number (I've got that working).

My problem is that I can't get incoming SIP calls working at all. 've been trying for the last 8 hours with no success.  At the moment, I'm not sure if its a NAT problem on my 877, or a dial-peer problem on the 2611.  I'd really like some help

I've got the following NAT on my 877:

ip nat service sip tcp port 5060

ip nat pool SIPPORTFWD 192.168.1.254 192.168.1.254 netmask 255.255.255.0 type rotary

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static udp 192.168.1.254 5060 interface Dialer1 5060

ip nat inside source static tcp 192.168.1.254 5060 interface Dialer1 5060

ip nat inside destination list 100 pool SIPPORTFWD

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.2.0 255.255.255.0 192.168.1.254

!

access-list 1 permit 192.168.0.0 0.0.255.255

access-list 100 permit udp any any range 4000 6000

These are the parts of the 2611XM config that I think are needed:

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

  registrar server

   outbound-proxy dns:voip.zen.co.uk

voice translation-rule 1

rule 1 /^9\(.*\)/ /\1/

!        

voice translation-rule 2

rule 1 /.*/ /012xxxx8882/

!        

!        

voice translation-profile SIP

translate calling 2

translate called 1

dial-peer voice 200 voip

description SIP Outgoing Dial Peer

translation-profile outgoing SIP

destination-pattern 9T

voice-class sip outbound-proxy  dns:voip.zen.co.uk

session protocol sipv2

session target dns:voip.zen.co.uk

session transport udp

dtmf-relay rtp-nte

codec g711ulaw

no vad  

dial-peer voice 150 voip

description SIP Incoming Dial Peer

destination-pattern 0125370

voice-class sip outbound-proxy  dns:voip.zen.co.uk

session protocol sipv2

session target dns:voip.zen.co.uk

session transport udp

incoming called-number 012xxx0....

dtmf-relay rtp-nte

codec g711ulaw

no vad  

!        

!        

sip-ua   

authentication username 012xxxxx82 password 7 11101A56411B0D1F0F0939

registrar dns:voip.zen.co.uk expires 3600

sip-server dns:voip.zen.co.uk

  host-registrar

permit hostname dns:voip.zen.co.uk

permit hostname dns:asterisk01.voip.zen.co.uk

permit hostname dns:asterisk02.voip.zen.co.uk

ephone-dn  1  dual-line

number xx82 secondary 012xxxx82 no-reg both

label Main Desk

name 012xxxxx88

!        

!        

ephone-dn  2  dual-line

number xx83 secondary 012xxxxx83 no-reg both

label Spare Desk

name 012xxxxx88

I am able to dial out and audio works both ways, but incoming calls don't work.  I get the following using debug ccsip all

Oct 25 16:15:10.950: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads: Msg enqueued for SPI with IP addr: 212.23.7.228:5060

Oct 25 16:15:10.954: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event: ccsip_spi_get_msg_type returned: 2 for event 1

Oct 25 16:15:10.954: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewConnMsg: context=0x00000000

Oct 25 16:15:10.954: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:012xxxxxx82@212.23.7.228 SIP/2.0

Via: SIP/2.0/UDP 212.23.7.228:5060;branch=z9hG4bK610cd600-Proxy

Via: SIP/2.0/UDP 212.23.7.226:5060;branch=z9hG4bK610cd600;rport

Max-Forwards: 70

From: "+447xxxxx1188" <sip:+447xxxxx1188@212.23.7.226>;tag=as2e3b9b65

To: <sip:012xxxxx882@212.23.7.228>

Contact: <sip:+447xxxxx1188@212.23.7.228:5060>

Call-ID: 1278ad607dc403861d86bb831e4107d1@212.23.7.226:5060

CSeq: 102 INVITE

User-Agent: Zen Internet Telephony Service

Date: Fri, 25 Oct 2013 16:15:10 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

Supported: replaces

Content-Type: application/sdp

Content-Length: 297

v=0

o=root 900441406 900441406 IN IP4 212.23.7.226

s=Asterisk PBX 1.8.13.1~dfsg-1~bpo60+1

c=IN IP4 212.23.7.226

t=0 0

m=audio 29672 RTP/AVP 0 8 3 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:3 GSM/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=sendrecv

Oct 25 16:15:10.958: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_new_msg_preprocessor: Checking Invite Dialog

Oct 25 16:15:10.962: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIAddContextToTable: Added context(0x864D8764) with key=[13172] to table

Oct 25 16:15:10.962: //-1/xxxxxxxxxxxx/SIP/Transport/sipSPIUpdateResponseInfo: Dialog Transaction Address 212.23.7.228,Port 5060, Transport 1, SentBy Port 5060

Oct 25 16:15:10.962: //-1/74F528F38465/SIP/State/sipSPIChangeState: 0x864D8764 : State change from (STATE_NONE, SUBSTATE_NONE)  to (STATE_IDLE, SUBSTATE_NONE)

Oct 25 16:15:10.966: //-1/xxxxxxxxxxxx/SIP/Transport/sipSPIUpdateResponseInfo: Dialog Transaction Address 212.23.7.228,Port 5060, Transport 1, SentBy Port 5060

Oct 25 16:15:10.966: //-1/xxxxxxxxxxxx/SIP/Info/sipSPISetDateHeader: Converting TimeZone BST to SIP default timezone = GMT

Oct 25 16:15:10.970: //-1/xxxxxxxxxxxx/SIP/Transport/sipSPIUpdateResponseInfo: Dialog Transaction Address 212.23.7.228,Port 5060, Transport 1, SentBy Port 5060

Oct 25 16:15:10.974: //-1/xxxxxxxxxxxx/SIP/Error/sipSPI_validate_own_ip_addr: ReqLine IP addr does not match with host IP addr

Oct 25 16:15:10.974: //-1/74F528F38465/SIP/Error/sact_idle_new_message_invite: Invalid URL in incoming INVITE

Oct 25 16:15:10.974: //-1/74F528F38465/SIP/Info/ccsip_set_cc_cause_for_spi_err: Categorized cause:100, category:100

Oct 25 16:15:10.978: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_set_release_source_for_peer: ownCallId[-1], src[6]

Oct 25 16:15:10.978: //-1/74F528F38465/SIP/Info/sipSPIUaddCcbToUASReqTable: ****Adding to UAS Request table.

Oct 25 16:15:10.978: //-1/74F528F38465/SIP/Info/sipSPIUaddCcbToTable: Added to table. ccb=0x864D8764 key=1278ad607dc403861d86bb831e4107d1@212.23.7.226:506001253708882

Oct 25 16:15:10.978: //-1/74F528F38465/SIP/Info/sipSPIUaddCcbToUASRespTable: ****Adding to UAS Response table.

Oct 25 16:15:10.978: //-1/74F528F38465/SIP/Info/sipSPIUaddCcbToTable: Added to table. ccb=0x864D8764 key=1278ad607dc403861d86bb831e4107d1@212.23.7.226:50606C0F8E6F-F0B

Oct 25 16:15:10.987: //-1/74F528F38465/SIP/Transport/sipSPITransportSendMessage: msg=0x88B322CC, addr=212.23.7.228, port=5060, sentBy_port=5060, is_req=0, transport=1, switch=0, callBack=0x8137A1B8

Oct 25 16:15:10.987: //-1/74F528F38465/SIP/Transport/sipSPITransportSendMessage: Proceedable for sending msg immediately

Oct 25 16:15:10.987: //-1/74F528F38465/SIP/Transport/sipTransportLogicSendMsg: switch transport is 0

Oct 25 16:15:10.987: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportPostSendMessage: Posting send for msg=0x88B322CC, addr=212.23.7.228, port=5060, connId=0 for UDP

Oct 25 16:15:10.987: //-1/74F528F38465/SIP/Info/sentErrResDisconnecting: Sent an 3456XX Error Response

Oct 25 16:15:10.991: //-1/74F528F38465/SIP/State/sipSPIChangeState: 0x864D8764 : State change from (STATE_IDLE, SUBSTATE_NONE)  to (STATE_DISCONNECTING, SUBSTATE_NONE)

Oct 25 16:15:10.995: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 400 Bad Request - 'Invalid Host'

Via: SIP/2.0/UDP 212.23.7.228:5060;branch=z9hG4bK610cd600-Proxy,SIP/2.0/UDP 212.23.7.226:5060;branch=z9hG4bK610cd600;rport

From: "+447xxxxx1188" <sip:+447xxxxx1188@212.23.7.226>;tag=as2e3b9b65

To: <sip:012xxxxx882@212.23.7.228>;tag=6C0F8E6F-F0B

Date: Fri, 25 Oct 2013 16:15:10 GMT

Call-ID: 1278ad607dc403861d86bb831e4107d1@212.23.7.226:5060

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=100

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

Oct 25 16:15:11.011: //-1/xxxxxxxxxxxx/SIP/Info/HandleUdpSocketReads: Msg enqueued for SPI with IP addr: 212.23.7.228:5060

Oct 25 16:15:11.011: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_process_sipspi_queue_event: ccsip_spi_get_msg_type returned: 2 for event 1

Oct 25 16:15:11.011: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportProcessNWNewConnMsg: context=0x00000000

Oct 25 16:15:11.015: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:01253708882@212.23.7.228 SIP/2.0

Via: SIP/2.0/UDP 212.23.7.228:5060;branch=z9hG4bK610cd600-Proxy

Via: SIP/2.0/UDP 212.23.7.226:5060;branch=z9hG4bK610cd600;rport

Max-Forwards: 70

From: "+447xxxxxxx88" <sip:+447xxxxxxx88@212.23.7.226>;tag=as2e3b9b65

To: <sip:012xxxxxxx2@212.23.7.228>;tag=6C0F8E6F-F0B

Contact: <sip:+447xxxxx1188@212.23.7.228:5060>

X-ZEN-Transaction: OK

Call-ID: 1278ad607dc403861d86bb831e4107d1@212.23.7.226:5060

CSeq: 102 ACK

User-Agent: Zen Internet Telephony Service

Content-Length: 0

Oct 25 16:15:11.015: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_new_msg_preprocessor: Checking Invite Dialog

Oct 25 16:15:11.023: //-1/74F528F38465/SIP/Info/sipSPIFindCcbUASRespTable: *****CCB found in UAS Response table. ccb=0x864D8764

Oct 25 16:15:11.023: //-1/xxxxxxxxxxxx/SIP/Transport/sipSPIUpdateResponseInfo: Subsq Transaction Address 212.23.7.228,Port 5060, Transport 1, SentBy Port 5060

Oct 25 16:15:11.023: //-1/xxxxxxxxxxxx/SIP/Info/sipSPISetDateHeader: Converting TimeZone BST to SIP default timezone = GMT

Oct 25 16:15:11.027: //-1/xxxxxxxxxxxx/SIP/Transport/sipSPIUpdateResponseInfo: Subsq Transaction Address 212.23.7.228,Port 5060, Transport 1, SentBy Port 5060

Oct 25 16:15:11.027: //-1/74F528F38465/SIP/State/sipSPIChangeState: 0x864D8764 : State change from (STATE_DISCONNECTING, SUBSTATE_NONE)  to (STATE_DEAD, SUBSTATE_NONE)

Oct 25 16:15:11.027: //-1/74F528F38465/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x864D8764

State of The Call        : STATE_DEAD

TCP Sockets Used         : NO

Calling Number           :

Called Number            : 012xxxxx882

Source IP Address (Sig  ): 192.168.1.254

Destn SIP Req Addr:Port  : 212.23.7.228:0

Destn SIP Resp Addr:Port : 212.23.7.228:5060

Destination Name         : 212.23.7.228

Oct 25 16:15:11.031: //-1/74F528F38465/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC)    : 100

Disconnect Cause (SIP)   : 400

Oct 25 16:15:11.031: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIDeleteContextFromTable: Context for key=[13172] removed.

Oct 25 16:15:11.031: //-1/74F528F38465/SIP/Info/sipSPIUdeleteCcbFromUASReqTable: ****Deleting from UAS Request table.

Oct 25 16:15:11.031: //-1/74F528F38465/SIP/Info/sipSPIUdeleteCcbFromTable: Deleting from table. ccb=0x864D8764 key=1278ad607dc403861d86bb831e4107d1@212.23.7.226:506001253708882

Oct 25 16:15:11.035: //-1/74F528F38465/SIP/Info/sipSPIUdeleteCcbFromUASRespTable: ****Deleting from UAS Response table.

2611xm-1#

Oct 25 16:15:11.035: //-1/74F528F38465/SIP/Info/sipSPIUdeleteCcbFromTable: Deleting from table. ccb=0x864D8764 key=1278ad607dc403861d86bb831e4107d1@212.23.7.226:50606C0F8E6F-F0B

Oct 25 16:15:11.035: //-1/74F528F38465/SIP/Info/sipSPIFlushEventBufferQueue: There are 0 events on the internal queue that are going to be free'd

Oct 25 16:15:11.039: //-1/74F528F38465/SIP/Info/sipSPIUfreeOneCCB: Freeing ccb 864D8764

Oct 25 16:15:11.039: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIGetContextFromTable: NO context for key[13172]

Please can someone help?!

Thanks!

Everyone's tags (4)
4 REPLIES

Incoming calls from SIP Trunk fails to CME

The error message 'SIP/2.0 400 Bad Request - 'Invalid Host' mostly indicates the NAT issue.

Perhaps the IP address 212.23.7.226 is not configured in any of the CME interfaces. Kindly check it.

//Suresh Please rate all the useful posts.

Re: Incoming calls from SIP Trunk fails to CME

Hi Andy.
As mentioned in many posts here in this forum, this is a tipical nat issue.
Remove static nat associaton to the Cube.
If you have multiple interface bind signaling and media to the interface leading to the internet by issuing bind all source-interface g0/0 under voice service voip -> sip.
Also under voice service voip you can add ip address trusted list
ipv4 x.x.x.x y.y.y.y (address an subnet mask)

HTH

Regards

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: Incoming calls from SIP Trunk fails to CME

I've been playing with this, and still not managed to get it working! :-(

On my 2611XM I've added:

interface Loopback0

ip address 212.23.7.227 255.255.255.255 secondary

ip address 212.23.7.226 255.255.255.255 secondary

ip address 212.23.7.228 255.255.255.255

no ip route-cache

Then changed my voice service voip to:

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

  bind control source-interface FastEthernet0/0.1

  bind media source-interface FastEthernet0/0.1

  registrar server

   outbound-proxy dns:voip.zen.co.uk

I also removed the static nat association so my NAT is now:

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.2.0 255.255.255.0 192.168.1.254

!

access-list 1 permit 192.168.0.0 0.0.255.255

In this configuration, no calls work.  If I remove the loopback interface, outgoing calls work again.

If I add the the following to the 877:

ip nat inside source static udp 192.168.1.254 5060 82.70.85.118 5060 extendable

I can get an incoming call to ring a phone, but the call can't be established (plus, there's no security on this and I can occasionally see other people try and bounce calls through my CME).

I think what I need to do is put static NAT on so I can only accept calls from 212.23.7.226/7/8 never any other addresses and forward this to my CME box, then tell the CME to ignore the loopback interfaces and send calls out via fa0/0.1 - its difficult as I'm using CME 4.1 and some commands don't work.

I supose the only other option I have is using a bridge (again with an ACL for those IP addresses) and placing an interface on the CME directly on the Internet, but this is far beyond my skills at the moment!

I'm really stuck with this now, please can someone help?!

Thanks!

New Member

Re: Incoming calls from SIP Trunk fails to CME

Anyone able to help with this one?

2436
Views
0
Helpful
4
Replies
CreatePlease to create content